aide sur une formule trouvée sur xcell05.free.fr

Le
gegebar
Bonjour,

dans un tableau de 7 colonnes et 4000 lignes où il n'y a que des nombres
de 1 à 49 (les tirages du Loto).
Tableau¡:G4000
Dans une plage, les critères (par exmple: 1,2,3,4,5,6,7)
Critères=H1:N1
Je voudrais compter:
le nombre de lignes qui contiennent les 2 premiers critères
le nombre de lignes qui contiennent les 3 premiers critères
etc.

J'ai trouvé sur xcell05.free.fr à la rubrique
Formules - Recherche de combinaisons
plusieurs formules qui correspondent à mes besoin.
Voici une de ces formules et sa description:

***********************************************************
Nombre occurrences partielles :

. Nombre de lignes contenant exactement N éléments de Cbt (dans
n'importe quel ordre) :

{=SOMME(N(FREQUENCE(SI(NB.SI(DECALER(Ref;LIGNE(Ref)-LIGNE(Pr);;1);Cbt);LIGNE(Ref));LIGNE(Ref))=N))}


Cbt = plage ou tableau (1 ligne * N colonnes) contenant la combinaison à
rechercher
Ref = plage (X lignes * N colonnes) dans laquelle on recherche cette
combinaison
Pr = première ligne de la plage Ref. Par exemple, si Ref = A2:F15, Pr =
A2:F2.
***********************************************************
Je remplace bien:
Cbt par H1:N1 - Ref par A1:G4000 - Pr par A1:G1 - N par 7
Ce qui donne:
=SOMME(7(FREQUENCE(SI(NB.SI(DECALER(A2:G4000;LIGNE(A2:G4000)-LIGNE(A2:G2);;1);I1:O1);LIGNE(A2:G4000));LIGNE(A2:G4000))=7))
Je fais bien CTRL+MAJ+ENTREE pour valider la formule matricielle
Et là excel me dit qu'il y a une erreur
et me propose une * derrière le 7:
=SOMME(7*(FREQUENCE(SI(NB.SI(DECALERLIGNE(A2:G4000));LIGNE(A2:G4000))=7))

Où ai-je fait une erreur?

merci de votre aide

gegebar
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #6792721
Réponse message précédent.



"gegebar" %
Bonjour,

dans un tableau de 7 colonnes et 4000 lignes où il n'y a que des nombres
de 1 à 49 (les tirages du Loto).
Tableau¡:G4000
Dans une plage, les critères (par exmple: 1,2,3,4,5,6,7)
Critères=H1:N1
Je voudrais compter:
le nombre de lignes qui contiennent les 2 premiers critères
le nombre de lignes qui contiennent les 3 premiers critères
etc....

J'ai trouvé sur xcell05.free.fr à la rubrique
Formules - Recherche de combinaisons
plusieurs formules qui correspondent à mes besoin.
Voici une de ces formules et sa description:

***********************************************************
Nombre occurrences partielles :

. Nombre de lignes contenant exactement N éléments de Cbt (dans
n'importe quel ordre) :

{=SOMME(N(FREQUENCE(SI(NB.SI(DECALER(Ref;LIGNE(Ref)-LIGNE(Pr);;1);Cbt);LIGNE(Ref));LIGNE(Ref))=N))}


Cbt = plage ou tableau (1 ligne * N colonnes) contenant la combinaison à
rechercher
Ref = plage (X lignes * N colonnes) dans laquelle on recherche cette
combinaison
Pr = première ligne de la plage Ref. Par exemple, si Ref = A2:F15, Pr A2:F2.
***********************************************************
Je remplace bien:
Cbt par H1:N1 - Ref par A1:G4000 - Pr par A1:G1 - N par 7
Ce qui donne:
=SOMME(7(FREQUENCE(SI(NB.SI(DECALER(A2:G4000;LIGNE(A2:G4000)-LIGNE(A2:G2);;1);I1:O1);LIGNE(A2:G4000));LIGNE(A2:G4000))=7))
Je fais bien CTRL+MAJ+ENTREE pour valider la formule matricielle
Et là excel me dit qu'il y a une erreur
et me propose une * derrière le 7:
=SOMME(7*(FREQUENCE(SI(NB.SI(DECALER......LIGNE(A2:G4000));LIGNE(A2:G4000))=7))

Où ai-je fait une erreur?

merci de votre aide

gegebar
Christophe Mathon
Le #6814451
Bonjour Gegebar,

Une macro serai a mon avie plus simple a metre en place:
<><><><><><><><><><><><><><><><>
<><><><><><><><><><><><><><><><>
Sub checkNumbers()
For Each cellp In Range(Cells(1, 8), Cells(1, 14))
nRow = 1
NumberOfCellFind = 0
Do While (nRow < 4001)
nColumn = 1
Do While (nColumn < 8)
If (Cells(nRow, nColumn) = cellp) Then
NumberOfCellFind = NumberOfCellFind + 1
End If
nColumn = nColumn + 1
Loop
nRow = nRow + 1
Loop
MsgBox "Find " & NumberOfCellFind & " Equals to: " & cellp
Next
MsgBox "end"
End Sub
<><><><><><><><><><><><><><><><>
<><><><><><><><><><><><><><><><>

Christophe Mathon

"gegebar" news:%
Bonjour,

dans un tableau de 7 colonnes et 4000 lignes où il n'y a que des nombres
de 1 à 49 (les tirages du Loto).
Tableau¡:G4000
Dans une plage, les critères (par exmple: 1,2,3,4,5,6,7)
Critères=H1:N1
Je voudrais compter:
le nombre de lignes qui contiennent les 2 premiers critères
le nombre de lignes qui contiennent les 3 premiers critères
etc....

J'ai trouvé sur xcell05.free.fr à la rubrique
Formules - Recherche de combinaisons
plusieurs formules qui correspondent à mes besoin.
Voici une de ces formules et sa description:

***********************************************************
Nombre occurrences partielles :

. Nombre de lignes contenant exactement N éléments de Cbt (dans n'importe
quel ordre) :

{=SOMME(N(FREQUENCE(SI(NB.SI(DECALER(Ref;LIGNE(Ref)-LIGNE(Pr);;1);Cbt);LIGNE(Ref));LIGNE(Ref))=N))}

Cbt = plage ou tableau (1 ligne * N colonnes) contenant la combinaison à
rechercher
Ref = plage (X lignes * N colonnes) dans laquelle on recherche cette
combinaison
Pr = première ligne de la plage Ref. Par exemple, si Ref = A2:F15, Pr =
A2:F2.
***********************************************************
Je remplace bien:
Cbt par H1:N1 - Ref par A1:G4000 - Pr par A1:G1 - N par 7
Ce qui donne:
=SOMME(7(FREQUENCE(SI(NB.SI(DECALER(A2:G4000;LIGNE(A2:G4000)-LIGNE(A2:G2);;1);I1:O1);LIGNE(A2:G4000));LIGNE(A2:G4000))=7))
Je fais bien CTRL+MAJ+ENTREE pour valider la formule matricielle
Et là excel me dit qu'il y a une erreur
et me propose une * derrière le 7:
=SOMME(7*(FREQUENCE(SI(NB.SI(DECALER......LIGNE(A2:G4000));LIGNE(A2:G4000))=7))

Où ai-je fait une erreur?

merci de votre aide

gegebar






Publicité
Poster une réponse
Anonyme