Aide moyenne Si

Le
mattparisien59
Bonjour,

Sur la ligne 3, j'ai les jours L, M, Mer, J, V, S, L, M,Mer,J,V,S,..(plage allant de C3 jusque HI). qui sont en fonction de la date de la case d'en dessous. A la ligne 13, j'ai le chiffre d'affaire de chaque jour. Dans un tableau à part j'aimerais avoir la moyenne automatique du chiffre d'affaire en fonction des différents jours (une moyenne pour tous les lundi, une pour tous les mardis,.) à chaque fois que je rentre une nouvelle saisie pour un nouveau jour. donc des cellules soit différents de 0 et vides.
Je souhaiterais savoir s'il est judicieux de faire soit un code VB ou une fonction excel pour l'exemple proposé et serait il possible d'en donner soit la formule ou le code VB svp Merci d'avance pour votre aide.
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21647851
Bonjour.
Avec les jours en A16:A21, la formule en B16 est :
=SOMMEPROD(($C$3:$HI$3=$A16)*$C$13:$HI$13)/SOMMEPROD(N($C$3:$HI$3=$A16))
à recopier vers le bas.
Cordialement.
Daniel

Bonjour,

Sur la ligne 3, j'ai les jours L, M, Mer, J, V, S, L, M,Mer,J,V,S,.....(plage
allant de C3 jusque HI). qui sont en fonction de la date de la case d'en
dessous. A la ligne 13, j'ai le chiffre d'affaire de chaque jour. Dans un
tableau à part j'aimerais avoir la moyenne automatique du chiffre d'affaire
en fonction des différents jours (une moyenne pour tous les lundi, une pour
tous les mardis,....) à chaque fois que je rentre une nouvelle saisie pour
un nouveau jour. donc des cellules soit différents de 0 et vides.
Je souhaiterais savoir s'il est judicieux de faire soit un code VB ou une
fonction excel pour l'exemple proposé et serait il possible d'en donner soit
la formule ou le code VB svp Merci d'avance pour votre aide.
Publicité
Poster une réponse
Anonyme