Ajouter des années à une date

Le
Denys
Bonjour,

Dans la colonne A j'ai différentes dates format AAAA/MM/JJ.
Je voudrais en colonne B une formule qui dirait:
Si l'année en A1 = 2006 alors le résultat est 2006/11/01, sinon, le r=
ésultat est l'année en A1 + 3 et toujours 11/01. Donc, si j'ai 2007/=
05/28 en A1, alors le résultat en B1 devrait être 2010/11/01.

Merci pour votre temps

Denys
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #26340949
Bonjour,
En B1 :
=SI(ANNEE(A1) 06;"2006/11/1"*1;MOIS.DECALER(A1;36))
Cordialement.
Daniel


Bonjour,

Dans la colonne A j'ai différentes dates format AAAA/MM/JJ.
Je voudrais en colonne B une formule qui dirait:
Si l'année en A1 = 2006 alors le résultat est 2006/11/01, sinon, le résultat
est l'année en A1 + 3 et toujours 11/01.... Donc, si j'ai 2007/05/28 en A1,
alors le résultat en B1 devrait être 2010/11/01.

Merci pour votre temps

Denys
Denys
Le #26340965
Le mercredi 25 février 2015 08:57:34 UTC-5, DanielCo a écrit :
Bonjour,
En B1 :
=SI(ANNEE(A1) 06;"2006/11/1"*1;MOIS.DECALER(A1;36))
Cordialement.
Daniel



Bonjour Daniel

Excel me retourne une erreur...VBA !!!
=IF(YEAR(A1) 06,"2006/11/1"*1,month.offset(A1,36))

Denys
DanielCo
Le #26340971
[B1].Formula = "=IF(YEAR(A1) 06," & """1/11/2006""" &
"*1,EDATE(A1,36))"
Daniel


Le mercredi 25 février 2015 08:57:34 UTC-5, DanielCo a écrit :
Bonjour,
En B1 :
=SI(ANNEE(A1) 06;"2006/11/1"*1;MOIS.DECALER(A1;36))
Cordialement.
Daniel



Bonjour Daniel

Excel me retourne une erreur...VBA !!!
=IF(YEAR(A1) 06,"2006/11/1"*1,month.offset(A1,36))

Denys
Denys
Le #26340975
Le mercredi 25 février 2015 11:17:23 UTC-5, DanielCo a écrit :
[B1].Formula = "=IF(YEAR(A1) 06," & """1/11/2006""" &
"*1,EDATE(A1,36))"
Daniel


> Le mercredi 25 février 2015 08:57:34 UTC-5, DanielCo a écrit :
>> Bonjour,
>> En B1 :
>> =SI(ANNEE(A1) 06;"2006/11/1"*1;MOIS.DECALER(A1;36))
>> Cordialement.
>> Daniel
>
> Bonjour Daniel
>
> Excel me retourne une erreur...VBA !!!
> =IF(YEAR(A1) 06,"2006/11/1"*1,month.offset(A1,36))
>
> Denys



Bonjour Daniel,

Merci beaucoup...ne me reste qu'à toujours avoir le 1er novembre comme da te d'arrivée.

Très aimable...j'apprécie beaucoup

Bonne journée

Denys
Denys
Le #26340974
Voici

=IF(YEAR(A1) 06," & ""1/11/2006"" &
"*1,DATE(YEAR(EDATE(A1,36)),11,1))

Merci encore !!!
DanielCo
Le #26340973
Alors, plutôt :
=IF(YEAR(A1) 06," & ""1/11/2006"" & "*1,DATE(YEAR(A1)+3,11,1))
Daaniel



=IF(YEAR(A1) 06," & ""1/11/2006"" &
"*1,DATE(YEAR(EDATE(A1,36)),11,1))
Denys
Le #26340986
Le mercredi 25 février 2015 11:43:16 UTC-5, DanielCo a écrit :
Alors, plutôt :
=IF(YEAR(A1) 06," & ""1/11/2006"" & "*1,DATE(YEAR(A1)+3,11,1))
Daaniel



> =IF(YEAR(A1) 06," & ""1/11/2006"" &
> "*1,DATE(YEAR(EDATE(A1,36)),11,1))



Encore mieux !!!

merci ! :-)
Publicité
Poster une réponse
Anonyme