Alsa et /etc/asound.conf

Le
JKB
Bonjour à tous,

Je suis en train d'essayer de configurer alsa sur un Thinkpad Edge
E325. J'arrive à envoyer un son sur les hauts-parleurs, mais pas à
utiliser directement wmmixer parce que la carte par défaut n'est pas
la bonne.

Root riemann:[/etc] > cat /proc/asound/cards
0 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xf0344000 irq 44
1 [SB ]: HDA-Intel - HDA ATI SB
HDA ATI SB at 0xf0340000 irq 16
29 [ThinkPadEC ]: ThinkPad EC - ThinkPad Console Audio Control
ThinkPad Console Audio Control at EC reg 0x30, fw unknown
Root riemann:[/etc] >

La carte qui répond aux commandes de volume est la SB. J'ai donc
ouvert la doc d'alsa ét écrit :

Root riemann:[/etc] > cat /etc/asound.conf
pcm.!default {
type hw
card SB
}
ctl.!default {
type hw
card SB
}

L'ennui est que ce fichier ne semble pas pris en compte puisqu'au
reboot suivant, j'ai toujours les mêmes cartes dansle même ordre.

Qu'ai-je raté ?

Merci de vos lumières,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse
=> http://grincheux.de-charybde-en-scylla.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #25035752
JKB , dans le message écrit :
L'ennui est que ce fichier ne semble pas pris en compte puisqu'au
reboot suivant, j'ai toujours les mêmes cartes dansle même ordre.



Tu parles de l'ordre dans /proc/asound/cards ? C'est l'ordre vu par le
noyau, on voit mal comment la configuration d'une bibliothèque pourrait
l'influencer.

Que se passe-t-il si tu essaies avec alsamixer ? L'explication la plus
plausible à ton problème est un bug de wmmixer.
Publicité
Poster une réponse
Anonyme