apt-get autoremove trop conséquent

Le
andre_debian
J'ai installé le bureau TDE (Trinity DEsktop) sous wheezy.

Lors de l'installation d'un paquet, apt-get me propose
de faire "apt-get autoremove"
afin de désinstaller moultes paquets, pourtant très utiles
comportant le nom "trinity".

Ceci mettrait en péril le bureau et pourquoi me propose t-il
ces suppressions ?

N'y a t-il pas moyen de le dire à apt-get ?

Merci

André

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/201308291826.31909.andre_debian@numericable.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
stephane.gargoly
Le #25620492
Bonjour à tous les utilisateurs et développeurs de Debian :

Dans son message du 29/08/13 à 18:26, a écrit :
J'ai installé le bureau TDE (Trinity DEsktop) sous wheezy.



Tiens, un nostalgique de KDE 3.5... ;-)

Lors de l'installation d'un paquet, apt-get me propose
de faire "apt-get autoremove"
afin de désinstaller moultes paquets, pourtant très utiles
comportant le nom "trinity".



As-tu pensé à regarder le manuel de apt-get ?

Extrait de "man apt-get" :
"Avec la commande autoremove, apt-get supprime les paquets installés d ans le but de satisfaire les dépendances d'un paquet donné et qui ne sont plus nécessaires"

Cordialement et à bientôt,

Stéphane.



Une messagerie gratuite, garantie à vie et des services en plus, à §a vous tente ?
Je crée ma boîte mail www.laposte.net

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25620462
On Thursday 29 August 2013 19:14:21 wrote:
Bonjour à tous les utilisateurs et développeurs de Debian :
Dans son message du 29/08/13 à 18:26, a écrit :
> J'ai installé le bureau TDE (Trinity DEsktop) sous wheezy.
> Lors de l'installation d'un paquet, apt-get me propose
> de faire "apt-get autoremove"
> afin de désinstaller moultes paquets, pourtant très utiles
> comportant le nom "trinity".

Tiens, un nostalgique de KDE 3.5... ;-) :


Ça ne dépend pas de moi.

As-tu pensé à regarder le manuel de apt-get ?


Oui et inutile de le rappeler.

Extrait de "man apt-get" :
"Avec la commande autoremove, apt-get supprime les paquets installés dans
le but de satisfaire les dépendances d'un paquet donné et qui n e sont plus
nécessaires"
Cordialement et à bientôt, Stéphane :



"apt-get autoremove" propose de désinstaller des paquets qui
ne sont pas des dépendances mais des applis qui, si supprimées,
empêcheront ensuite le bureau de se lancer.

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25620512
On Thursday 29 August 2013 19:23:42 wrote:
On Thursday 29 August 2013 19:14:21 wrote:

> > J'ai installé le bureau TDE (Trinity DEsktop) sous wheezy.
> > Lors de l'installation d'un paquet, apt-get me propose
> > de faire "apt-get autoremove"
> > afin de désinstaller moultes paquets, pourtant très utiles
> > comportant le nom "trinity".

> Extrait de "man apt-get" :
> "Avec la commande autoremove, apt-get supprime les paquets installà ©s dans
> le but de satisfaire les dépendances d'un paquet donné et qui ne sont
> plus nécessaires"
> Cordialement et à bientôt, Stéphane :

"apt-get autoremove" propose de désinstaller des paquets qui
ne sont pas des dépendances mais des applis qui, si supprimées,
empêcheront ensuite le bureau de se lancer.
andré



J'ai trouvé cette solution :
# apt-mark unmarkauto <paquets-à-ne-pas-désinstaller>

et si on a des regrets :
# apt-mark markauto <paquets-à-ne-pas-désinstaller>

donc sans trop de danger.

André




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
stephane.gargoly
Le #25620632
Bonjour à tous les utilisateurs et développeurs de Debian :

Dans son message du 29/08/13 à 19:24, a écrit :
On Thursday 29 August 2013 19:14:21 wrote:
> As-tu pensé à regarder le manuel de apt-get ?
Oui et inutile de le rappeler.



D'accord mais au moment où tu as lancé ce fil de discussion, tu m 'es apparu comme, pour le moins, interrogatif quand apt-get te propose de s upprimer ce que Apt considère comme des dépendances (devenues, to ujours selon Apt, inutiles) même si, toi, tu les prends comme des appl ications...

Mais peut-être que c'est moi qui ait "sur-interprété" ta r éaction. ;-)

"apt-get autoremove" propose de désinstaller des paquets qui
ne sont pas des dépendances mais des applis qui, si supprimées,
empêcheront ensuite le bureau de se lancer.



Dans son message du 29/08/13 à 19:42, a écrit :
J'ai trouvé cette solution :
# apt-mark unmarkauto


et si on a des regrets :
# apt-mark markauto


donc sans trop de danger.



Parfait. Reste à savoir pourquoi les paquets issus de Trinity ont à ©té initialement marqués comme installés automatiquement ( comme s'ils étaient des dépendances d'un paquet qu'on aurait aupa ravant désinstallé ou purgé)...

Cordialement et à bientôt,

Stéphane.



Une messagerie gratuite, garantie à vie et des services en plus, à §a vous tente ?
Je crée ma boîte mail www.laposte.net

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
François Boisson
Le #25620662
Le Thu, 29 Aug 2013 19:23:42 +0200
a écrit:

"apt-get autoremove" propose de désinstaller des paquets qui
ne sont pas des dépendances mais des applis qui, si supprimées,
empêcheront ensuite le bureau de se lancer.




Simple tu as fait

# apt-get install kde
(meta paquet)

puis pour des raisons diverses qui te egardent, tu as supprimé un des paquets
de kde qui a entrainé la suppression de ce meta paquet. Du coup tous les
paquets de kde, ibnstallés par dépendance au meta paquet, passent en
autoremove.

Voilà voilà.

Je te dirais bien de passer à XFCE mais je sens que l'ambiance n'y est pas...

François Boisson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Johnny B
Le #25620642
Salut,

apt-get autoremove est sensé supprimer des packages qui ne sont plus
nécessaires au fonctionnement du système. autoremove ne break pas les
dépendances.

Lorsqu'un package est installé il dispose de "marqueurs" qui le
définissent "manuel" ou "auto" tu as donc fais des manipulations de
packages qui font que certains ne sont plus nécessaires au
fonctionnement du système ou autre appli.

Les packages que ton système veut supprimer ce sont des dépendances
installées automatiquement. Il faut donc que ces dépendances aient des
tag "manuels" pour ne pas faire parti du clean autoremove et donc il
faut les installer à la main.

En revanche c'est plus étrange que ton système te propose de supprimer
des dépendances que tu viens d'installer... il y a quelque chose qui
cloche dans le déroulement de l'installation de tes packages ;)


Le 08/29/2013 06:26 PM, a écrit :
J'ai installé le bureau TDE (Trinity DEsktop) sous wheezy.

Lors de l'installation d'un paquet, apt-get me propose
de faire "apt-get autoremove"
afin de désinstaller moultes paquets, pourtant très utiles
comportant le nom "trinity".

Ceci mettrait en péril le bureau et pourquoi me propose t-il
ces suppressions ?

N'y a t-il pas moyen de le dire à apt-get ?

Merci

André




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25620672
On Thursday 29 August 2013 20:44:23 wrote:
Dans son message du 29/08/13 à 19:24, a écrit :
> On Thursday 29 August 2013 19:14:21 wrote:
> > As-tu pensé à regarder le manuel de apt-get ?

> Oui et inutile de le rappeler.

D'accord mais au moment où tu as lancé ce fil de discussion, tu m'es apparu
comme, pour le moins, interrogatif quand apt-get te propose de supprimer ce
que Apt considère comme des dépendances (devenues, toujours sel on Apt,
inutiles) même si, toi, tu les prends comme des applications...
Mais peut-être que c'est moi qui ait "sur-interprété" ta r éaction. ;-)



Oui, c'est bien ça ! => pas grave.

> J'ai trouvé cette solution :
> # apt-mark unmarkauto
> et si on a des regrets :
> # apt-mark markauto
> donc sans trop de danger.

Parfait. Reste à savoir pourquoi les paquets issus de Trinity ont été
initialement marqués comme installés automatiquement (comme s'i ls étaient
des dépendances d'un paquet qu'on aurait auparavant désinstall é ou
purgé)...
Stéphane.

puis pour des raisons diverses qui te egardent, tu as supprimé un des
paquets de kde qui a entrainé la suppression de ce meta paquet. Du c oup
tous les paquets de kde, ibnstallés par dépendance au meta paqu et, passent
en autoremove. Voilà voilà.
Je te dirais bien de passer à XFCE mais je sens que l'ambiance n'y e st pas...
François Boisson



L'ambiance est bonne mais c'est vrai que XFCE, KDE4 ... ne tiltent pas trop
chez moi.
TDE est un bon compromis entre KDE4 (un peu lourd) et XFCE (un peu lég er).
"Chacun voit midi à sa porte" :-)

En revanche c'est plus étrange que ton système te propose de su pprimer
des dépendances que tu viens d'installer... il y a quelque chose qui
cloche dans le déroulement de l'installation de tes packages ;)



Sur 2 PC, la migration Squeeze => Wheezy s'est bien passée
et moins bien la 3ème.
Je pense que des paquets KDE4 étaient installés ou des applis
liées à KDE4 comme audacious, amarok, mplayer etc ...
Ils existent des versions spécifiques à TDE.
apt-get interprète alors que certaines applis n'ont plus à ê tre installées.

Merci de vos réponses et j'ai découvert la commande "apt-mark (un )markauto"
qui peut servir à d'autres ici.

andré

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Johnny B
Le #25620692
Le 08/29/2013 09:28 PM, a écrit :
On Thursday 29 August 2013 20:44:23 wrote:
Dans son message du 29/08/13 à 19:24, a écrit :
On Thursday 29 August 2013 19:14:21 wrote:
As-tu pensé à regarder le manuel de apt-get ?


Oui et inutile de le rappeler.


D'accord mais au moment où tu as lancé ce fil de discussion, tu m'es apparu
comme, pour le moins, interrogatif quand apt-get te propose de supprimer ce
que Apt considère comme des dépendances (devenues, toujours selon Apt,
inutiles) même si, toi, tu les prends comme des applications...
Mais peut-être que c'est moi qui ait "sur-interprété" ta réaction. ;-)


Oui, c'est bien ça ! => pas grave.

J'ai trouvé cette solution :
# apt-mark unmarkauto
et si on a des regrets :
# apt-mark markauto
donc sans trop de danger.


Parfait. Reste à savoir pourquoi les paquets issus de Trinity ont été
initialement marqués comme installés automatiquement (comme s'ils étaient
des dépendances d'un paquet qu'on aurait auparavant désinstallé ou
purgé)...
Stéphane.
puis pour des raisons diverses qui te egardent, tu as supprimé un des
paquets de kde qui a entrainé la suppression de ce meta paquet. Du coup
tous les paquets de kde, ibnstallés par dépendance au meta paquet, passent
en autoremove. Voilà voilà.
Je te dirais bien de passer à XFCE mais je sens que l'ambiance n'y est pas...
François Boisson


L'ambiance est bonne mais c'est vrai que XFCE, KDE4 ... ne tiltent pas trop
chez moi.
TDE est un bon compromis entre KDE4 (un peu lourd) et XFCE (un peu léger).
"Chacun voit midi à sa porte" :-)

En revanche c'est plus étrange que ton système te propose de supprimer
des dépendances que tu viens d'installer... il y a quelque chose qui
cloche dans le déroulement de l'installation de tes packages ;)


Sur 2 PC, la migration Squeeze => Wheezy s'est bien passée




Et du coup le fil de la discussion est perdu sur tes 2 posts on y
comprend plus rien


et moins bien la 3ème.
Je pense que des paquets KDE4 étaient installés ou des applis
liées à KDE4 comme audacious, amarok, mplayer etc ...
Ils existent des versions spécifiques à TDE.
apt-get interprète alors que certaines applis n'ont plus à être installées.

Merci de vos réponses et j'ai découvert la commande "apt-mark (un)markauto"
qui peut servir à d'autres ici.

andré

andré




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
stephane.gargoly
Le #25620712
Bonjour à tous les utilisateurs et développeurs de Debian :

Dans son message du 29/08/13 à 21:29, François Boisson a écr it :
Le Thu, 29 Aug 2013 19:23:42 +0200
a écrit:
> "apt-get autoremove" propose de désinstaller des paquets qui
> ne sont pas des dépendances mais des applis qui, si supprimée s,
> empêcheront ensuite le bureau de se lancer.

Simple tu as fait

# apt-get install kde
(meta paquet)

puis pour des raisons diverses qui te egardent, tu as supprimé un de s paquets
de kde qui a entrainé la suppression de ce meta paquet. Du coup tous les
paquets de kde, ibnstallés par dépendance au meta paquet, passe nt en
autoremove.



Sauf que Trinity n'est pas KDE 4 et ne fait même pas partie de Debian - André a du se procurer son environnement de bureau préfér é sur le site http://www.trinitydesktop.org/ - donc, à priori, le fait d'installer ou de désinstaller un paquet (issu de KDE) ne devrai t pas avoir d'influence sur les paquets Trinity...

D'ailleurs, je me demande même s'il ne devrait pas avoir un problà ¨me de conflit entre KDE et Trinity si on cherche à installer tous l es deux en même temps.

Peut-être qu'André peut-il répondre à cette interrogati on ?

Pour information, je suis sous KDE 4 fourni par Debian. ;-)

Cordialement et à bientôt,

Stéphane.



Une messagerie gratuite, garantie à vie et des services en plus, à §a vous tente ?
Je crée ma boîte mail www.laposte.net

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
andre_debian
Le #25620812
On Thursday 29 August 2013 21:59:03 wrote:
Bonjour à tous les utilisateurs et développeurs de Debian :

Sauf que Trinity n'est pas KDE 4 et ne fait même pas partie de Debia n -
André a du se procurer son environnement de bureau préfér é sur le site
http://www.trinitydesktop.org/ - donc, à priori, le fait d'installer ou de
désinstaller un paquet (issu de KDE) ne devrait pas avoir d'influenc e sur
les paquets Trinity...

D'ailleurs, je me demande même s'il ne devrait pas avoir un problà ¨me de
conflit entre KDE et Trinity si on cherche à installer tous les deux en
même temps.
Peut-être qu'André peut-il répondre à cette interroga tion ?
Pour information, je suis sous KDE 4 fourni par Debian. ;-)
Cordialement et à bientôt, Stéphane.



Le bureau Trinity (TDE) fait partie des packages Debian et encore sous Whee zy.

Il fallait taper avant : # apt-cache search trinity

On peut installer les 2 bureaux puisque les applis TDE contiennent toujours
"trinity" : ex. kmail-trinity

andré

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme