arrondi d'heures

Le
C15
Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que si
les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le bilan
est arrondi à l'heure inférieure (ici 01:00) alors que si elles sont
supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30 (ici
01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures à
01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule seuls
les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent, les bilans
égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
dre
Le #4315091
Bonjour,

A essayer :
Une valeur en A1
=ARRONDI.INF(A1*48;0)/48

... ou bien j'ai rien compris.

Â+





Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que si
les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le bilan
est arrondi à l'heure inférieure (ici 01:00) alors que si elles sont
supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30 (ici
01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures à
01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule seuls
les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent, les bilans
égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15





C15
Le #4315051
bonjour,

Pour toi à quoi correspond la cellule A1 ?

Merci de ton aide

A+

C15
"dre"
Bonjour,

A essayer :
Une valeur en A1
=ARRONDI.INF(A1*48;0)/48

... ou bien j'ai rien compris.

Â+





Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que
si
les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le
bilan
est arrondi à l'heure inférieure (ici 01:00) alors que si elles sont
supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30 (ici
01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures
à
01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule
seuls
les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent, les
bilans
égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15







dre
Le #4315041
Bonjour,

En A1 : une valeur horaire, ou le résuluat d'une formule en format horaire.

Â+



bonjour,

Pour toi à quoi correspond la cellule A1 ?

Merci de ton aide

A+

C15
"dre"
Bonjour,

A essayer :
Une valeur en A1
=ARRONDI.INF(A1*48;0)/48

... ou bien j'ai rien compris.

Â+





Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que
si
les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le
bilan
est arrondi à l'heure inférieure (ici 01:00) alors que si elles sont
supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30 (ici
01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures
à
01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule
seuls
les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent, les
bilans
égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15












Sibusate
Le #4315011
Les heures:minutes:secondes étant en fait un nombre égal à 1/24ème d'une
journée, il me semble plus facile de multiplier la valeur du nombre
d'heures et de minutes par 24 dans une autre cellule mise en format
nombre sans aucune décimale....
Autrement dit : déclarer une cellule L2C2 (où tu veux) en format nombre
avec 0 décimale et y inscrire la formule =L1C1*24 (L1C1 = cellule
contenant le résultat horaire.... en format Heures:minutes

Tout simplement
Si cela peut t'aider....
François

Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que si
les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le bilan
est arrondi à l'heure inférieure (ici 01:00) alors que si elles sont
supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30 (ici
01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures à
01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule seuls
les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent, les bilans
égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15




C15
Le #4314961
bonsoir à tous les deux,

Merci de vos 2 réponses complémentaires.

La fonction arrondi.inf semble effectivement répondre à mon besoin, il
suffit que je la combine autrement pour lever le problème des heures
négatives.
Au lieu d'une formule usine à gaz, il fallait penser tout bêtement que 30
mn=1/48ième de journée.

A+

C15
"Sibusate"
Les heures:minutes:secondes étant en fait un nombre égal à 1/24ème d'une
journée, il me semble plus facile de multiplier la valeur du nombre
d'heures et de minutes par 24 dans une autre cellule mise en format nombre
sans aucune décimale....
Autrement dit : déclarer une cellule L2C2 (où tu veux) en format nombre
avec 0 décimale et y inscrire la formule =L1C1*24 (L1C1 = cellule
contenant le résultat horaire.... en format Heures:minutes

Tout simplement
Si cela peut t'aider....
François

Bonjour à tous et à toutes.

J'ai un tableau pour suivre les heures de travail.
En D1 j'ai la journée de référence (par exemple 08:30)
En E4, j'ai le temps de travail (départ - arrivée).
En ligne 4 je veux calculer le bilan des heures travaillées en disant que
si les minutes du bilan (par ex 01:27, donc 27) sont inférieures à 29, le
bilan est arrondi à l'heure inférieure (ici 01:00) alors que si elles
sont supérieures ou égales à 30 (par ex 01:42), elles sont arrondies à 30
(ici 01:30).

En m'inspirant du post de 03/02/07 16:42, j'ai fait la formule suivante :

=SI(ESTERREUR(SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440));"";SI(MINUTE(E4-$D$1)>0;E4-$D$1-(MINUTE(E4-$D$1)-30)/1440;E4-$D$1-(MINUTE(E4-$D$1))/1440))

Globalement cela marche SAUF pour CERTAINES valeurs de bilan inférieures
à 01:00.
Si l'on se limite à saisir les heures de 5mn en 5mn, dans ma formule
seuls les bilans égaux à 00:00 et 00:25 puis de 00:30 à 00:55 marchent,
les bilans égaux à 00:05, 00:10, 00:15, 00:20 ne marchent pas.

Je n'arrive pas à voir où cela coince.

Merci de votre aide

A+

C15





Publicité
Poster une réponse
Anonyme