Base polluée ?

Le
Didier Bicking
Bonjour,



J'ai un problème avec une base de données en Access 2000. Cette base est en
fonctionnement sur plusieurs postes. Les tables de cette base son liées sur
une autre base de données située sur le serveur local, de sorte que tous les
postes travaillent sur les mêmes données.



Le poste sur lequel je travaille est consacré au développement. Avant de
faire quoi que ce soit, je copie la base avec les données du serveur sur mon
disque dur, de sorte que je peux faire des simulations sans endommager les
données réelles sur lesquelles travaillent les gestionnaires.



J'ai donc deux bases :

- Une base « programme » présente sur chaque poste

- Une base « données » sur laquelle pointent toutes les bases «
programme ».



Dans la base « programme », un formulaire est intitulé «
ExploitationListeMAJ ». Ce formulaire fonctionne de manière satisfaisante
sur chacun des postes. Lorsque je vais sur l'un des postes de gestionnaires,
je peux ouvrir ce formulaire en mode création ou l'utiliser normalement en
mode formulaire. Jusque là, tout va bien.



Depuis plusieurs jours se produit un phénomène étrange :

- Je copie la base « programme » du post d'un gestionnaire sur mon
post de développement. Je peux alors accéder correctement au formulaire «
ExploitationListeMAJ » comme à tous les autres formulaires (environ 200
formulaires)

- J'ouvre cette base et, utilisant le gestionnaire des tables liées,
je modifie toutes les liaisons de tables pour qu'elles pointent sur les
données copiées sur mon disque dur

- Je relance la base « programme »



Je ne peux alors plus accéder au formulaire « ExploitationListeMaj », quel
que soit le mode, formulaire ou création. A chaque tentative d'accès, j'obtiens
un message m'informant qu'Access a rencontré une erreur et doit fermer. Une
procédure de réparation automatique se met alors en marche, mais qui ne
donne rien, le problème d'accès à ce formulaire subsiste. Et, franchement,
ça m'embêterait beaucoup d'avoir à refaire ce formulaire qui est complexe et
comporte beaucoup de programmation. J'espère que le problème ne s'est pas
propagé sur d'autres formulaires, je n'ai pas encore eu le temps de tester
cela.



Je précise que, sur mon poste, c'est Access 2003 qui est installé mais les
bases « programme » et « données » sont au format Access 2000 car les postes
de gestionnaires sont restés en Access 2000.



Si vous avez déjà rencontré ce genre de problème, je serais très heureux de
vous lire. Surtout si vous avez une solution.



Merci d'avance.


--
Didier Bicking
dbicking@wanadoo.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #18709901
Salut Didier,

Toujours dans Access ? ;-)


Si tu te crées une nouvelle base vide, arrives-tu à importer ce formulaire
sans problème ? l'éventuel code est bien en place ?


--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)





"Didier Bicking"
| J'ai un problème avec une base de données en Access 2000. Cette base est en
| fonctionnement sur plusieurs postes. Les tables de cette base son liées sur
| une autre base de données située sur le serveur local, de sorte que tous les
| postes travaillent sur les mêmes données.
|
|
|
| Le poste sur lequel je travaille est consacré au développement. Avant de
| faire quoi que ce soit, je copie la base avec les données du serveur sur mon
| disque dur, de sorte que je peux faire des simulations sans endommager les
| données réelles sur lesquelles travaillent les gestionnaires.
|
|
|
| J'ai donc deux bases :
|
| - Une base « programme » présente sur chaque poste
|
| - Une base « données » sur laquelle pointent toutes les bases «
| programme ».
|
|
|
| Dans la base « programme », un formulaire est intitulé «
| ExploitationListeMAJ ». Ce formulaire fonctionne de manière satisfaisante
| sur chacun des postes. Lorsque je vais sur l'un des postes de gestionnaires,
| je peux ouvrir ce formulaire en mode création ou l'utiliser normalement en
| mode formulaire. Jusque là, tout va bien.
|
|
|
| Depuis plusieurs jours se produit un phénomène étrange :
|
| - Je copie la base « programme » du post d'un gestionnaire sur mon
| post de développement. Je peux alors accéder correctement au formulaire «
| ExploitationListeMAJ » comme à tous les autres formulaires (environ 200
| formulaires)
|
| - J'ouvre cette base et, utilisant le gestionnaire des tables liées,
| je modifie toutes les liaisons de tables pour qu'elles pointent sur les
| données copiées sur mon disque dur
|
| - Je relance la base « programme »
|
|
|
| Je ne peux alors plus accéder au formulaire « ExploitationListeMaj », quel
| que soit le mode, formulaire ou création. A chaque tentative d'accès, j'obtiens
| un message m'informant qu'Access a rencontré une erreur et doit fermer. Une
| procédure de réparation automatique se met alors en marche, mais qui ne
| donne rien, le problème d'accès à ce formulaire subsiste. Et, franchement,
| ça m'embêterait beaucoup d'avoir à refaire ce formulaire qui est complexe et
| comporte beaucoup de programmation. J'espère que le problème ne s'est pas
| propagé sur d'autres formulaires, je n'ai pas encore eu le temps de tester
| cela.
|
|
|
| Je précise que, sur mon poste, c'est Access 2003 qui est installé mais les
| bases « programme » et « données » sont au format Access 2000 car les postes
| de gestionnaires sont restés en Access 2000.
|
|
|
| Si vous avez déjà rencontré ce genre de problème, je serais très heureux de
| vous lire. Surtout si vous avez une solution.
|
|
|
| Merci d'avance.
|
|
| --
| Didier Bicking
|
|
|
Publicité
Poster une réponse
Anonyme