Beaucoup de pb de son depuis le dernier update de pulse :(

Le
C. Mourad Jaber
Bonjour,

J'ai plusieurs problèmes de son depuis le dernier update de pulse audio

Tous les softs utilisant le serveur de son de KDE fonctionne bien, par
contre, plus rien d'autre, je n'ai plus de son pour vlc, mplayer, flash,
virtualbox, pour ceux que j'ai testé !

Y'a-t-il des modifications à faire quelque part pour réactiver le son
sur les logiciels non kde ?

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/4C2C9304.7030504@nativobject.net
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
C. Mourad Jaber
Le #22322131
Le 01/07/2010 15:07, C. Mourad Jaber a écrit :
Bonjour,

J'ai plusieurs problèmes de son depuis le dernier update de pulse
audio...

Tous les softs utilisant le serveur de son de KDE fonctionne bien, par
contre, plus rien d'autre, je n'ai plus de son pour vlc, mplayer,
flash, virtualbox, pour ceux que j'ai testé !

Y'a-t-il des modifications à faire quelque part pour réactiver le son
sur les logiciels non kde ?

++

Mourad



J'ai pas beaucoup avancé sur ce problème, mais il semble que le backend
xine fonctionne (c'est ce qu'utilise KDE), part contre gstreamer semble
incapable d'émettre le moindre son :(

Y'a-t-il moyen de diagnostiquer quelque chose dans l'infrastructure de
son ? je ne vois pas de log particulier...

Le truc qui me semble curieux, c'est que je n'ai aucun outil alsa, mais
des outils esound !

Est-ce que le jeu des dépendances m'aurait trahi ?

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
C. Mourad Jaber
Le #22330381
Le 02/07/2010 14:12, C. Mourad Jaber a écrit :
Le 01/07/2010 15:07, C. Mourad Jaber a écrit :
Bonjour,

J'ai plusieurs problèmes de son depuis le dernier update de pulse
audio...

Tous les softs utilisant le serveur de son de KDE fonctionne bien,
par contre, plus rien d'autre, je n'ai plus de son pour vlc, mplayer,
flash, virtualbox, pour ceux que j'ai testé !

Y'a-t-il des modifications à faire quelque part pour réactiver le son
sur les logiciels non kde ?

++

Mourad



J'ai pas beaucoup avancé sur ce problème, mais il semble que le
backend xine fonctionne (c'est ce qu'utilise KDE), part contre
gstreamer semble incapable d'émettre le moindre son :(

Y'a-t-il moyen de diagnostiquer quelque chose dans l'infrastructure de
son ? je ne vois pas de log particulier...

Le truc qui me semble curieux, c'est que je n'ai aucun outil alsa,
mais des outils esound !

Est-ce que le jeu des dépendances m'aurait trahi ?

++

Mourad


Je suis surpris que personne ne semble avoir le problème que je rencontre :(

J'essais de me dépatouiller de l'infrastructure son, mais je n'y
comprends plus rien !

Pourquoi tous ces composants ? quel est leur rôle (phonon, les divers
backend, pulseaudio, esound, alsa...) ? et comment identifier un
problème dans ces multiples couches logiciels ?

A partir de là, je pourrai avancer, mais pour l'instant, je suis dans le
flou le plus total !

Si quelqu'un peut un peu éclairer ma lanterne, pour que je puisse savoir
ce qu'il se passe, ce serait un bon début !

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Klaus Becker
Le #22330451
Le lundi 05 juillet 2010 17:08:25, C. Mourad Jaber a écrit :
Le 02/07/2010 14:12, C. Mourad Jaber a écrit :
> Le 01/07/2010 15:07, C. Mourad Jaber a écrit :
>> Bonjour,
>>
>> J'ai plusieurs problèmes de son depuis le dernier update de pulse
>> audio...
>>
>> Tous les softs utilisant le serveur de son de KDE fonctionne bien,
>> par contre, plus rien d'autre, je n'ai plus de son pour vlc, mplayer,
>> flash, virtualbox, pour ceux que j'ai testé !
>>
>> Y'a-t-il des modifications à faire quelque part pour réactiv er le son
>> sur les logiciels non kde ?
>>
>> ++
>>
>> Mourad




Salut,

essaye

#alsa force-reload

ciao

Klaus

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Kevin Hinault
Le #22330431
Le 5 juillet 2010 17:08, C. Mourad Jaber

Je suis surpris que personne ne semble avoir le problème que je rencont re :(



Oh si y en a d'autres. J'ai des problèmes sons aussi mais moi c'est
Amarok sur KDE4.4 qui ne fonctionne plus à cause d'une incompatibilité
avec le moteur de son Xine. Si je ne m'agite pas trop c'est que j'ai
vu, je ne sais plus trop où, que des devs bossent sur le sujet donc je
prend mon mal en patience et je les laisse bosser plutôt que de faire
du bruit inutilement ;)
Après tout j'ai choisi d'être en sid/squeeze à mes risques et péril s !


J'essais de me dépatouiller de l'infrastructure son, mais je n'y compre nds plus rien !

Pourquoi tous ces composants ? quel est leur rôle (phonon, les divers b ackend, pulseaudio, esound, alsa...) ? et comment identifier un problème dans ces multiples couches logiciels ?



<vendredi>
Ah mais non l'audio sous Linux c'est très simple, suffit de suivre le
GPS : http://matt.bottrell.com.au/uploads/Pics/linuxaudio.png

:D
 </vendredi>

--
Kévin
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org
http://identi.ca/khi - http://twitter.com/kh_i - http://system-linux.eu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
C. Mourad Jaber
Le #22330441
Le 05/07/2010 17:27, Klaus Becker a écrit :
alsa force-reload



Effectivement ça a débloqué la situation, j'ai du installer alsa-base et
alsa-utils !

Merci

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Kevin Hinault
Le #22330541
Le 5 juillet 2010 17:39, C. Mourad Jaber

Justement l'interet de "faire du bruit" et de pouvoir trouver les probl èmes
pour éventuellement les diagnostiquer d'un manière utile aux maintene urs...

Il n'est pas rare qu'il manque des liens symboliques, des fichiers de con f
mal configuré de base ou des paquets re-pompé sur une autre distribut ion
(ubuntu, par exemple) et mal adaptés...

Tous ces petits problèmes ne concernent pas les devs est peuvent être
facilement résolus s'ils sont remontés correctement...

Pour ma part, je fait des bugs reports régulièrement pour soit signal er un
problème que je ne peux pas résoudre soit pour poster une solution, c 'est ça
qui fait avancer la testing d'ailleurs...

Bien sûr, je vérifie dans les bugs si quelqu'un a déjà rencontr é le problème
pour éviter dans la manière du possible les doublons.

C'est d'ailleurs aussi pour ça que je suis en testing/Sid...

PS : pour ma part amarock marche très bien et je n'ai pas de problème
particulier avec phonon et son backend xine...




Je me suis mal exprimé sûrement : j'évite le bruit sur les forums et
les mailings-lists quand un problème est déjà signalé aux devs dans
leur interface de gestion de bugs. Ce qui est le cas avec les
problèmes de sons de KDE4.4.

--
Kévin
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org
http://identi.ca/khi - http://twitter.com/kh_i - http://system-linux.eu

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
C. Mourad Jaber
Le #22330531
Le 05/07/2010 17:25, Kevin Hinault a écrit :
Le 5 juillet 2010 17:08, C. Mourad Jaber
Je suis surpris que personne ne semble avoir le problème que je rencontre :(



Oh si y en a d'autres. J'ai des problèmes sons aussi mais moi c'est
Amarok sur KDE4.4 qui ne fonctionne plus à cause d'une incompatibilité
avec le moteur de son Xine. Si je ne m'agite pas trop c'est que j'ai
vu, je ne sais plus trop où, que des devs bossent sur le sujet donc je
prend mon mal en patience et je les laisse bosser plutôt que de faire
du bruit inutilement ;)
Après tout j'ai choisi d'être en sid/squeeze à mes risques et périls !
--
Kévin
Membre de l'April - « promouvoir et défendre le logiciel libre » -
http://www.april.org
http://identi.ca/khi - http://twitter.com/kh_i - http://system-linux.eu





Justement l'interet de "faire du bruit" et de pouvoir trouver les
problèmes pour éventuellement les diagnostiquer d'un manière utile aux
mainteneurs...

Il n'est pas rare qu'il manque des liens symboliques, des fichiers de
conf mal configuré de base ou des paquets re-pompé sur une autre
distribution (ubuntu, par exemple) et mal adaptés...

Tous ces petits problèmes ne concernent pas les devs est peuvent être
facilement résolus s'ils sont remontés correctement...

Pour ma part, je fait des bugs reports régulièrement pour soit signaler
un problème que je ne peux pas résoudre soit pour poster une solution,
c'est ça qui fait avancer la testing d'ailleurs...

Bien sûr, je vérifie dans les bugs si quelqu'un a déjà rencontré le
problème pour éviter dans la manière du possible les doublons.

C'est d'ailleurs aussi pour ça que je suis en testing/Sid...

PS : pour ma part amarock marche très bien et je n'ai pas de problème
particulier avec phonon et son backend xine...

++

Mourad

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme