Besoin d'aide sur une matricielle

Le
ThierryP
Bonjour le forum,
Le soleil revenant, mes quelques neurones survivants commencent à gril=
ler ! Donc, j'ai besoin d'un coup de main sur une matricielle :

Dans une feuille "Cdes", j'ai une colonne nommée "Ventes", dans laquel=
le chaque cellule peut avoir comme valeur :
- vide
- @
- 03/16 (mois/année)

Dans une feuille "Ventes", je souhaite connaitre le nombre vendu par mois, =
donc 12 cellules de A à L
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #26403608
Bonjour,
Je te fais une suggestion :
Une colonne date nommée "DATES" (plage nommée) pouvant contenir :
Totalement vide - une date - "@"
Une colonne Vente nommée "VENTES", contenant le montant des ventes pour
chacune des dates.
Pour calculer le total :
Formule matricielle :
Le 7 dans la formule représente le mois de juillet et 2016 l'année en cours.
=SOMME(SI(NON(ESTERREUR(MOIS(Dates)=7))*(NON(ESTERREUR(ANNEE(Dates) 16)))*(Dates<>"");Ventes;0))
MichD
MichD
Le #26403633
Le 06/07/16 à 12:53, MichD a écrit :
Bonjour,
Je te fais une suggestion :
Une colonne date nommée "DATES" (plage nommée) pouvant contenir :
Totalement vide - une date - "@"
Une colonne Vente nommée "VENTES", contenant le montant des ventes pour
chacune des dates.
Pour calculer le total :
Formule matricielle :
Le 7 dans la formule représente le mois de juillet et 2016 l'année en
cours.
=SOMME(SI(NON(ESTERREUR(MOIS(Dates)=7))*(NON(ESTERREUR(ANNEE(Dates) 16)))*(Dates<>"");Ventes;0))

MichD

Si tu préfères, tu as aussi ceci, cette formule ne demande pas une
validation matricielle.
=SOMMEPROD((NON(ESTERREUR(MOIS(Dates)=7))*(NON(ESTERREUR(ANNEE(Dates) 16)))*(Dates<>""));Ventes)
MichD
Le #26403637
Désolé. Oublie les 2 formules précédentes...un vice important dans la
conception. Celle-ci devrait fonctionner correctement :
Validation matricielle :
=SOMME(SI(ESTNUM(((MOIS(Dates)=7)*ANNEE(Dates) 16)*1*Ventes);((MOIS(Dates)=7)*ANNEE(Dates) 16)*1*Ventes))
MichD
ThierryP
Le #26403642
Le jeudi 7 juillet 2016 04:14:09 UTC+2, MichD a écrit :
Désolé. Oublie les 2 formules précédentes...un vice i mportant dans la
conception. Celle-ci devrait fonctionner correctement :
Validation matricielle :
=SOMME(SI(ESTNUM(((MOIS(Dates)=7)*ANNEE(Dates) 16)*1*Ventes);((MO IS(Dates)=7)*ANNEE(Dates) 16)*1*Ventes))
MichD

Bonjour Denis,
Toujours là en cas de besoin !
Comme je l'ai dit à Stéphane, je voulais essayer de faire une seu le formule mais du coup je m'en suis sorti en créant deux colonnes nom mées pour extraire le mois et l'année et cette formule fonctionne :
{SOMME((Modele=$A3)*(Ventes<>"@")*(Ventes<>"")*(Mois=MOIS(G$2))*(Annà ©e=$U$1)*1)}
Merci du coup de main !
ThierryP
MichD
Le #26403662
On peut même avoir plus court à celle déjà proposée en supprimant le "*1".
Validation matricielle :
=SOMME(SI(ESTNUM(((MOIS(Dates)=7)*ANNEE(Dates) 16)*Ventes);
((MOIS(Dates)=7)*ANNEE(Dates) 16)*Ventes))
En plus, elle fonctionne! ;-))
MichD
Publicité
Poster une réponse
Anonyme