[Biz] URL ouvre Apercu image

Le
Daniel92
Bonsoir,

Bizarre , bizarre

Si je mets ces deux références URL d'images Jpeg dans la
Barre d'adresses de IE6 , j'ai un comportement différent :

L-AnneeColour2
http://pages.interlog.com/~dolphind/L'AnneeColour2.jpg
s'ouvre normalement avec la partie viewer de IE6 ,

et celle-ci
Junta (Garage Olimpo)
http://tauschzone.de/art/1135/1/full.jpg
s'ouvre ANORMALEMENT avec
' Aperçu des images et des télécopies Windows ' ,
sans demander la permission par "Enregistrer sous" ?

J'ai pensé à un code contenu dans l'image qui s'exécute
automatiquement; mais , une fois téléchargée ou
directement à partir du TIF/cache , si je l'ouvre en interne
avec IE6 , elle apparaît normalement dans la fenêtre
de Internet Explorer.

J'avoue z-être un peu perdu Est-ce pareil chez vous ?

Si vous avez une idée sur la cause de ce phénomène très
Windowsien ?

Merci,
--
Daniel92.
Vidéos High-Tech et Jeu Vidéo
  • Skype lance le partage de liens pour contacter ses amis ou sa famille n'ayant pas de ...
  • Capcom a diffusé de nouveaux extraits de son prochain survival horror à venir sur PC et ...
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
~Jean-Marc~ [MVP]
Le #1203423
Salut Daniel92,
tu nous disais :
Bonsoir,

Bizarre , bizarre

Si je mets ces deux références URL d'images Jpeg dans la
Barre d'adresses de IE6 , j'ai un comportement différent :

L-AnneeColour2
http://pages.interlog.com/~dolphind/L'AnneeColour2.jpg
s'ouvre normalement avec la partie viewer de IE6 ,


Content-Type: image/jpeg

et celle-ci
Junta (Garage Olimpo)
http://tauschzone.de/art/1135/1/full.jpg


Content-Type: image/jpg

A vérifier, je ne suis pas certain que le Content-Type soit normal.

D'ailleurs, lorsque je vérifie :
HKEY_CLASSES_ROOTMIMEDataBaseContent Type
Je n'y trouve pas ce content-type (vista semble le corriger,
il s'affiche correctement chez moi).

Il faudrait vérifier dans "Options des dossiers" les options
utilisées pour les .jpg

s'ouvre ANORMALEMENT avec


ça ne me semble pas anormal, le jpg étant (habituellement, mais
il y a des exceptions) inoffensif.

@+

--
~Jean-Marc~ MVP Shell/User Fr
( Vista x86 Ultimate )
- http://msmvps.com/blogs/docxp/ -
- http://docxp.mvps.org -

~Jean-Marc~ [MVP]
Le #1203208
Salut Daniel92,
tu nous disais :

Comment vois-tu le mime-type de chaque image ?


C'est le serveur http qui renvoie ce type mime pour chaquer fichier.
(c'est inclus dans les headers)

J'utilise "fiddler" pour voir ces headers.

@+

--
~Jean-Marc~ MVP Shell/User Fr
( Vista x86 Ultimate )
- http://msmvps.com/blogs/docxp/ -
- http://docxp.mvps.org -

Daniel92
Le #1202643
*~Jean-Marc~ [MVP]* écrit dans
|
| Salut Daniel92,
| tu nous disais :
|
| > Comment vois-tu le mime-type de chaque image ?
|
| C'est le serveur http qui renvoie ce type mime pour chaquer fichier.
| (c'est inclus dans les headers)
|
| J'utilise "fiddler" pour voir ces headers.

Très "pro" à première vue
Fiddler HTTP Debugger - A free web debugging tool
http://www.fiddlertool.com/fiddler/

avec des Cours en Vidéo sur son utilisation
http://www.fiddlertool.com/fiddler/help/video/default.asp


Je vais l'essayer sur la référence qui provoque, chez moi,
ce déclenchement de 'Aperçu des images et télécopies'

Junta (Garage Olimpo) DVD neu - Tauschzone
http://tauschzone.de/art/1135/1-junta_garage_olimpo_dvd_neu.html

|
| @+
|

Merci Jean-Marc,
--
Daniel92.
======
Publicité
Poster une réponse
Anonyme