Blocage gnome suite

Le
Marc JEAN
Bonjour !

Suite à récente màj, l'ouverture de session se bloque pour les
utilisateurs ayant un thème issu de gnome-themes-extras, qui ne semble
plus être compatible avec les versions en cours (en tous cas, c'est mon
diagnostic de débutant).

Les utilisateurs concernés ne peuvent pas entrer en session de secours.

Quelle façon simple de corriger uniquement les utilisateurs concernés en
modifiant le moins possible leurs bureaux ?

D'avance merci à tous !

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gaëtan PERRIER
Le #16609901
Le Sat, 23 Aug 2008 19:18:28 +0200
Marc JEAN
Bonjour !

Suite à récente màj, l'ouverture de session se bloque pour les
utilisateurs ayant un thème issu de gnome-themes-extras, qui ne semble
plus être compatible avec les versions en cours (en tous cas, c'est
mon diagnostic... de débutant).

Les utilisateurs concernés ne peuvent pas entrer en session de
secours.

Quelle façon simple de corriger uniquement les utilisateurs concernés
en modifiant le moins possible leurs bureaux ?

D'avance merci à tous !





Salut,

Normalement le thème de chaque utilisateur est enregistré dans le fichi er ~/.gconf/apps/metacity/general/%gconf.xml
Si tu supprimes ce fichier tu devrais redémarrer ta session avec le thè me standard (ClearLooks je crois). Fais quand même une copie avant...

Gaëtan

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Marc JEAN
Le #16610361
Le dimanche 24 août 2008 à 00:31 +0200, Gaëtan PERRIER a écrit :

Normalement le thème de chaque utilisateur est enregistré dans le fichier ~/.gconf/apps/metacity/general/%gconf.xml
Si tu supprimes ce fichier tu devrais redémarrer ta session avec le thème standard (ClearLooks je crois). Fais quand même une copie avant...

Gaëtan



C'est bien metacity qui avait un problème après la màj d'hier
syslog : kernel: [ 339.927819] metacity[3353]: segfault at c ip
b77260a0 sp bfebe400 error 4 in libc-2.7.so[b76b6000+155000]

C'est moins brutal que d'effacer ~/.gconf en entier ;) mais j'avais
atteint mon seuil d'incompétence...

C'est peut être une conséquence de la màj lenny de libxml2, qui semble
avoir posé quelques problèmes à voir les listes. Une màj vers libxml2
unstable comme conseillé par Christian Debarbieri sur un fil voisin
ferait alors l'affaire.

Je ne sais pas si le problème est général, mais ça ne me semble pas
heureux que la session ne secours ne charge pas le thème standard.

Encore merci !

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Christian Debarbieri
Le #16612461
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

C'est le même probleme que le mien.
Maj de libxml2 qui fait planter gnome.

Voir le lien donné par Stéphane Aulery
http://lists.debian.org/cgi-bin/search?query=libxml2&DEFAULTOP=and&author=&sortÚte&HITSPERPAGE&language=fr
Ils citent aussi metacity qui plante.

= La solution de contournement est de repasser à la version précédente
provenant de unstable.
apt-get install -t unstable libxml2/unstable
Mais il faut le source.list qui va bien
=

Marc JEAN a écrit :
Le dimanche 24 août 2008 à 00:31 +0200, Gaëtan PERRIER a écrit :

Normalement le thème de chaque utilisateur est enregistré dans le fichier ~/.gconf/apps/metacity/general/%gconf.xml
Si tu supprimes ce fichier tu devrais redémarrer ta session avec le thème standard (ClearLooks je crois). Fais quand même une copie avant...

Gaëtan



C'est bien metacity qui avait un problème après la màj d'hier
syslog : kernel: [ 339.927819] metacity[3353]: segfault at c ip
b77260a0 sp bfebe400 error 4 in libc-2.7.so[b76b6000+155000]

C'est moins brutal que d'effacer ~/.gconf en entier ;) mais j'avais
atteint mon seuil d'incompétence...

C'est peut être une conséquence de la màj lenny de libxml2, qui semble
avoir posé quelques problèmes à voir les listes. Une màj vers libxml2
unstable comme conseillé par Christian Debarbieri sur un fil voisin
ferait alors l'affaire.

Je ne sais pas si le problème est général, mais ça ne me semble pas
heureux que la session ne secours ne charge pas le thème standard.

Encore merci !




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkixVbcACgkQXfnFyCNJxzYwCwCcDemMquRKbsT1cBP0NOS/Q4R9
S1wAni09CrlriL5IucymMStrh7AH+gDW
=mF0u
-----END PGP SIGNATURE-----

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Stéphane Aulery
Le #16613021
Le problème n'est pas isolé à Lenny (cf. #496178, #496190, #496311).
Il semble que la libxml2 ne soit pas le problème, mais qu'elle fasse
apparaitre d'autres bug dans la libsvg.

Une entrée a été ouverte dans le BTS (#496125) :
http://bugs.debian.org/cgi-bin/bugreport.cgi?bugI6125

Bug#496125: libxml2: security fix does double free / segfaults (breaks
Gnome apps)
Reported by: Christian Jaeger Date: Fri, 22 Aug 2008 20:12:02 UTC
Severity: grave
Tags: confirmed
Merged with 496178, 496190, 496311
Bug#496178: debian lenny: after upgrade, gdm failed to start
Bug#496190: gnome-panel: Memory corruption
Bug#496311: gdmgreeter, gnome-panel, metacity .... segfault at c ip
b74750a0 sp bfb43480 error 4 in libc-2.7.so
Found in version 2.6.32.dfsg-2+lenny1



On pouvait lire sur la liste debian-bugs-rc :



On Sun, Aug 24, 2008 at 09:27:50AM +0200, Christian Jaeger wrote:
Mike Hommey wrote:
> Now, try changing your gnome theme and re-run galeon ; if i'm
> correct, it shouldn't crash. Can you tell me what package this svg
> file belongs to ?

Yes, the segfaults happen only in the "Gorilla" and "Wasp" themes
(apps
did start when running the Amaranth, Clearlooks, Crux, Glider, Glossy,
Industrial, Lush, Mist, Nuvola, SphereCrystal themes).

With Gorilla the svg file in question is
/usr/share/icons/Gorilla/scalable/actions/gtk-jump-to-ltr.svg

What this file does *not* share with the one from the Wasp theme, is
that xmllint not even outputs a warning.

Not sure what to conclude from this. Except that it might be a bug in
one of these packages:

$ dpkgS /usr/lib/librsvg-2.so.2
librsvg2-2: /usr/lib/librsvg-2.so.2.22.2
$ dpkgS /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so
librsvg2-common: /usr/lib/gtk-2.0/2.10.0/loaders/svg_loader.so



So... the culprit is just librsvg that creates xmlEntity objects not
through the API, but by malloc'ing a buffer of sizeof(xmlEntity).
This struct has gained a member in the security update, breaking rsvg's
assumptions...

A BinNMU of librsvg against libxml2-dev 2.6.32.dfsg-2+lenny1 should
solve the issue (and won't break compatibility with older libxml2, since
older libxml2 will be happy with a too big buffer)

I can confirm that installing a librsvg from lenny rebuilt against the
new libxml2-dev works.

# installing rebuilt librsvg2-2, librsvg2-bin, librsvg2-common,
# librsvg2-dev

eog, galeon and gnome-appearance-properties don't segfault anymore
(interestingly, now I also couldn't get galeon to segfault on quit
anymore on quit so far!).

Take a look at the backtrace, it doesn't involve libxml2.




Yes sure. And that segfault happened with the *non*-problematic libxml2
version. I should have been a little more clear: my whole point there
was that *another* change than the one in libxml2 might have introduced
a problem, which is just exhibited by the new libxml2. As we don't know
whether it's libxml2's fault or the fault of another library, I have to
mention every other breakage, too.

Now you may be right and it's not "related" to libxml2 in the sense that
libxml2 might not be at fault for those issues, *but* those segfaults
might be very well related in the sense that they might lead us to the
very same cause leading to the segfaults we see inside libxml2. So your
conclusion to not further look at those crashes can't be definitive
(with our current knowledge).

I'm running etch and it seems like it is being affected by this bug
also. Just after updating libxml2 to 2.6.27.dfsg-3 I was unable to open
any files with eog, nor eog alone. No error messages when run from the
command line, no pop ups. Upon rebooting gdm started but when starting
gnome, it would hang for a little while at starting the window manager,
and then stop with the top and bottom panels drawn with nothing in them,
no menus, icons, or applets, just blank panels. No response from the
panels.

Downgrading from 2.6.27.dfsg-3 back to 2.6.27.dfsg-2 fixed the problem.

--
Stéphane Aulery Melius est parum cum justitia
(Pr. XV, 8)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Nicolas FRANCOIS
Le #16631731
Le Sun, 24 Aug 2008 14:36:10 +0200 Christian Debarbieri

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

C'est le même probleme que le mien.
Maj de libxml2 qui fait planter gnome.

Voir le lien donné par Stéphane Aulery
http://lists.debian.org/cgi-bin/search?query=libxml2&DEFAULTOP=and&author=&sortÚte&HITSPERPAGE&language=fr
Ils citent aussi metacity qui plante.

= > La solution de contournement est de repasser à la version précédente
provenant de unstable.
apt-get install -t unstable libxml2/unstable
Mais il faut le source.list qui va bien



Bon, et le source.list qui va bien, c'est quoi ?

Faut vous dire que j'ai un peu de mal avec ces "etch", "lenny" et autres
"instable" :-( Mon sources.list contient ce dont j'ai eu
besoin pour l'installation (par netinst) :
- l'entrée CDROM,
- les deux deb des paquets (ftp2.fr.debian.org, etch, main contrib
nonfree)
- l'entrée security.debian.org
- une entrée debian-unofficial... peut-être pour le driver nvidia ???

J'ai essayé de rajouter une ligne avec "unstable" à la place de etch, et
je me fais jeter lors du "apt-get upgrade" parce que le fichier status ne
peut pas être lu...

Bref, j'y comprends que dalle, donc si une bonne âme pouvait me dire soit
comment revenir à l'ancienne version, soit comment recharger les bonnes
librsvg (puisque ce sont elles qui semblent poser problème), je lui en
serait vachement reconnaissant !

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #16633231
Nicolas FRANCOIS wrote:
Le Sun, 24 Aug 2008 14:36:10 +0200 Christian Debarbieri


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

C'est le même probleme que le mien.
Maj de libxml2 qui fait planter gnome.

Voir le lien donné par Stéphane Aulery
http://lists.debian.org/cgi-bin/search?query=libxml2&DEFAULTOP=and&author=&sortÚte&HITSPERPAGE&language=fr
Ils citent aussi metacity qui plante.

= >> La solution de contournement est de repasser à la version précédente
provenant de unstable.
apt-get install -t unstable libxml2/unstable
Mais il faut le source.list qui va bien




Bon, et le source.list qui va bien, c'est quoi ?

Faut vous dire que j'ai un peu de mal avec ces "etch", "lenny" et autres
"instable" :-( Mon sources.list contient ce dont j'ai eu
besoin pour l'installation (par netinst) :
- l'entrée CDROM,
- les deux deb des paquets (ftp2.fr.debian.org, etch, main contrib
nonfree)
- l'entrée security.debian.org
- une entrée debian-unofficial... peut-être pour le driver nvidia ???

J'ai essayé de rajouter une ligne avec "unstable" à la place de etch, et
je me fais jeter lors du "apt-get upgrade" parce que le fichier status ne
peut pas être lu...

Bref, j'y comprends que dalle, donc si une bonne âme pouvait me dire soit
comment revenir à l'ancienne version, soit comment recharger les bonnes
librsvg (puisque ce sont elles qui semblent poser problème), je lui en
serait vachement reconnaissant !

bye




Salut
Si ça intéresse quelqu'un, j'ai une version de libxml2 et libxml2-utils
non impactés par le bug.
Il doivent dater d'un mois environ :
libxml2_2.6.32.dfsg-2_i386.deb
libxml2-utils_2.6.32.dfsg-2_i386.deb

Il doit y avoir moyen de forcer leur installation.
Mais ça risque de casser les dépendances et je ne sais pas si la
situation peut être rétablie facilement par la suite.

David.

--
Web site : http://david.hautbois.free.fr
Tablet users map : http://david.hautbois.free.fr/maps/index.php


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #16633511
Salut

Tout le monde semble à peu près au courant des soucis engendrés par la
dernière mise à jour de libxml2.
Mais il y a quelques petites choses que je ne m'explique pas :
Le problème semble être apparu le 22/08/08.
Cette mise à jour a mis a évidence des bugs dans librsvg (d'après ce que
j'ai compris).
Or si on regarde ici :
http://packages.qa.debian.org/libx/libxml2.html
http://packages.qa.debian.org/libr/librsvg.html

Il n'y a eu aucune mise à jour de ces deux modules le 22/08/08.
Je comprends pas....

Le problème a t'il été corrigé (on voit sur ces mêmes pages un mise à
jour de libxml2 aujourd'hui)
Si non, la correction me parait un peu longue à venir... (c'est pas une
critique)

David.
PS : Je suis en train de mettre à jour une lenny dans une VM, pour voir....
J'hésite à mettre à jour ma machine princpale....

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Hautbois
Le #16633501
Apparement le problème est corrigé en unstable :


libxml2 unstable; urgency=high

* Fix DoS which leads to recursive evaluation of entities.
Fixes: CVE-2008-3281
-- Mike Hommey
Aug 2008 22:01:17 +0200


->
http://packages.debian.org/changelogs/pool/main/libx/libxml2/current/changelog

David Hautbois wrote:


Nicolas FRANCOIS wrote:
Le Sun, 24 Aug 2008 14:36:10 +0200 Christian Debarbieri


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

C'est le même probleme que le mien.
Maj de libxml2 qui fait planter gnome.

Voir le lien donné par Stéphane Aulery
http://lists.debian.org/cgi-bin/search?query=libxml2&DEFAULTOP=and&author=&sortÚte&HITSPERPAGE&language=fr

Ils citent aussi metacity qui plante.

= >>> La solution de contournement est de repasser à la version précédente
provenant de unstable.
apt-get install -t unstable libxml2/unstable
Mais il faut le source.list qui va bien




Bon, et le source.list qui va bien, c'est quoi ?

Faut vous dire que j'ai un peu de mal avec ces "etch", "lenny" et autres
"instable" :-( Mon sources.list contient ce dont j'ai eu
besoin pour l'installation (par netinst) : - l'entrée CDROM, - les
deux deb des paquets (ftp2.fr.debian.org, etch, main contrib
nonfree)
- l'entrée security.debian.org
- une entrée debian-unofficial... peut-être pour le driver nvidia ???

J'ai essayé de rajouter une ligne avec "unstable" à la place de etch, et
je me fais jeter lors du "apt-get upgrade" parce que le fichier
status ne
peut pas être lu...

Bref, j'y comprends que dalle, donc si une bonne âme pouvait me dire
soit
comment revenir à l'ancienne version, soit comment recharger les bonnes
librsvg (puisque ce sont elles qui semblent poser problème), je lui en
serait vachement reconnaissant !

bye




Salut
Si ça intéresse quelqu'un, j'ai une version de libxml2 et
libxml2-utils non impactés par le bug.
Il doivent dater d'un mois environ :
libxml2_2.6.32.dfsg-2_i386.deb
libxml2-utils_2.6.32.dfsg-2_i386.deb

Il doit y avoir moyen de forcer leur installation.
Mais ça risque de casser les dépendances et je ne sais pas si la
situation peut être rétablie facilement par la suite.

David.




--
Web site : http://david.hautbois.free.fr
Tablet users map : http://david.hautbois.free.fr/maps/index.php


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Nicolas FRANCOIS
Le #16634441
Le Tue, 26 Aug 2008 17:50:44 +0200 Nicolas FRANCOIS

Bref, j'y comprends que dalle, donc si une bonne âme pouvait me dire soit
comment revenir à l'ancienne version, soit comment recharger les bonnes
librsvg (puisque ce sont elles qui semblent poser problème), je lui en
serait vachement reconnaissant !



Bon, bin c'est fait : le problème a été corrigé ([DSA 1631-1]).

Tout cela ne me dit pas comment faire un sources.list digne d'un
"véritable", mais mon petit orteil me dit que ça n'est sans doute de
toute façon pas une bonne idée ! La dernière fois que j'ai essayé, je me
suis retrouvé avec un système tout cassé :-(

Allez, tous à vos apt-get upgrade !

bye

--

Nicolas FRANCOIS | /
http://nicolas.francois.free.fr | |__|
X--/\
We are the Micro$oft. __V
Resistance is futile.
You will be assimilated. darthvader penguin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme