Bluetooth sous Ubuntu

Le
docanski
Bonjour a foule !

Je tente, en vain, d'activer une clef bluetooth (genre mini-clef USB)
sous 9.04 après avoir installé l'analyseur (www.bluez.org) et le
"partage de fichiers Bluetooth".
Le système ne détecte même pas la clef (sans marque : il s'agit d'une
clef fournie à l'achat d'un mini-portable Akoya) et l'applet Bluetooth
de "Préférences" n'offre aucun menu de recherche mais un paramétrage des
plus désuets de l'affichage d'une icône ou pas lors de la détection du
bidule. Mais voilà : rien n'est détecté :-(
J'ajoute que cette clef est pourtant détectée sous WinXP.

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Cumbalero
Le #20039171
docanski a écrit :
Bonjour a foule !

Je tente, en vain, d'activer une clef bluetooth (genre mini-clef USB)



Pour savoir ce que c'est comme "genre de mini clef USB", un petit lsusb
pourrait aider à t'indiquer quel module charger.

A+
JF
Sergio
Le #20039521
Cumbalero a écrit :
docanski a écrit :
Bonjour a foule !

Je tente, en vain, d'activer une clef bluetooth (genre mini-clef USB)



Pour savoir ce que c'est comme "genre de mini clef USB", un petit lsusb
pourrait aider à t'indiquer quel module charger.



Et pourtant. Avec ma clef BT USB (qui fonctionne très bien par ailleurs), le "lsusb" ne donne rien :
-----------------------------------------
:~$ lsusb
Bus 001 Device 007: ID 174b:0001
Bus 001 Device 006: ID 046d:c016 Logitech, Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse
Bus 001 Device 005: ID 0409:0058 NEC Corp. HighSpeed Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 07c4:a000 Datafab Systems, Inc. CompactFlash Card Reader
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 04f9:000d Brother Industries, Ltd HL-1440 Laser Printer
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 04b8:010f Seiko Epson Corp. Perfection 1250
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
-----------------------------------------

(c'est la première ligne, ma clef)

--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Cumbalero
Le #20039581
Sergio a écrit :

Et pourtant. Avec ma clef BT USB (qui fonctionne très bien par
ailleurs), le "lsusb" ne donne rien :
-----------------------------------------
:~$ lsusb
Bus 001 Device 007: ID 174b:0001



Ben si, la première ligne.

Il semble que le constructeur de ta clé ait mal implémenté certains
aspects de la norme USB. En outre, le vendor ID 174b n'est pas référe ncé.

A+
JF
Sergio
Le #20039891
Cumbalero a écrit :

Et pourtant. Avec ma clef BT USB (qui fonctionne très bien par
ailleurs), le "lsusb" ne donne rien :
-----------------------------------------
:~$ lsusb
Bus 001 Device 007: ID 174b:0001



Ben si, la première ligne.

Il semble que le constructeur de ta clé ait mal implémenté certains
aspects de la norme USB. En outre, le vendor ID 174b n'est pas référencé.



Mais alors, comment se fait-il que ma clef soit quand même reconnue sans problème ? Je n'ai rien eu à bricoler pour la faire
fonctionner sous mon Linux (Ubuntu) ? [*]

[*]Alors que sous Windows XP, il faut installer un pilote...
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Cumbalero
Le #20040061
Sergio a écrit :

Mais alors, comment se fait-il que ma clef soit quand même reconnue s ans
problème ?



Parce que le noyau se fout de la description "en mots compréhensibles
par les humains". Le couple 174b:0001 a suffi au hal/udev pour charger
le bon module, créer le bon fichier de périphérique...

De même que ta souris c'est 046d:c016 pour le système, et pas "Logite ch,
Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse"

Sous Linux aussi. Le pilote est fourni sous forme de module. Il est
livré par ta distribution.


A+
JF
Nicolas George
Le #20040481
Cumbalero wrote in message
Parce que le noyau se fout de la description "en mots compréhensibles
par les humains". Le couple 174b:0001 a suffi au hal/udev pour charger
le bon module, créer le bon fichier de périphérique...



Pas exactement. Ce qui lui a servi, c'est bDeviceClass"4=0xE0,
bDeviceSubClass=1 et bDeviceProtocol=1

http://www.usb.org/developers/defined_class#BaseClassE0h

De même que ta souris c'est 046d:c016 pour le système, et pas "Logitech,
Inc. M-UV69a/HP M-UV96 Optical Wheel Mouse"



De même, ici, ce qui est déterminant, c'est bDeviceClass=3.
docanski
Le #20041381
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Cumbalero ecrit ce qui suit en ce 02/09/2009 07:58 :

Pour savoir ce que c'est comme "genre de mini clef USB", un petit lsusb
pourrait aider à t'indiquer quel module charger.



Le problème est que lsusb ne donne rien :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Elle n'est donc même pas vue par le SE.
Que je tente cette reconnaissance sous root ou sous l'utilisateur, le
résultat est le même.
Sur mon portable sous XP, elle est reconnue. Sur la tour, que ce soit
sous Win2k ou Ubuntu 9.04, pas le moindre signal, même pas l'allumage de
la loupiotte bleue qui permet de constater que la clef est bien
alimentée. Je sèche ... :-(

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
ahura
Le #20043141
docanski a écrit :
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Cumbalero ecrit ce qui suit en ce 02/09/2009 07:58 :

Pour savoir ce que c'est comme "genre de mini clef USB", un petit
lsusb pourrait aider à t'indiquer quel module charger.



Le problème est que lsusb ne donne rien :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Elle n'est donc même pas vue par le SE.
Que je tente cette reconnaissance sous root ou sous l'utilisateur, le
résultat est le même.
Sur mon portable sous XP, elle est reconnue. Sur la tour, que ce soit
sous Win2k ou Ubuntu 9.04, pas le moindre signal, même pas l'allumage de
la loupiotte bleue qui permet de constater que la clef est bien
alimentée. Je sèche ... :-(

Cordialement,



est-ce que tu as verifié que ton bios est configuré correctement, j'en
ai deja vu ou il etait possible d'inhiber les ports usb ?
ahura
Le #20043131
docanski a écrit :
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Cumbalero ecrit ce qui suit en ce 02/09/2009 07:58 :

Pour savoir ce que c'est comme "genre de mini clef USB", un petit
lsusb pourrait aider à t'indiquer quel module charger.



Le problème est que lsusb ne donne rien :

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Elle n'est donc même pas vue par le SE.
Que je tente cette reconnaissance sous root ou sous l'utilisateur, le
résultat est le même.
Sur mon portable sous XP, elle est reconnue. Sur la tour, que ce soit
sous Win2k ou Ubuntu 9.04, pas le moindre signal, même pas l'allumage de
la loupiotte bleue qui permet de constater que la clef est bien
alimentée. Je sèche ... :-(

Cordialement,



tu n'as aucun peripherique usb sur ta tour ?
Cumbalero
Le #20043311
docanski a écrit :

Le problème est que lsusb ne donne rien :



Et que donne lsmod | grep hci ?

A+
JF
Publicité
Poster une réponse
Anonyme