Bonne formule, résultat inadéquat

Le
claude
Bonjour,
J'ai dans la colone A une série de cellule avec codes
AGD
1WA
DFG
DRE
SAD
DWA

En A7 j'inclue une formule pour connaître le nombre de cellules dont on
retrouve la lettre «A» , ma formule est la suivante :
=NB(CHERCHE("w";A1:A6)). L'assistant formule, m'indique que ma formule est
bonne puisque dans cette même fenêtre j'obtient toujours le bon résultat soit
«4» (et si je m'amuse à changer le contenu de la colone A, dans l'assistant
j'obtiens toujours le bon résultat) cependant ma cellule A7 affiche toujours
«0» comme résultat! Comment faire pour régler ce problème?
--
Claude
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #6560321
Bonjour,

Comment faire pour régler ce problème?


Formule matricielle.
Valider la formule par Ctrl+majuscule+entrée et non pas par entrée
Elle doit ressembler à ceci:
{=NB(CHERCHE("A";A1:A6))}

--
Salutations
JJ


"claude"
Bonjour,
J'ai dans la colone A une série de cellule avec codes
AGD
1WA
DFG
DRE
SAD
DWA

En A7 j'inclue une formule pour connaître le nombre de cellules dont on
retrouve la lettre «A» , ma formule est la suivante :
=NB(CHERCHE("w";A1:A6)). L'assistant formule, m'indique que ma formule est
bonne puisque dans cette même fenêtre j'obtient toujours le bon résultat
soit
«4» (et si je m'amuse à changer le contenu de la colone A, dans
l'assistant
j'obtiens toujours le bon résultat) cependant ma cellule A7 affiche
toujours
«0» comme résultat! Comment faire pour régler ce problème?
--
Claude


Philippe.R
Le #6560301
Bonjour,
Et si tu valides cette formule par la combinaison de touches Ctrl+Maj+Entrée
?
(il s'agit d'une formule matricielle)
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"claude" news:
Bonjour,
J'ai dans la colone A une série de cellule avec codes
AGD
1WA
DFG
DRE
SAD
DWA

En A7 j'inclue une formule pour connaître le nombre de cellules dont on
retrouve la lettre «A» , ma formule est la suivante :
=NB(CHERCHE("w";A1:A6)). L'assistant formule, m'indique que ma formule est
bonne puisque dans cette même fenêtre j'obtient toujours le bon résultat
soit
«4» (et si je m'amuse à changer le contenu de la colone A, dans
l'assistant
j'obtiens toujours le bon résultat) cependant ma cellule A7 affiche
toujours
«0» comme résultat! Comment faire pour régler ce problème?
--
Claude


LSteph
Le #6560511
Bonjour,
(pas besoin de matricielle)

=NB.SI(A1:A6;"*a*")

Cordialement.

--
lSteph

nota: "w" n'est pas "A"



retrouve la lettre «A»
=NB(CHERCHE("w";A1:A6)).


claude
Le #6567041
Merci, à tous, effectivement LSteph, je n'ai pas besoin d'une formule
matricielle, mais j'avais tout de même oublié ses fameuses formules
matricielles!!!
--
Claude



Bonjour,
(pas besoin de matricielle)

=NB.SI(A1:A6;"*a*")

Cordialement.

--
lSteph

nota: "w" n'est pas "A"



retrouve la lettre «A»
=NB(CHERCHE("w";A1:A6)).





Publicité
Poster une réponse
Anonyme