box-shadow et IE9

Le
JKB
Bonjour à tous,

J'ai un petit souci avec box-shadow et IE9. Sur certaines pages, il
est pris en compte, sur d'autres non et je ne vois vraiment pas
pourquoi

Considérons la page suivante :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique4

Avec firefox/seamonkey, les images sont ombrées. Avec IE9, non.
En revanche, si je vais ici :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique1
l'image en haut à gauche est bien ombrée quel que soit le
navigateur.

Je suspecte un problème de css, mais je ne vois pas. Lorsque
j'explore la page avec les outils de développement de IE9 (F12), je
vois bien pour l'image en question la propriété :
"box-shadow: 4px 4px 8px #777;". La question est donc : où ai-je
encore écrit une bêtise ?

Merci de vos lumières,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse
=> http://grincheux.de-charybde-en-scylla.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JKB
Le #23552841
Le Mon, 11 Jul 2011 12:38:43 +0000 (UTC),
JKB
Bonjour à tous,

J'ai un petit souci avec box-shadow et IE9. Sur certaines pages, il
est pris en compte, sur d'autres non et je ne vois vraiment pas
pourquoi...

Considérons la page suivante :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique4

Avec firefox/seamonkey, les images sont ombrées. Avec IE9, non.
En revanche, si je vais ici :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique1
l'image en haut à gauche est bien ombrée quel que soit le
navigateur.

Je suspecte un problème de css, mais je ne vois pas. Lorsque
j'explore la page avec les outils de développement de IE9 (F12), je
vois bien pour l'image en question la propriété :
"box-shadow: 4px 4px 8px #777;". La question est donc : où ai-je
encore écrit une bêtise ?

Merci de vos lumières,




Bon, je viens de trouver... Bug de IE9 lorsque box-shadow est
utilisé dans une table. Il faut rajouter border-collapse: separate;.

Désolé pour le bruit,

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
SAM
Le #23552981
Le 11/07/11 14:38, JKB a écrit :
Bonjour à tous,

J'ai un petit souci avec box-shadow et IE9. Sur certaines pages, il
est pris en compte, sur d'autres non et je ne vois vraiment pas
pourquoi...

Considérons la page suivante :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique4

Avec firefox/seamonkey, les images sont ombrées. Avec IE9, non.
En revanche, si je vais ici :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique1
l'image en haut à gauche est bien ombrée quel que soit le
navigateur.

Je suspecte un problème de css, mais je ne vois pas. Lorsque
j'explore la page avec les outils de développement de IE9 (F12), je
vois bien pour l'image en question la propriété :
"box-shadow: 4px 4px 8px #777;". La question est donc : où ai-je
encore écrit une bêtise ?



le layout est-il actif pour cette box ?

la boite a-t-elle été dimensionnée ? par exemple.

... oui elles le sont toutes (en ts cas, les images)

alors ... c'est le table conteneur ?


J'ai pas IE (et encore moins le 9)

--
Stéphane Moriaux avec/with iMac-intel
SAM
Le #23553011
Le 11/07/11 14:52, JKB a écrit :

Bon, je viens de trouver... Bug de IE9 lorsque box-shadow est
utilisé dans une table. Il faut rajouter border-collapse: separate;.



c'est vraiment touj et encore du n'importe quoi ce IE ! :-(
(m'enfin j'avais presque trouvé)

Désolé pour le bruit,



trop tard ! ;-)

--
Stéphane Moriaux avec/with iMac-intel
JKB
Le #23553001
Le Mon, 11 Jul 2011 15:50:26 +0200,
SAM
Le 11/07/11 14:38, JKB a écrit :
Bonjour à tous,

J'ai un petit souci avec box-shadow et IE9. Sur certaines pages, il
est pris en compte, sur d'autres non et je ne vois vraiment pas
pourquoi...

Considérons la page suivante :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique4

Avec firefox/seamonkey, les images sont ombrées. Avec IE9, non.
En revanche, si je vais ici :
http://dev2.de-charybde-en-scylla.fr/spip.php?rubrique1
l'image en haut à gauche est bien ombrée quel que soit le
navigateur.

Je suspecte un problème de css, mais je ne vois pas. Lorsque
j'explore la page avec les outils de développement de IE9 (F12), je
vois bien pour l'image en question la propriété :
"box-shadow: 4px 4px 8px #777;". La question est donc : où ai-je
encore écrit une bêtise ?



le layout est-il actif pour cette box ?

la boite a-t-elle été dimensionnée ? par exemple.

... oui elles le sont toutes (en ts cas, les images)



J'allais répondre la même chose ;-)

alors ... c'est le table conteneur ?


J'ai pas IE (et encore moins le 9)



Disons que j'ai installé W7 dans un qemu pour vérifier l'affichage
d'un site dans IE9... Je n'ai pas de vraie ouïndowzerie sous la
main.

En tout cas, merci pour le coup de main.

JKB

--
Si votre demande me parvient sur carte perforée, je titiouaillerai très
volontiers une réponse...
=> http://grincheux.de-charybde-en-scylla.fr
Olivier Masson
Le #23555101
Le 11/07/2011 15:50, SAM a écrit :


le layout est-il actif pour cette box ?




Pas de haslayout sur IE9
Publicité
Poster une réponse
Anonyme