Brother HL2030 pour AMD64

Le
Aurelien
Salut,

Je tourne avec Debian AMD64 / SID, et j'essaie d'installer une
imprimante HL2030 dessus.
J'étais parvenu à quelque chose, il y a peu, mais le résultat était bof,
les impressions pas très belles, et les plantages réguliers (obligé de
relancer cups après l'arrivée d'un foomatic-rip failed).

Donc, comme aujourd'hui, ça ne fonctionnait pas, j'ai décidé de la
réinstaller, en utilisant les drivers 32 bits proposés par Brother.
Malheureusement, même en suivant leurs instructions, je me retrouve avec
le même problème, et à vrai dire j'ai une erreur très tôt dans
l'impasse, car l'install du driver foire.

Voilà les pages de référence (ci-dessous les opérations effectuées, et
le résultat) :
http://www.debianforum.de/forum/viewtopic.php?f1&t–346&sidh2fab0171a0d6637e5aaed410383e8d
(allemand)
http://solutions.brother.com/linux/sol/printer/linux/lpr_install.html
http://solutions.brother.com/linux/sol/printer/linux/cups_wrapper_install5.html

> For cups users:
> If you plan to install the CUPS Wrapper driver later, you DO NOT have to
> edit the "/etc/brprintcap" file.

OK, je n'y touche pas.

> For 64 bit users:
> lib32stdc++6 or ia32-libs is required to use our driver for 64 bit environment.

Je vérifie :
$> dpkg -l ia32-libs
ii ia32-libs 2.2 ia32 shared libraries for use on amd64 and ia64 systems
$> dpkg -l lib32stdc++6
ii lib32stdc++6 4.3.0-2 The GNU Standard C++ Library v3 (32 bit Version)

Donc, c'est OK.

> Also please copy the files which named start with "brlpdwrapper" in "
> /usr/lib/cups/filter" to "/usr/lib64/cups/filter" after the installation

Je retiens, mais l'histoire montrera que le .deb fait ça tout seul.

> Ignorable error message:
> If you see error message "/var/spool/lpd/ the folder or file doesn't exist". Please ignore it.

D'accord

> # Make a temporary directory on your HDD and download the LPR driver to
> # that directory.

Le driver est celui-ci :
http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_debian/brhl2030lpr-2.0.1-1.i386.deb
(imprimante Brother HL-2030)

> # Log in as root user or use the "su" command.
> # When the driver has been downloaded run the relevant rpm/dpkg file
> # from the command prompt:
> dpkg -i --force-all --force-architecture xxxx.deb* (for dpkg Users)

$> dpkg -i --force-all --force-architecture /home/orl/Imprimantes/brhl2030lpr-2.0.1-1.i386.deb
dpkg - avertissement, problème contourné à cause de --force :
l'architecture du paquet (i386) ne correspond pas à celle du système (amd64)
Sélection du paquet brhl2030lpr précédemment désélectionné.
(Lecture de la base de données 147566 fichiers et répertoires déjà installés.)
Dépaquetage de brhl2030lpr (à partir de /brhl2030lpr-2.0.1-1.i386.deb)
Paramétrage de brhl2030lpr (2.0.1-1)
/var/lib/dpkg/info/brhl2030lpr.postinst: line 3: /usr/local/Brother/inf/braddprinter: cannot execute binary file

OK, donc déjà, je sens le truc mal barré, parce qu'un message d'erreur
aussi tôt, c'est pas gagné.

> This will install the Brother printer driver onto your computer and
> configure it to use the USB interface.

Admettons.

> NOTE:
> If you are plainning to use cups, you do not need to make any further
> modifications. Please go to cupswrapper installation instruction for
> next steps. (Instruction pages differ between models.)

OK, j'y vais

> If you already have a Brother LPR driver installed, you may receive an
> error message. In this instance, run the install command again and use
> the :
> --force-all(For dpkg Users) or --force(For rpm Users) switches

Je n'ai pas de driver installé (j'ai pris soin de virer toutes mes
version de l'imprimante dans cups avant, bien sûr), mais je retente
quand même. Strictement le même résultat.

Je continue.

> Install the cupswrapper driver.
> (i.e)
> For dpkg Users:
> dpkg -i --force-all --force-architecture cupswrapperHL2030-2.0.0-1.i386.deb

$> dpkg -i --force-all --force-architecture /home/orl/Imprimantes/cupswrapperHL2030-2.0.1-2.i386.deb
dpkg - avertissement, problème contourné à cause de --force :
l'architecture du paquet (i386) ne correspond pas à celle du système (amd64)
Sélection du paquet cupswrapperhl2030 précédemment désélectionné.
(Lecture de la base de données 147582 fichiers et répertoires déjà installés.)
Dépaquetage de cupswrapperhl2030 (à partir de /cupswrapperHL2030-2.0.1-2.i386.deb)
Paramétrage de cupswrapperhl2030 (2.0.1-2)
cp: `/usr/lib/cups/filter/brlpdwrapperHL2030' et `/usr/lib64/cups/filter/brlpdwrapperHL2030' identifient le même fichier.
Restarting Common Unix Printing System: cupsd.

Je n'ai donc pas besoin de faire la copie, déjà parce que c'est prévu
dans le script d'install, et en plus parce qu'il semble que ce soit déjà
les même fichiers.

Après, il faut lancer localhost:631 et ajouter l'imprimante.
je l'ai fait, cups ne me propose pas de suite d'ajouter l'imprimante. Je
le fais à la main. Je trouve une proposition de bus USB pour la HL2030,
je la prends, mais après, il n'y a pas de driver pour la 2030.
Bon, j'en reviens donc au même point.
J'essaie avec les drivers de la 2060, ceux de la 1250, en version
normale, HPIJS, et en LPR, mais rien n'y fait, ça ne fonctionne pas.

Pourtant, le type du premier lien, avec une distrib Etch n'a aucun
problème.

je ne vois pas du tout ce que j'ai pu mal faire, et je ne sais pas quoi
faire de plus.

Je suis preneur de toutes les explications, aides, etc.

Note : au passage, je n'ai pas bien suivi ce qui se passe avec gs, mais
si j'ai bien tout compris, ça change de nom. Ca fout un sacré bordel
dans pas mal d'applications qui peuvent imprimer (de lilypond à
evince!!)

Merci d'avance.

A bientôt.



--

ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yvan Martzluff
Le #9694011
salut,

Sinon tu peux utiliser sans problème le driver Cups :
Brother HL-2060 Foomatic/hl1250

ça marche très bien. mieux que le driver proprio (comme souvent
d'ailleurs :-) ) qui utilise un wrapper pour LPR

A bientôt

Le mercredi 2 avril 2008 19:13, Aurelien a écrit :
Salut,

Je tourne avec Debian AMD64 / SID, et j'essaie d'installer une
imprimante HL2030 dessus.
J'étais parvenu à quelque chose, il y a peu, mais le résultat éta it bof,
les impressions pas très belles, et les plantages réguliers (obligé de
relancer cups après l'arrivée d'un foomatic-rip failed).

Donc, comme aujourd'hui, ça ne fonctionnait pas, j'ai décidé de la
réinstaller, en utilisant les drivers 32 bits proposés par Brother.
Malheureusement, même en suivant leurs instructions, je me retrouve avec
le même problème, et à vrai dire j'ai une erreur très tôt dans
l'impasse, car l'install du driver foire.

Voilà les pages de référence (ci-dessous les opérations effectu ées, et
le résultat) :
http://www.debianforum.de/forum/viewtopic.php?f1&t–346&sidh2f ab0171a0
d6637e5aaed410383e8d (allemand)
http://solutions.brother.com/linux/sol/printer/linux/lpr_install.html
http://solutions.brother.com/linux/sol/printer/linux/cups_wrapper_install 5.
html

> For cups users:
> If you plan to install the CUPS Wrapper driver later, you DO NOT have to
> edit the "/etc/brprintcap" file.

OK, je n'y touche pas.

> For 64 bit users:
> lib32stdc++6 or ia32-libs is required to use our driver for 64 bit
> environment.

Je vérifie :
$> dpkg -l ia32-libs
ii ia32-libs 2.2 ia32 shared libraries for
use on amd64 and ia64 systems $> dpkg -l lib32stdc++6
ii lib32stdc++6 4.3.0-2 The GNU Standard C++
Library v3 (32 bit Version)

Donc, c'est OK.

> Also please copy the files which named start with "brlpdwrapper" in "
> /usr/lib/cups/filter" to "/usr/lib64/cups/filter" after the installation

Je retiens, mais l'histoire montrera que le .deb fait ça tout seul.

> Ignorable error message:
> If you see error message "/var/spool/lpd/ the folder or file doesn't
> exist". Please ignore it.

D'accord

> # Make a temporary directory on your HDD and download the LPR driver to
> # that directory.

Le driver est celui-ci :
http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_debia n/
brhl2030lpr-2.0.1-1.i386.deb (imprimante Brother HL-2030)

> # Log in as root user or use the "su" command.
> # When the driver has been downloaded run the relevant rpm/dpkg file
> # from the command prompt:
> dpkg -i --force-all --force-architecture xxxx.deb* (for dpkg Users)

$> dpkg -i --force-all --force-architecture
/home/orl/Imprimantes/brhl2030lpr-2.0.1-1.i386.deb dpkg - avertissement,
problème contourné à cause de --force :
l'architecture du paquet (i386) ne correspond pas à celle du système
(amd64) Sélection du paquet brhl2030lpr précédemment désélectio nné.
(Lecture de la base de données... 147566 fichiers et répertoires dé jà
installés.) Dépaquetage de brhl2030lpr (à partir de
.../brhl2030lpr-2.0.1-1.i386.deb) ... Paramétrage de brhl2030lpr (2.0.1 -1)
...
/var/lib/dpkg/info/brhl2030lpr.postinst: line 3:
/usr/local/Brother/inf/braddprinter: cannot execute binary file

OK, donc déjà, je sens le truc mal barré, parce qu'un message d'err eur
aussi tôt, c'est pas gagné.

> This will install the Brother printer driver onto your computer and
> configure it to use the USB interface.

Admettons....

> NOTE:
> If you are plainning to use cups, you do not need to make any further
> modifications. Please go to cupswrapper installation instruction for
> next steps. (Instruction pages differ between models.)

OK, j'y vais

> If you already have a Brother LPR driver installed, you may receive an
> error message. In this instance, run the install command again and use
> the :
> --force-all(For dpkg Users) or --force(For rpm Users) switches...

Je n'ai pas de driver installé (j'ai pris soin de virer toutes mes
version de l'imprimante dans cups avant, bien sûr), mais je retente
quand même. Strictement le même résultat.

Je continue.

> Install the cupswrapper driver.
> (i.e)
> For dpkg Users:
> dpkg -i --force-all --force-architecture
> cupswrapperHL2030-2.0.0-1.i386.deb

$> dpkg -i --force-all --force-architecture
/home/orl/Imprimantes/cupswrapperHL2030-2.0.1-2.i386.deb dpkg -
avertissement, problème contourné à cause de --force :
l'architecture du paquet (i386) ne correspond pas à celle du système
(amd64) Sélection du paquet cupswrapperhl2030 précédemment désé lectionné.
(Lecture de la base de données... 147582 fichiers et répertoires dé jà
installés.) Dépaquetage de cupswrapperhl2030 (à partir de
.../cupswrapperHL2030-2.0.1-2.i386.deb) ... Paramétrage de
cupswrapperhl2030 (2.0.1-2) ...
cp: `/usr/lib/cups/filter/brlpdwrapperHL2030' et
`/usr/lib64/cups/filter/brlpdwrapperHL2030' identifient le même fichier.
Restarting Common Unix Printing System: cupsd.

Je n'ai donc pas besoin de faire la copie, déjà parce que c'est pré vu
dans le script d'install, et en plus parce qu'il semble que ce soit déj à
les même fichiers.

Après, il faut lancer localhost:631 et ajouter l'imprimante.
je l'ai fait, cups ne me propose pas de suite d'ajouter l'imprimante. Je
le fais à la main. Je trouve une proposition de bus USB pour la HL2030,
je la prends, mais après, il n'y a pas de driver pour la 2030.
Bon, j'en reviens donc au même point.
J'essaie avec les drivers de la 2060, ceux de la 1250, en version
normale, HPIJS, et en LPR, mais rien n'y fait, ça ne fonctionne pas.

Pourtant, le type du premier lien, avec une distrib Etch n'a aucun
problème.

je ne vois pas du tout ce que j'ai pu mal faire, et je ne sais pas quoi
faire de plus.

Je suis preneur de toutes les explications, aides, etc.

Note : au passage, je n'ai pas bien suivi ce qui se passe avec gs, mais
si j'ai bien tout compris, ça change de nom. Ca fout un sacré bordel
dans pas mal d'applications qui peuvent imprimer (de lilypond à
evince!!)

Merci d'avance.

A bientôt.



--
======================== ======
ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring
period: 04-06/2008 ° Unexpect (www.unexpect.com - Montréal [CA]) - Eu rope
tour w/ Sebkha-Chott period: 09-12/2008 ° La Muette (www.myspace.com/mu ette
- Paris [FR]) - next touring period: 05/2008 (Bretagne) ° Mel-P
(www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008 Phone: +33
(0)95 234 72 48



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact rg
Aurelien
Le #9693961
C'est ce que j'avais fait à l'origine, mais le résultat était assez
crado la plupart du temps (HPIJS ou pas), les marges rarement valables
(souvent des dépassements), et surtout, je me retrouvais régulièrement
avec l'erreur susdite : foomatic-rip failed.
Je n'ai pas réussi à identifier exactement quand est-ce que cette erreur
se produit, mais je me demande si c'est pas quand c'est des PDF exportés
depuis OpenOffice. Enfin, c'est annexe, si tu me dis que le résultat du
proprio est moins bien, je suis déçu, parce que le résultat du libre est
pas très bien.

On Wed, Apr 02, 2008 at 08:24:52PM +0200, Yvan Martzluff wrote :
salut,

Sinon tu peux utiliser sans problème le driver Cups :
Brother HL-2060 Foomatic/hl1250

ça marche très bien. mieux que le driver proprio (comme souvent
d'ailleurs :-) ) qui utilise un wrapper pour LPR

A bientôt

Le mercredi 2 avril 2008 19:13, Aurelien a écrit :
> Salut,
>
> Je tourne avec Debian AMD64 / SID, et j'essaie d'installer une
> imprimante HL2030 dessus.
> J'étais parvenu à quelque chose, il y a peu, mais le résultat était bof,
> les impressions pas très belles, et les plantages réguliers (obligé de
> relancer cups après l'arrivée d'un foomatic-rip failed).
>
> Donc, comme aujourd'hui, ça ne fonctionnait pas, j'ai décidé de la
> réinstaller, en utilisant les drivers 32 bits proposés par Brother.
> Malheureusement, même en suivant leurs instructions, je me retrouve avec
> le même problème, et à vrai dire j'ai une erreur très tôt dans
> l'impasse, car l'install du driver foire.
>
> Voilà les pages de référence (ci-dessous les opérations effectuées, et
> le résultat) :
> http://www.debianforum.de/forum/viewtopic.php?f1&t–346&sidh2fab0171a0
>d6637e5aaed410383e8d (allemand)
> http://solutions.brother.com/linux/sol/printer/linux/lpr_install.html
> http://solutions.brother.com/linux/sol/printer/linux/cups_wrapper_install5.
>html
>
> > For cups users:
> > If you plan to install the CUPS Wrapper driver later, you DO NOT have to
> > edit the "/etc/brprintcap" file.
>
> OK, je n'y touche pas.
>
> > For 64 bit users:
> > lib32stdc++6 or ia32-libs is required to use our driver for 64 bit
> > environment.
>
> Je vérifie :
> $> dpkg -l ia32-libs
> ii ia32-libs 2.2 ia32 shared libraries for
> use on amd64 and ia64 systems $> dpkg -l lib32stdc++6
> ii lib32stdc++6 4.3.0-2 The GNU Standard C++
> Library v3 (32 bit Version)
>
> Donc, c'est OK.
>
> > Also please copy the files which named start with "brlpdwrapper" in "
> > /usr/lib/cups/filter" to "/usr/lib64/cups/filter" after the installation
>
> Je retiens, mais l'histoire montrera que le .deb fait ça tout seul.
>
> > Ignorable error message:
> > If you see error message "/var/spool/lpd/ the folder or file doesn't
> > exist". Please ignore it.
>
> D'accord
>
> > # Make a temporary directory on your HDD and download the LPR driver to
> > # that directory.
>
> Le driver est celui-ci :
> http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_debian/
>brhl2030lpr-2.0.1-1.i386.deb (imprimante Brother HL-2030)
>
> > # Log in as root user or use the "su" command.
> > # When the driver has been downloaded run the relevant rpm/dpkg file
> > # from the command prompt:
> > dpkg -i --force-all --force-architecture xxxx.deb* (for dpkg Users)
>
> $> dpkg -i --force-all --force-architecture
> /home/orl/Imprimantes/brhl2030lpr-2.0.1-1.i386.deb dpkg - avertissement,
> problème contourné à cause de --force :
> l'architecture du paquet (i386) ne correspond pas à celle du système
> (amd64) Sélection du paquet brhl2030lpr précédemment désélectionné.
> (Lecture de la base de données... 147566 fichiers et répertoires déjà
> installés.) Dépaquetage de brhl2030lpr (à partir de
> .../brhl2030lpr-2.0.1-1.i386.deb) ... Paramétrage de brhl2030lpr (2.0.1-1)
> ...
> /var/lib/dpkg/info/brhl2030lpr.postinst: line 3:
> /usr/local/Brother/inf/braddprinter: cannot execute binary file
>
> OK, donc déjà, je sens le truc mal barré, parce qu'un message d'erreur
> aussi tôt, c'est pas gagné.
>
> > This will install the Brother printer driver onto your computer and
> > configure it to use the USB interface.
>
> Admettons....
>
> > NOTE:
> > If you are plainning to use cups, you do not need to make any further
> > modifications. Please go to cupswrapper installation instruction for
> > next steps. (Instruction pages differ between models.)
>
> OK, j'y vais
>
> > If you already have a Brother LPR driver installed, you may receive an
> > error message. In this instance, run the install command again and use
> > the :
> > --force-all(For dpkg Users) or --force(For rpm Users) switches...
>
> Je n'ai pas de driver installé (j'ai pris soin de virer toutes mes
> version de l'imprimante dans cups avant, bien sûr), mais je retente
> quand même. Strictement le même résultat.
>
> Je continue.
>
> > Install the cupswrapper driver.
> > (i.e)
> > For dpkg Users:
> > dpkg -i --force-all --force-architecture
> > cupswrapperHL2030-2.0.0-1.i386.deb
>
> $> dpkg -i --force-all --force-architecture
> /home/orl/Imprimantes/cupswrapperHL2030-2.0.1-2.i386.deb dpkg -
> avertissement, problème contourné à cause de --force :
> l'architecture du paquet (i386) ne correspond pas à celle du système
> (amd64) Sélection du paquet cupswrapperhl2030 précédemment désélectionné.
> (Lecture de la base de données... 147582 fichiers et répertoires déjà
> installés.) Dépaquetage de cupswrapperhl2030 (à partir de
> .../cupswrapperHL2030-2.0.1-2.i386.deb) ... Paramétrage de
> cupswrapperhl2030 (2.0.1-2) ...
> cp: `/usr/lib/cups/filter/brlpdwrapperHL2030' et
> `/usr/lib64/cups/filter/brlpdwrapperHL2030' identifient le même fichier.
> Restarting Common Unix Printing System: cupsd.
>
> Je n'ai donc pas besoin de faire la copie, déjà parce que c'est prévu
> dans le script d'install, et en plus parce qu'il semble que ce soit déjà
> les même fichiers.
>
> Après, il faut lancer localhost:631 et ajouter l'imprimante.
> je l'ai fait, cups ne me propose pas de suite d'ajouter l'imprimante. Je
> le fais à la main. Je trouve une proposition de bus USB pour la HL2030,
> je la prends, mais après, il n'y a pas de driver pour la 2030.
> Bon, j'en reviens donc au même point.
> J'essaie avec les drivers de la 2060, ceux de la 1250, en version
> normale, HPIJS, et en LPR, mais rien n'y fait, ça ne fonctionne pas.
>
> Pourtant, le type du premier lien, avec une distrib Etch n'a aucun
> problème.
>
> je ne vois pas du tout ce que j'ai pu mal faire, et je ne sais pas quoi
> faire de plus.
>
> Je suis preneur de toutes les explications, aides, etc.
>
> Note : au passage, je n'ai pas bien suivi ce qui se passe avec gs, mais
> si j'ai bien tout compris, ça change de nom. Ca fout un sacré bordel
> dans pas mal d'applications qui peuvent imprimer (de lilypond à
> evince!!)
>
> Merci d'avance.
>
> A bientôt.
>
>
>
> --
> ============================= > > ORL /// AMMD Booking (www.ammd.net)
> ° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring
> period: 04-06/2008 ° Unexpect (www.unexpect.com - Montréal [CA]) - Europe
> tour w/ Sebkha-Chott period: 09-12/2008 ° La Muette (www.myspace.com/muette
> - Paris [FR]) - next touring period: 05/2008 (Bretagne) ° Mel-P
> (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008 Phone: +33
> (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact





--
============================= ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Aurelien
Le #9693941
Re !

Je viens justement de le faire, pour me persuader, au cas où, et après
avoir choisi le driver dont tu me parles, l'impression de la page de
test de cups s'arrête, et j'otbiens :
/usr/lib/cups/filter/foomatic-rip failed
toujours le même message.

Pour info, voici l'état de l'imprimante après coup :

HL2030 "/usr/lib/cups/filter/foomatic-rip failed"
Description : Brother HL2030
Lieu : Bureau
Marque et modèle : Brother HL-2060 Foomatic/hl1250 (recommended)
État de l'imprimante : ne fait rien, accepte les tâches, publique.
URI du matériel : usb://Brother/HL-2030%20series

Sauf qu'en pratique, à partir de là, je ne peux plus rien faire.


On Wed, Apr 02, 2008 at 08:24:52PM +0200, Yvan Martzluff wrote :
salut,

Sinon tu peux utiliser sans problème le driver Cups :
Brother HL-2060 Foomatic/hl1250

ça marche très bien. mieux que le driver proprio (comme souvent
d'ailleurs :-) ) qui utilise un wrapper pour LPR

A bientôt

Le mercredi 2 avril 2008 19:13, Aurelien a écrit :
> Salut,
>
> Je tourne avec Debian AMD64 / SID, et j'essaie d'installer une
> imprimante HL2030 dessus.
> J'étais parvenu à quelque chose, il y a peu, mais le résultat était bof,
> les impressions pas très belles, et les plantages réguliers (obligé de
> relancer cups après l'arrivée d'un foomatic-rip failed).
>
> Donc, comme aujourd'hui, ça ne fonctionnait pas, j'ai décidé de la
> réinstaller, en utilisant les drivers 32 bits proposés par Brother.
> Malheureusement, même en suivant leurs instructions, je me retrouve avec
> le même problème, et à vrai dire j'ai une erreur très tôt dans
> l'impasse, car l'install du driver foire.
>
> Voilà les pages de référence (ci-dessous les opérations effectuées, et
> le résultat) :
> http://www.debianforum.de/forum/viewtopic.php?f1&t–346&sidh2fab0171a0
>d6637e5aaed410383e8d (allemand)
> http://solutions.brother.com/linux/sol/printer/linux/lpr_install.html
> http://solutions.brother.com/linux/sol/printer/linux/cups_wrapper_install5.
>html
>
> > For cups users:
> > If you plan to install the CUPS Wrapper driver later, you DO NOT have to
> > edit the "/etc/brprintcap" file.
>
> OK, je n'y touche pas.
>
> > For 64 bit users:
> > lib32stdc++6 or ia32-libs is required to use our driver for 64 bit
> > environment.
>
> Je vérifie :
> $> dpkg -l ia32-libs
> ii ia32-libs 2.2 ia32 shared libraries for
> use on amd64 and ia64 systems $> dpkg -l lib32stdc++6
> ii lib32stdc++6 4.3.0-2 The GNU Standard C++
> Library v3 (32 bit Version)
>
> Donc, c'est OK.
>
> > Also please copy the files which named start with "brlpdwrapper" in "
> > /usr/lib/cups/filter" to "/usr/lib64/cups/filter" after the installation
>
> Je retiens, mais l'histoire montrera que le .deb fait ça tout seul.
>
> > Ignorable error message:
> > If you see error message "/var/spool/lpd/ the folder or file doesn't
> > exist". Please ignore it.
>
> D'accord
>
> > # Make a temporary directory on your HDD and download the LPR driver to
> > # that directory.
>
> Le driver est celui-ci :
> http://solutions.brother.com/Library/sol/printer/linux/rpmfiles/lpr_debian/
>brhl2030lpr-2.0.1-1.i386.deb (imprimante Brother HL-2030)
>
> > # Log in as root user or use the "su" command.
> > # When the driver has been downloaded run the relevant rpm/dpkg file
> > # from the command prompt:
> > dpkg -i --force-all --force-architecture xxxx.deb* (for dpkg Users)
>
> $> dpkg -i --force-all --force-architecture
> /home/orl/Imprimantes/brhl2030lpr-2.0.1-1.i386.deb dpkg - avertissement,
> problème contourné à cause de --force :
> l'architecture du paquet (i386) ne correspond pas à celle du système
> (amd64) Sélection du paquet brhl2030lpr précédemment désélectionné.
> (Lecture de la base de données... 147566 fichiers et répertoires déjà
> installés.) Dépaquetage de brhl2030lpr (à partir de
> .../brhl2030lpr-2.0.1-1.i386.deb) ... Paramétrage de brhl2030lpr (2.0.1-1)
> ...
> /var/lib/dpkg/info/brhl2030lpr.postinst: line 3:
> /usr/local/Brother/inf/braddprinter: cannot execute binary file
>
> OK, donc déjà, je sens le truc mal barré, parce qu'un message d'erreur
> aussi tôt, c'est pas gagné.
>
> > This will install the Brother printer driver onto your computer and
> > configure it to use the USB interface.
>
> Admettons....
>
> > NOTE:
> > If you are plainning to use cups, you do not need to make any further
> > modifications. Please go to cupswrapper installation instruction for
> > next steps. (Instruction pages differ between models.)
>
> OK, j'y vais
>
> > If you already have a Brother LPR driver installed, you may receive an
> > error message. In this instance, run the install command again and use
> > the :
> > --force-all(For dpkg Users) or --force(For rpm Users) switches...
>
> Je n'ai pas de driver installé (j'ai pris soin de virer toutes mes
> version de l'imprimante dans cups avant, bien sûr), mais je retente
> quand même. Strictement le même résultat.
>
> Je continue.
>
> > Install the cupswrapper driver.
> > (i.e)
> > For dpkg Users:
> > dpkg -i --force-all --force-architecture
> > cupswrapperHL2030-2.0.0-1.i386.deb
>
> $> dpkg -i --force-all --force-architecture
> /home/orl/Imprimantes/cupswrapperHL2030-2.0.1-2.i386.deb dpkg -
> avertissement, problème contourné à cause de --force :
> l'architecture du paquet (i386) ne correspond pas à celle du système
> (amd64) Sélection du paquet cupswrapperhl2030 précédemment désélectionné.
> (Lecture de la base de données... 147582 fichiers et répertoires déjà
> installés.) Dépaquetage de cupswrapperhl2030 (à partir de
> .../cupswrapperHL2030-2.0.1-2.i386.deb) ... Paramétrage de
> cupswrapperhl2030 (2.0.1-2) ...
> cp: `/usr/lib/cups/filter/brlpdwrapperHL2030' et
> `/usr/lib64/cups/filter/brlpdwrapperHL2030' identifient le même fichier.
> Restarting Common Unix Printing System: cupsd.
>
> Je n'ai donc pas besoin de faire la copie, déjà parce que c'est prévu
> dans le script d'install, et en plus parce qu'il semble que ce soit déjà
> les même fichiers.
>
> Après, il faut lancer localhost:631 et ajouter l'imprimante.
> je l'ai fait, cups ne me propose pas de suite d'ajouter l'imprimante. Je
> le fais à la main. Je trouve une proposition de bus USB pour la HL2030,
> je la prends, mais après, il n'y a pas de driver pour la 2030.
> Bon, j'en reviens donc au même point.
> J'essaie avec les drivers de la 2060, ceux de la 1250, en version
> normale, HPIJS, et en LPR, mais rien n'y fait, ça ne fonctionne pas.
>
> Pourtant, le type du premier lien, avec une distrib Etch n'a aucun
> problème.
>
> je ne vois pas du tout ce que j'ai pu mal faire, et je ne sais pas quoi
> faire de plus.
>
> Je suis preneur de toutes les explications, aides, etc.
>
> Note : au passage, je n'ai pas bien suivi ce qui se passe avec gs, mais
> si j'ai bien tout compris, ça change de nom. Ca fout un sacré bordel
> dans pas mal d'applications qui peuvent imprimer (de lilypond à
> evince!!)
>
> Merci d'avance.
>
> A bientôt.
>
>
>
> --
> ============================= > > ORL /// AMMD Booking (www.ammd.net)
> ° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring
> period: 04-06/2008 ° Unexpect (www.unexpect.com - Montréal [CA]) - Europe
> tour w/ Sebkha-Chott period: 09-12/2008 ° La Muette (www.myspace.com/muette
> - Paris [FR]) - next touring period: 05/2008 (Bretagne) ° Mel-P
> (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008 Phone: +33
> (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact





--
============================= ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Papinux
Le #9693841
Le Wed, 2 Apr 2008 23:33:57 +0200, Aurelien wrote :

Re !

Je viens justement de le faire, pour me persuader, au cas où, et après
avoir choisi le driver dont tu me parles, l'impression de la page de
test de cups s'arrête, et j'otbiens :
/usr/lib/cups/filter/foomatic-rip failed
toujours le même message.




Regarde si le paquet gs est bien installé.
Le cas échéant, passe cups en mode debug:
dans /etc/cups/cupsd.conf , remplace
LogLevel warning
par
LogLevel debug

Puis relancer cups

Lancer une impression puis regarder /var/log/cups/error_log

(ne pas oublier, à l'issue, de remettre LogLevel à warning)

@+

--
Aurelien
Le #9693751
On Thu, Apr 03, 2008 at 01:19:39PM +0200, Papinux wrote :
Le Wed, 2 Apr 2008 23:33:57 +0200, Aurelien wrote :

> Re !
>
> Je viens justement de le faire, pour me persuader, au cas où, et après
> avoir choisi le driver dont tu me parles, l'impression de la page de
> test de cups s'arrête, et j'otbiens :
> /usr/lib/cups/filter/foomatic-rip failed
> toujours le même message.
>

Regarde si le paquet gs est bien installé.



Le paquet gs est installé et à jour. Ceci dit, si ça peut être lié à ce
paquet, j'ai d'autres problèmes dessus (impossible d'exécuter lilypond
pour faire un pdf ou un ps), donc à voir. Je n'ai pourtant eu aucun bug
d'annoncé. Mais il y a une histoire de changement de nom que je n'ai ni
suivie ni comprise (du coup)/

Le cas échéant, passe cups en mode debug:
dans /etc/cups/cupsd.conf , remplace
LogLevel warning
par
LogLevel debug

Puis relancer cups

Lancer une impression puis regarder /var/log/cups/error_log

(ne pas oublier, à l'issue, de remettre LogLevel à warning)



OK, le résultat est carrément ultra long, donc je ne vais pas le copier.
Dans les trucs qui ressemblent à des erreurs (ou qui sonnent vaguement
négatif) :

[...]
D [04/Apr/2008:08:33:04 +0200] [Job 97] GhostScript extra search path ('GS_LIB'): /usr/share/cups/fonts
D [04/Apr/2008:08:33:04 +0200] [Job 97] Pondering option 'job-uuid=urn:uuid:7e3bc23f-ea7c-3405-5e71-7027a1aa4aab'
D [04/Apr/2008:08:33:04 +0200] [Job 97] Unknown option job-uuid=urn:uuid:7e3bc23f-ea7c-3405-5e71-7027a1aa4aab.
[...]
D [04/Apr/2008:08:33:04 +0200] [Job 97] perl: warning: Falling back to the standard locale ("C").
D [04/Apr/2008:08:33:04 +0200] [Job 97] foomatic-gswrapper: gs '-dBATCH' '-dPARANOIDSAFER' '-dNOPAUSE' '-sDEVICE=hl1250' '-dEconoMode=0' '-dSourceTray=0' '-sOutputFile=/dev/fd/3' '-_' 3>&1 1>&2 D [04/Apr/2008:08:33:04 +0200] [Job 97] sh: gs: command not found
[...]
D [04/Apr/2008:08:33:04 +0200] [Job 97] Process dying with "The renderer command line returned an unrecognized error code 127.", exit stat: 1
D [04/Apr/2008:08:33:04 +0200] [Job 97] error: Illegal seek (29)
D [04/Apr/2008:08:33:04 +0200] [Job 97] The renderer command line returned an unrecognized error code 127.
[...]
D [04/Apr/2008:08:33:04 +0200] [Job 97] Process dying with "Error closing renderer", exit stat: 1
D [04/Apr/2008:08:33:04 +0200] [Job 97] error: Bad file descriptor (9)
D [04/Apr/2008:08:33:04 +0200] [Job 97] Error closing renderer
E [04/Apr/2008:08:33:04 +0200] PID 2477 (/usr/lib/cups/filter/foomatic-rip) stopped with status 1!
[...]
E [04/Apr/2008:08:33:04 +0200] [Job 97] Job stopped due to filter errors.

On y revient : gs: command not found. C'est exactement le problème que
j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet transitionnel) :
$> dpkg -l gs
ii gs 8.62.dfsg.1-2 Transitional package


--
============================= ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
laurux
Le #9693741
Le Fri, 4 Apr 2008 08:45:13 +0200, Aurelien wrote :

[...]

On y revient : gs: command not found. C'est exactement le problème que
j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet transiti onnel) :
$> dpkg -l gs
ii gs 8.62.dfsg.1-2 Transitional package




J'ai eu le même problème: il faut installer le paquet ghostscript.

@+

--
Aurelien
Le #9693731
On Fri, Apr 04, 2008 at 01:21:53PM +0200, laurux wrote :
Le Fri, 4 Apr 2008 08:45:13 +0200, Aurelien wrote :

[...]
>
> On y revient : gs: command not found. C'est exactement le problème que
> j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet transitionnel) :
> $> dpkg -l gs
> ii gs 8.62.dfsg.1-2 Transitional package
>
>
J'ai eu le même problème: il faut installer le paquet ghostscript.



C'est le premier truc que j'avais vérifié quand j'avais eu le souci avec
lilypond, mais non, ghostscript est bien installé :

$> dpkg -l ghostscript
ii ghostscript 8.61.dfsg.1~svn8187-3 The GPL Ghostscript PostScript/PDF interpreter

Mais malgré tout :
$> which gs

(la réponse est vide)


--
============================= ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9693721
Aurelien, vendredi 4 avril 2008, 14:18:55 CEST

On Fri, Apr 04, 2008 at 01:21:53PM +0200, laurux wrote :
> Le Fri, 4 Apr 2008 08:45:13 +0200, Aurelien wrote :
>
> [...]
> >
> > On y revient : gs: command not found. C'est exactement le problè me que
> > j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet t ransitionnel) :
> > $> dpkg -l gs
> > ii gs 8.62.dfsg.1-2 Transitional package
> >
> >
> J'ai eu le même problème: il faut installer le paquet ghostsc ript.

C'est le premier truc que j'avais vérifié quand j'avais eu le s ouci avec
lilypond, mais non, ghostscript est bien installé :

$> dpkg -l ghostscript
ii ghostscript 8.61.dfsg.1~svn8187-3 The GPL Ghostscript PostS cript/PDF interpreter



Il vient d’où ton paquet pour avoir cette version ?
Ubuntu ?

Mais malgré tout :
$> which gs

(la réponse est vide)



Sur un Sid amd64 à jour :
$ apt-file search /usr/bin/gs
ghostscript: /usr/bin/gs
[… et d’autres pour /usr/bin/gsXXX …]

et c’est un binaire (pas un lien, une alternative ou une astuce).

Aussi :

$ apt-cache policy ghostscript
ghostscript:
Installé : 8.62.dfsg.1-2
Candidat : 8.62.dfsg.1-2
Table de version :
*** 8.62.dfsg.1-2 0
500 http://ftp.fr.debian.org sid/main Packages
100 /var/lib/dpkg/status

Testing est aussi dans mon sources.list, donc ghostscript
n’est pas dans Lenny. En revanche, gs y est :

$ apt-cache policy gs
gs:
Installé : (aucun)
Candidat : 8.62.dfsg.1-2
Table de version :
8.62.dfsg.1-2 0
500 http://ftp.fr.debian.org sid/main Packages
8.56.dfsg.1-1.1 0
500 http://ftp.fr.debian.org testing/main Packages

--
Sylvain Sauvage
Guy Roussin
Le #9693711
Et que dit :
# update-alternatives --config gs

guy

Aurelien a écrit :
On Fri, Apr 04, 2008 at 01:21:53PM +0200, laurux wrote :
Le Fri, 4 Apr 2008 08:45:13 +0200, Aurelien wrote :

[...]
On y revient : gs: command not found. C'est exactement le problème que
j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet tran sitionnel) :
$> dpkg -l gs
ii gs 8.62.dfsg.1-2 Transitional package




J'ai eu le même problème: il faut installer le paquet ghostscript.



C'est le premier truc que j'avais vérifié quand j'avais eu le souci avec
lilypond, mais non, ghostscript est bien installé :

$> dpkg -l ghostscript
ii ghostscript 8.61.dfsg.1~svn8187-3 The GPL Ghostscript Pos tScript/PDF interpreter

Mais malgré tout :
$> which gs

(la réponse est vide)




Aurelien
Le #9693691
On Fri, Apr 04, 2008 at 02:37:36PM +0200, Sylvain Sauvage wrote :
Aurelien, vendredi 4 avril 2008, 14:18:55 CEST
>
> On Fri, Apr 04, 2008 at 01:21:53PM +0200, laurux wrote :
> > Le Fri, 4 Apr 2008 08:45:13 +0200, Aurelien wrote :
> >
> > [...]
> > >
> > > On y revient : gs: command not found. C'est exactement le problème que
> > > j'ai avec lilypond. Pourtant, gs est installé (c'est un paquet transitionnel) :
> > > $> dpkg -l gs
> > > ii gs 8.62.dfsg.1-2 Transitional package
> > >
> > >
> > J'ai eu le même problème: il faut installer le paquet ghostscript.
>
> C'est le premier truc que j'avais vérifié quand j'avais eu le souci avec
> lilypond, mais non, ghostscript est bien installé :
>
> $> dpkg -l ghostscript
> ii ghostscript 8.61.dfsg.1~svn8187-3 The GPL Ghostscript PostScript/PDF interpreter

Il vient d’où ton paquet pour avoir cette version ?
Ubuntu ?




Heu, non, a priori de la distrib de base.
apt-cache policy ghostscript
ghostscript:
Installé : 8.61.dfsg.1~svn8187-3
Candidat : 8.61.dfsg.1~svn8187-3
Étiquette de paquet : 8.61.dfsg.1~svn8187-3
Table de version :
8.62.dfsg.1-2 1000
500 http://mirrors.ircam.fr sid/main Packages
*** 8.61.dfsg.1~svn8187-3 1000
100 /var/lib/dpkg/status

OK, j'ai un pin qui traînait (je ne me rappelais pas avoir bloqué un
upgrade, mais bon)

Je vais remettre ça en état.
Merci.



> Mais malgré tout :
> $> which gs
>
> (la réponse est vide)

Sur un Sid amd64 à jour :
$ apt-file search /usr/bin/gs
ghostscript: /usr/bin/gs
[… et d’autres pour /usr/bin/gsXXX …]

et c’est un binaire (pas un lien, une alternative ou une astuce).

Aussi :

$ apt-cache policy ghostscript
ghostscript:
Installé : 8.62.dfsg.1-2
Candidat : 8.62.dfsg.1-2
Table de version :
*** 8.62.dfsg.1-2 0
500 http://ftp.fr.debian.org sid/main Packages
100 /var/lib/dpkg/status

Testing est aussi dans mon sources.list, donc ghostscript
n’est pas dans Lenny. En revanche, gs y est :

$ apt-cache policy gs
gs:
Installé : (aucun)
Candidat : 8.62.dfsg.1-2
Table de version :
8.62.dfsg.1-2 0
500 http://ftp.fr.debian.org sid/main Packages
8.56.dfsg.1-1.1 0
500 http://ftp.fr.debian.org testing/main Packages

--
Sylvain Sauvage





--
============================= ORL /// AMMD Booking (www.ammd.net)
° Sebkha-Chott (www.sebkhachott.net - Ohreland [FR]) - next touring period: 04-06/2008
° Unexpect (www.unexpect.com - Montréal [CA]) - Europe tour w/ Sebkha-Chott period: 09-12/2008
° La Muette (www.myspace.com/muette - Paris [FR]) - next touring period: 05/2008 (Bretagne)
° Mel-P (www.mel-p.net - Le Mans [FR]) - next touring period: 09/2008
Phone: +33 (0)95 234 72 48

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme