bug affichage listes déroulantes ?

Le
Francis SLAWNY
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la zone
de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la zone
de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
3stone
Le #20394501
Salut,

Francis SLAWNY wrote:
XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien
les données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de
la zone de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la
zone de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans
m'en rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet
escompté. Quelqu'un a-t-il une idée ?




Si au formatage tu utilises le signe ">", vire le...

--
A+
Pierre (3stone) Access MVP
Perso: http://www.3stone.be/
MPFA: http://www.mpfa.info/ (infos générales)
Bear76
Le #20394491
Francis SLAWNY a formulé ce mercredi :
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la zone
de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la zone de
liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS



Bonsoir,
Si ce n'est que sur l'autre machine tu ne précises pas si elle a la
même configuration. Et je doute.
J'ai été confronté à un problème identique en effectuant la SP3 sur mon
Pack office 2003 Pro.
Peux-tu vérifier dans la table source de ta listebox si les champs
concernés n'ont pas une quelconque valeur dans la propriété "Format" ?
Supprimer dans ce cas la ou les valeurs.
@+
Francis SLAWNY
Le #20394571
Je doute aussi qu'elle ait la même config. Mais je ne sais pas où est la
différence.
Quant à la table source, elle a effectivement @ dans la proprieté format.
Mais c'est une table excel attachée et je n'arrive pas à supprimer cette
proprieté.


Bonsoir,
Si ce n'est que sur l'autre machine tu ne précises pas si elle a la même
configuration. Et je doute.
J'ai été confronté à un problème identique en effectuant la SP3 sur mon
Pack office 2003 Pro.
Peux-tu vérifier dans la table source de ta listebox si les champs
concernés n'ont pas une quelconque valeur dans la propriété "Format" ?
Supprimer dans ce cas la ou les valeurs.
@+




Francis SLAWNY
Le #20394701
Sur l'autre machine il s'agit de la même base mais la table attachée n'est
pas une table excel mais une table WinDev via ODBC
Gilbert
Le #20395561
Bonjour,

Regarde si cette page correspond à ton problème
http://support.microsoft.com/kb/945674

--
Cordialement,

Gilbert


"Francis SLAWNY" news:
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la


zone
de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la zone
de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS




Francis SLAWNY
Le #20395701
C'était bien ça.
Merci à tous pour les réponses.
FS


*
"Gilbert" %
Bonjour,

Regarde si cette page correspond à ton problème
http://support.microsoft.com/kb/945674

--
Cordialement,

Gilbert


"Francis SLAWNY" news:
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la


zone
de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la
zone
de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS








Goupil
Le #20397931
Bonjour,

J'ai été confronté plus d'une fois à ce bug Microsoft.
J'ai contourné le problème en créant une fonction qui ne fait rien:

Public Function QueDale(a As String) As String
QueDale = a
End Function

C'est la fonction la plus stupide que j'aie jamais faite, mais si tu
l'utilise dans la requête de ta liste déroulante, le champ qui
n'apparaissait pas va enfin apparaitre.

Bizarre... mais bon...

Goup'

"Francis SLAWNY" news:
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la
zone de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la zone
de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS



Francis SLAWNY
Le #20398061
Bizarre en effet.
Qu'est-ce qui t'a donné l'idée d'utiliser une fonction qui ne fait rien ?
FS


"Goupil" 4adff4d6$0$913$
Bonjour,

J'ai été confronté plus d'une fois à ce bug Microsoft.
J'ai contourné le problème en créant une fonction qui ne fait rien:

Public Function QueDale(a As String) As String
QueDale = a
End Function

C'est la fonction la plus stupide que j'aie jamais faite, mais si tu
l'utilise dans la requête de ta liste déroulante, le champ qui
n'apparaissait pas va enfin apparaitre.

Bizarre... mais bon...

Goup'

"Francis SLAWNY" news:
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la
zone de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la
zone de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS







Goupil
Le #20405981
Microsoft

;-)

Goup'

"Francis SLAWNY" news:
Bizarre en effet.
Qu'est-ce qui t'a donné l'idée d'utiliser une fonction qui ne fait rien ?
FS


"Goupil" 4adff4d6$0$913$
Bonjour,

J'ai été confronté plus d'une fois à ce bug Microsoft.
J'ai contourné le problème en créant une fonction qui ne fait rien:

Public Function QueDale(a As String) As String
QueDale = a
End Function

C'est la fonction la plus stupide que j'aie jamais faite, mais si tu
l'utilise dans la requête de ta liste déroulante, le champ qui
n'apparaissait pas va enfin apparaitre.

Bizarre... mais bon...

Goup'

"Francis SLAWNY" news:
Bonjour

XP SP3, Access 2003 SP3

Il m'arrive un truc bizarre.
Lorsque je crée une zone de liste, la zone en question contient bien les
données qu'elle doit contenir (à partir d'une table par exemple)
(J'ai testé en faisant afficher dans une zone de texte le contenu de la
zone de liste)
Mais ces données ne s'affichent pas dans la zone de liste.
Si je teste avec une autre machine cette même base, les données de la
zone de liste s'affichent bel et bien.
S'agit-il d'une erreur de configuration que j'aurais modifiée sans m'en
rendre compte ?
J'ai désinstallé et reinstallé access et ça n'a pas eu l'effet escompté.
Quelqu'un a-t-il une idée ?
Merci de vos lumières.
FS











Publicité
Poster une réponse
Anonyme