bug dans le terminal?

Le
steve
Salut,

Sur une testing à jour.

Sous zsh, voici ce qu'il se passe :

$ export LC_ALL=C
$ sux
Password:
bash: cannot set terminal process group (-1) : Inappropriate ioctl for device
bash: no job control in this shell

Bon

Ensuite, mettons que :

# tail -f /var/log/syslog

puis je termine le processus avec control-C, et :

Session terminated, terminating shell killed.
zsh: exit 255 sux
$

je me retrouve avec un shell sous mon user (plus root) !
De plus, j'ai les messages de syslog qui continuent de s'afficher dans le
terminal..

Est-ce que vous avez pareil ? J'ai fait une rechercher sur le net, il y
a pas mal de résultats, mais rien en ce qui concerne Debian.

Est-ce parce que je suis malade ou est-ce un vrai bug ?

Merci pour votre aide,
Steve

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20120223163004.GA13492@mangoo.homelinux.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
nicolas.patrois
Le #24275491
Le 23/02/2012 17:30:05, steve a écrit :

Sous zsh, voici ce qu'il se passe :

$ export LC_ALL=C



Et export LC_ALL='C' ?

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des
humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
steve
Le #24275771
Le 23-02-2012, à 19:22:55 +0100, () a écrit :

Le 23/02/2012 17:30:05, steve a écrit :

> Sous zsh, voici ce qu'il se passe :

> $ export LC_ALL=C

Et export LC_ALL='C' ?



Cela ne change rien. C'est juste pour que les messages soient en
anglais. Le fond du problème persiste que ce soit en français, anglais
ou autres langues bizarres... :-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
steve
Le #24301181
Le 23-02-2012, à 20:58:59 +0100, steve () a écrit :

Le 23-02-2012, à 19:22:55 +0100, () a écrit :

> Le 23/02/2012 17:30:05, steve a écrit :
>
> > Sous zsh, voici ce qu'il se passe :
>
> > $ export LC_ALL=C
>
> Et export LC_ALL='C' ?

Cela ne change rien. C'est juste pour que les messages soient en
anglais. Le fond du problème persiste que ce soit en français, anglais
ou autres langues bizarres... :-)




Après plusieurs mises à jour du système, ce comportement persiste. Ce
n'est que chez moi que ça arrive ? Bizarre...
Je parlais de zsh mais c'est pareil sous bash.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme