Bug ou pas avec vserver et apt-listbugs ?

Le
Aurélien
Bonjour à tous,

Je suis en train de m'amuser à monter un serveur - Debian testing. Par =

mesure de sécurité et aussi pour tester, je veux cloisonner les
différents services. Sur le site Unix Garden, j'ai lu un article
concernant la technologie de virtualisation, enfin de cloisonnement =

plutôt, vserver.
J'ai donc installé les paquets linux-2.6vserver-686, ses
dépendances, util-vserver et vserver-debiantools.
Avec "newvserver", j'ai créé un premier serveur virtuel.
Malheureusement, lorsque je veux installer mes services dans ce
serveur - que ce soit par apt-get ou aptitude - j'ai une erreur qui me =

dit que le script d'installation ne trouve pas la commande apt-
listbugs (celle-ci est installée dans le système hôte).

Après désinstallation de l'utilitaire apt-lisbugs du système hôte,=
je
recréé un serveur virtuel. Et là, lorsque je teste l'installation =
des
services désirés, il n'y a plus de problème avec apt-listbugs.

Quelqu'un a-t-il une explication ? Serait-ce un bug ?
Merci d'avance.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Glennie Vignarajah
Le #18283391
On Saturday 03 January 2009 00:19:14 Aurélien wrote:

Bonjour,

Avec "newvserver", j'ai créé un premier serveur virtuel.
Malheureusement, lorsque je veux installer mes services dans ce
serveur - que ce soit par apt-get ou aptitude - j'ai une erreur qui me
dit que le script d'installation ne trouve pas la commande apt-
listbugs (celle-ci est installée dans le système hôte).

Après désinstallation de l'utilitaire apt-lisbugs du système hôte , je
recréé un serveur virtuel. Et là, lorsque je teste l'installation d es
services désirés, il n'y a plus de problème avec apt-listbugs.



Le lancement de apt-listbugs est défini dans /etc/apt/apt.conf.d/??apt-
listbugs. *Normalement*, vous devez avoir un /etc/ pour le serveur hôte e t un
autre pour serveur virtuelle.
Si la déinstallation de apt-listbugs sur le serveur hôte supprime votr e
problème, cela veut dire qu'il y a des fichiers de "etc" partagés entr e le
serveur hôte et virtuelle.
Que donne la commande 'ls -ald /etc/apt/', 'ls -ald /etc/apt/apt.conf.d', 'ls
-al /etc/apt/apt.conf.d/??apt-listbugs'?
A+
--
Glennie Vignarajah

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme