Bug Samba #821002

Le
Sil
Bonjour,

Depuis la fin de la semaine dernière, il y a un bug sur Samba. Ce bug
est noté « En cours de traitement ».
Faut-il empêcher la mise à jour vers cette version et attendre la
prochaine ? Je voudrais être sûr de ne pas casser mon installation ?

Version installée : 2:4.2.10+dfsg-0+deb8u1
Version en attende de mise à jour : 2:4.2.10+dfsg-0+deb8u2

cat /etc/debian_version
8.4

Par avance merci.
Sil
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre Malard
Le #26395636
--Apple-Mail=_8CAD8CE1-B198-469F-AC65-A05E1EA800CB
Content-Type: multipart/alternative;
boundary="Apple-Mail=_2B8CD99A-3569-46AE-827F-6632395EE5F9"


--Apple-Mail=_2B8CD99A-3569-46AE-827F-6632395EE5F9
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset=utf-8

Le 18 avr. 2016 à 08:46, Sil

Bonjour,

Depuis la fin de la semaine dernière, il y a un bug sur Samba. Ce bug est noté « En cours de traitement ».
Faut-il empêcher la mise à jour vers cette version et attendre la prochaine ? Je voudrais être sûr de ne pas casser mon installation ?

Version installée : 2:4.2.10+dfsg-0+deb8u1
Version en attende de mise à jour : 2:4.2.10+dfsg-0+deb8u2

cat /etc/debian_version
8.4



Tout ce que je peux témoigner c’est que je n’ai pas eu ta prudence, que j’ai fais la MAJ hier et qu’aujourd⠀™hui mon serveur jessie ne sais plus comment s’authentifier sur mon serveur PDC… GRRRRRRR
:/etc/samba# net rpc join -W <DOMAINE> -U <ADMIN>
No realm has been specified! Do you really want to join an Active Directory server?
Enter Administrator's password:
smb_signing_good: BAD SIG: seq 1
Failed to join domain: failed to lookup DC info for domain '<DOMAINE>' over rpc: Access denied

Et que, du coup, plus personne n’a accès aux partages servis par ce serveur.

Je trouve la plaisanterie d’un goût très moyen.

--
Pierre Malard

«A force de faire "la rue" on est devenu le caniveau»
Abd Al Malik - Céli ne
| _,,,---,,_
/,`.-'`' -. ;-;;,_
|,4- ) )-,_. , ( `'-'
'---''(_/--' `-'_) πr

perl -e '$_=q#: 3| 5_,3-3,2_: 3/,`.'"'"'`'"'"' 5-. ;-;;,_: |,A- ) )-,_. , ( `'"'"'-'"'"': '"'"'-3'"'"'2(_/--'"'"' `-'"'"'_): 24πr::#;y#:#n#;s#(D)(d+)#$1x$2#ge;print'
- --> Ce message n’engage que son auteur <--


--Apple-Mail=_2B8CD99A-3569-46AE-827F-6632395EE5F9
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
charset=utf-8

</div>
<br class=""></body></html>
--Apple-Mail=_2B8CD99A-3569-46AE-827F-6632395EE5F9--

--Apple-Mail=_8CAD8CE1-B198-469F-AC65-A05E1EA800CB
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename=signature.asc
Content-Type: application/pgp-signature;
name=signature.asc
Content-Description: Message signed with OpenPGP using GPGMail

-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - https://gpgtools.org

iQIcBAEBCgAGBQJXFRPyAAoJELzRDw+wKgIyq+IP/3n8LHNEphWNht2W4w1L6+c3
fSPVmgIXFwSOGau+R5tigjxGITuLnj8ltDth6gqDPpOppB8ftMrjo5yfqeNHTLCG
4f1dTAblebjusWqdUdZX3YQPq0JPCg3mNAFe3ygSWBTnf2E9bCdj3JuRmE9RIuf2
Pl5e+YwZREi5d7vnFcP1aUqBeWyu5286qTJk/6fuJlYLetbVx9l28MgK5Zc7BG8C
S4OJScKGgtLeXVhtRZEzsWMCTY8ySjxowIKIx4it1Kdcz1vybEJEupHJoImGdEiP
4bCofsXMQHnZJfGbdNvcIfQrlfWrmVIpeRb7ijeoKTn7qQl9bNCrkzmMWBRhA+k5
UXRn3Qxqn+sjjq3ypvMxKp+Nqh6tEGva7EMXtQkmthB1GBQkb1W6uioBOxj3+Iqk
ZRNbo639XlUSk/RZ9StrFRcfEfrheGiMnMh5PPmHj38sf9/qf6QWghOESSuCmkDx
S4pR/bvHvYlVqY4+vku9xDcp1OLJ1k6joTFTDxOuYFWBq6ifmeKTfSSuiqmvTfwZ
hYWqkyZvlNU+mc+5kVPBJF4l9sO4lo5BStPBfTYRglWX2OROoQ4HqdOi7or+10N2
Vjz2jjyXF7t5c3RkqxcrfmfD7MBQ4YZgMY71sZXv6vu8HFxbxBfYhnlJgCcWMEDR
Q4BHJmvcawd5P3HRvgPs
=/7FH
-----END PGP SIGNATURE-----

--Apple-Mail=_8CAD8CE1-B198-469F-AC65-A05E1EA800CB--
andre_debian
Le #26395638
Quel est ce bug ?

On Monday 18 April 2016 08:46:17 Sil wrote:
Depuis la fin de la semaine dernière, il y a un bug sur Samba. Ce bu g
est noté « En cours de traitement ».
Faut-il empêcher la mise à jour vers cette version et attendre la
prochaine ? Je voudrais être sûr de ne pas casser mon installat ion ?
Version installée : 2:4.2.10+dfsg-0+deb8u1
Version en attende de mise à jour : 2:4.2.10+dfsg-0+deb8u2
cat /etc/debian_version
8.4
Par avance merci.
Sil
Le #26395658
Le 18/04/2016 19:23, a écrit :
Quel est ce bug ?


Bonjour,

Apparemment il y aurait un problème lors de la mise à jour du paquet
samba-libs :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug‚1002

Copie du rapport de bug #821002 :
samba: Error upgrading from deb8u1 to deb8u2. Missing Replaces for
libsmbd-base.so.0

Upgrading from +deb8u1 to +deb8u2 fails with this error:

Unpacking samba-libs:amd64 (2:4.2.10+dfsg-0+deb8u2) over (2:4.2.10+dfsg-0+deb8u1) ...
dpkg: error processing archive /var/cache/apt/archives/samba-libs_2%3a4.2.10+dfsg-0+deb8u2_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/samba/libsmbd-base.so.0', which is also in package samba 2:4.2.10+dfsg-0+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

De plus je viens de voir que la mise à jour vers Samba 4.2 a cassé Backuppc.
Les sauvegardes depuis des partages Windows ne sont plus possibles.
Je pense que les utilisateurs de rsync ne sont impactés.
( Bug #820963 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug‚0963 )

Sil
Pierre Malard
Le #26395691
--Apple-Mail=_875FE553-2829-49C8-BDF9-99606155A896
Content-Type: multipart/alternative;
boundary="Apple-Mail=_1EDD5D4F-C3B6-4A94-ACAE-BF3FEF09DD59"


--Apple-Mail=_1EDD5D4F-C3B6-4A94-ACAE-BF3FEF09DD59
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset=utf-8


Le 19 avr. 2016 à 08:22, Sil
Le 18/04/2016 19:23, a écrit :
Quel est ce bug ?


Bonjour,

Apparemment il y aurait un problème lors de la mise à jour du paquet samba-libs :

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug‚1002

Copie du rapport de bug #821002 :
samba: Error upgrading from deb8u1 to deb8u2. Missing Replaces for libsmbd-base.so.0

Upgrading from +deb8u1 to +deb8u2 fails with this error:

Unpacking samba-libs:amd64 (2:4.2.10+dfsg-0+deb8u2) over (2:4.2.10+dfsg-0+deb8u1) ...
dpkg: error processing archive /var/cache/apt/archives/samba-libs_2%3a4.2.10+dfsg-0+deb8u2_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/samba/libsmbd-base.so.0', which is also in package samba 2:4.2.10+dfsg-0+deb8u1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

De plus je viens de voir que la mise à jour vers Samba 4.2 a cassé Backuppc.
Les sauvegardes depuis des partages Windows ne sont plus possibles.
Je pense que les utilisateurs de rsync ne sont impactés.
( Bug #820963 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug‚0963 )



Tout ce dont je puis témoigner c’est que c’est bien cette mise à jour Samba qui à mis le bordel sur mon serveur. Je viens de faire une restauration de la situation avant la mose à jour et tout refonctionne.
Avec la mise à jour, mon serveur n’est plus capable de vérifier l’authentification des utilisateurs sur notre serveur PDC Samba 3 avec le message d’erreur indiqué dans mon précédent mail. Donc j’aurais tendance à conseiller d’attendre avant de faire une mise à jour si on a un serveur PDC ancienne version (Samba 3).

Cordialement


Sil




--
Pierre Malard

« La liberté de la presse ne s'use que lorsqu'on ne s'en sert pas ! »
Slogan du "Canard enchaîné"
| _,,,---,,_
/,`.-'`' -. ;-;;,_
|,4- ) )-,_. , ( `'-'
'---''(_/--' `-'_) πr

perl -e '$_=q#: 3| 5_,3-3,2_: 3/,`.'"'"'`'"'"' 5-. ;-;;,_: |,A- ) )-,_. , ( `'"'"'-'"'"': '"'"'-3'"'"'2(_/--'"'"' `-'"'"'_): 24πr::#;y#:#n#;s#(D)(d+)#$1x$2#ge;print'
- --> Ce message n’engage que son auteur <--


--Apple-Mail=_1EDD5D4F-C3B6-4A94-ACAE-BF3FEF09DD59
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
charset=utf-8

</div>
<br class=""></body></html>
--Apple-Mail=_1EDD5D4F-C3B6-4A94-ACAE-BF3FEF09DD59--

--Apple-Mail=_875FE553-2829-49C8-BDF9-99606155A896
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename=signature.asc
Content-Type: application/pgp-signature;
name=signature.asc
Content-Description: Message signed with OpenPGP using GPGMail

-----BEGIN PGP SIGNATURE-----
Comment: GPGTools - https://gpgtools.org

iQIcBAEBCgAGBQJXFkTkAAoJELzRDw+wKgIyMrwQAI0pU5BO54tCoM+j40dyAct7
qQfEmOy+HfaM5HJbkkCfi+WDivvzkTj9GDYmBFQqakJg07qn1qe5joxzhjFN4bST
6tEfBx957xwObFlfS5yMVBEDcmIvq+0zJaIPLaCR+ZSqDYrSNvkheRY6PXVR57ay
B4Ms7oLuFB/Mb3eEX4Yp2H1rzxCH4UP+GhFrZ97hKaJlF0VBVeBIrkBkQmVsHbdT
HOn7dtmEiSthtVzRRjNtKsyt9Yyk/OHSbxHKkg9FPv3siBEeQsS9C1rnymMKSQkv
m6ZsWFI8oIWjLLNAx51/4Uh3NZLAY8GoAfRrCVdpThrnuzbkjBHpzjif1Q/14uMI
MiN8xfJTCzNAY6Wp22g/npFq8mGAMGZpLEGhpzSwEpSAEWUi4cRpfPnhc14Kaj/R
vkCr45vmqddkYoFj2XaimmgP/g/YpPI0Xi0EWw6hMhhPkkLOmb6s4TIEpY8wHU0g
5QIN2pFcnqnplKmr7a5NX7GQ2Gng1OzfxWt2zbEqD+oGqgv0CfY8VNrJLoD/C72i
YNysCXziwFM4SNvr3G/7HtyJlL1cC0BQI76DW56Qu2s89WMlmjVkvt4GhC7eA5FZ
a7YLreaf3NzwHqUy7WjNIQL/xkDcPILuMp+Tfp6RY792DxtVbPeTHIpxvo8cZ6io
o1Dzg4jxYfbyk4t6xeOm
=aKdy
-----END PGP SIGNATURE-----

--Apple-Mail=_875FE553-2829-49C8-BDF9-99606155A896--
Sil
Le #26395856
Bonjour,

Je ne vois pas d’évolutions sur la correction de ces bugs et mes
machines ne sont plus sauvegardées. C'est donc là qu'une des machines va
me lâcher...
Pensez-vous que je puisse réinstaller la version 2:4.1.17+dfsg-2+deb8u2
en attendant ? Si je retrouve les paquets ?

Merci
Sil
Pascal Obry
Le #26395857
Le 21 avril 2016 à 10:09, Sil
Je ne vois pas d’évolutions sur la correction de ces bugs et mes machines ne
sont plus sauvegardées. C'est donc là qu'une des machines va me lâcher...
Pensez-vous que je puisse réinstaller la version 2:4.1.17+dfsg-2+deb 8u2 en
attendant ? Si je retrouve les paquets ?



Je ne sais pas, mais pour une machine critique tu n'aurais jamais dû
quitter cette version :)

L'autre solution est maintenant d'attendre.

--
Pascal Obry / Magny Les Hameaux (78)

The best way to travel is by means of imagination

http://photos.obry.net
http://www.obry.net

gpg --keyserver keys.gnupg.net --recv-key F949BD3B
andre_debian
Le #26395884
On Thursday 21 April 2016 10:09:55 Sil wrote:
Je ne vois pas d’évolutions sur la correction de ces bugs et mes
machines ne sont plus sauvegardées. C'est donc là qu'une des ma chines va
me lâcher...
Pensez-vous que je puisse réinstaller la version 2:4.1.17+dfsg-2+deb 8u2
en attendant ? Si je retrouve les paquets ?



Es tu sous Jessie ?
Si oui, télécharger le paquet Samba de Wheezy.

Je pense que de toutes façons on doit pouvoir réinstaller Samba
avec l'avant dernière version.

Sinon, aller au Brésil (grande spécialiste) pour la chercher :-)

André
Jean-Louis Mas
Le #26395882
Le 21/04/2016 10:09, Sil a écrit :

Pensez-vous que je puisse réinstaller la version 2:4.1.17+dfsg-2+deb8u2
en attendant ? Si je retrouve les paquets ?



J'ai fait un :

apt-get update

apt-get install python-samba=2:4.1.17+dfsg-2+deb8u2
samba-common=2:4.1.17+dfsg-2+deb8u2 samba-libs=2:4.1.17+dfsg-2+deb8u2
samba-common-bin=2:4.1.17+dfsg-2+deb8u2
samba-dsdb-modules=2:4.1.17+dfsg-2+deb8u2
samba-vfs-modules=2:4.1.17+dfsg-2+deb8u2 libldb1=2:1.1.17-2+deb8u1
python-ldb=2:1.1.17-2+deb8u1 samba=2:4.1.17+dfsg-2+deb8u2

Puis pour bloquer les mises à jours

apt-mark hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules

attention a ne pas utiliser 'aptitude hold ...' à cause du bug 137771

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug7771

Tu peux utiliser apt-get avec l'option -s (pour simulate) avant de te
lancer, de manière à régler d'éventuels problèmes.


Cordialement

--
Jean Louis Mas
Sil
Le #26395997
Le 21/04/2016 16:26, Jean-Louis Mas a écrit :
J'ai fait un :

apt-get update

apt-get install python-samba=2:4.1.17+dfsg-2+deb8u2
samba-common=2:4.1.17+dfsg-2+deb8u2 samba-libs=2:4.1.17+dfsg-2+deb8u2
samba-common-bin=2:4.1.17+dfsg-2+deb8u2
samba-dsdb-modules=2:4.1.17+dfsg-2+deb8u2
samba-vfs-modules=2:4.1.17+dfsg-2+deb8u2 libldb1=2:1.1.17-2+deb8u1
python-ldb=2:1.1.17-2+deb8u1 samba=2:4.1.17+dfsg-2+deb8u2

Puis pour bloquer les mises à jours

apt-mark hold samba samba-common samba-common-bin samba-dsdb-modules
samba-libs samba-vfs-modules


Bonjour,

J'étais en train de chercher les paquets sur des dépôts web. Je ne
pensait pas que les anciennes versions étaient toujours disponibles sous
apt.
Je viens de faire la manip, je regarde ce qui ce passe lundi matin au
retour des machines sur le réseau.

Merci, Bon Week-end.
Sil
Jean-Louis Mas
Le #26396282
Le 22/04/2016 20:51, Sil a écrit :

J'étais en train de chercher les paquets sur des dépôts web. Je ne
pensait pas que les anciennes versions étaient toujours disponibles sous
apt.



La commande 'aptitude versions paquet' te donne les différentes versions
présentes dans les dépôts Debian. Très utile en cas de donwgrade

Par exemple :

aptitude versions samba-common

Paquet samba-common :
ihA 2:4.1.17+dfsg-2+deb8u2 stable 500
phA 2:4.2.10+dfsg-0+deb8u2 stable 500

Cordialement

--
Jean Louis Mas
Publicité
Poster une réponse
Anonyme