Calcul de différence d'abscisses entre deux ordonnées identiques

Le
invivus Hors ligne
Bonjour,

sous excel 2007 je récupère un fichier de point qui contient une courbe représentant une courbe passe bande à plusieurs endroits. En gros une courbe avec des pics à certains endroits.

J'aimerais calculé automatiquement la différence d'abscisse entre deux ordonnées identiques sachant qu'il y a plusieurs pics.

En gros si j'ai :
A = B=
1 ; 1
2 ; 21
3 ; 22
4 ; 23
5 ; 8
6 ; 2
7 ; 21
8 ; 22
9 ; 4

J'aimerais une formule qui me renvoie 4-2=2 pour le pic 1 et 8-7 pour le pic 2.si je cherche l'intervalle d'abscisses entre les ordonnées supérieurs à 20

J'ai essayé avec les fonctions recherche mais je ne suis pas sur que ça soit la bonne chose à faire Help plz ^^

Merci d'avance !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude
Le #23115521
Bonjour,

en partant du principe que la ligne 1 contient les en-tête, et que les pics
sont les valeurs supérieures à 20 ;
la formule suivante est à copier en C2, et copier/coller dans les cellules
suivantes :
=SI(ET(B1<20;20<B2);A2;SI(ET(20<B2;B3<20);A2-C1;SI(20<B2;C1;0)))

Le principe : mémoriser l'abscisse de la première valeur > 20, et la copier
de cellule en cellule jusqu'à la dernière valeur du pic, pour y calculer la
différence. L'utilisation du résultat dépend de vous (voir colonne D).
Cf. http://cjoint.com/?0cluHPPqtyx

NB : je ne me suis pas attardé sur la valeur limite 20, il y peut-être des <
à remplacer par des <=.

Jean-Claude
michel ou sam
Le #23119251
Bonjour,
ceci a l'air de fonctionner
$B$10 étant la fin de tes données
à mettre dans C2
=SI(ET(B1< ;B2>20);EQUIV(FAUX;B3:$B$10< );"")
puis à valider en matricielle en validant par Ctrl Maj Entrée

puis à copier vers le bas.
Michel

"invivus" news:
Bonjour,

sous excel 2007 je récupère un fichier de point qui contient une courbe
représentant une courbe passe bande à plusieurs endroits. En gros une
courbe
avec des pics à certains endroits.

J'aimerais calculé automatiquement la différence d'abscisse entre deux
ordonnées identiques sachant qu'il y a plusieurs pics.

En gros si j'ai :
A = B > 1 ; 1
2 ; 21
3 ; 22
4 ; 23
5 ; 8
6 ; 2
7 ; 21
8 ; 22
9 ; 4

J'aimerais une formule qui me renvoie 4-2=2 pour le pic 1 et 8-7 pour le
pic
2.si je cherche l'intervalle d'abscisses entre les ordonnées supérieurs à
20

J'ai essayé avec les fonctions recherche mais je ne suis pas sur que ça
soit la
bonne chose à faire Help plz ^^

Merci d'avance !
invivus Hors ligne
Le #23124231
michel ou sam a écrit le 12/02/2011 à 17h28 :
Bonjour,
ceci a l'air de fonctionner
$B$10 étant la fin de tes données
à mettre dans C2
=SI(ET(B1< ;B2>20);EQUIV(FAUX;B3:$B$10< );"")
puis à valider en matricielle en validant par Ctrl Maj Entrée

puis à copier vers le bas.
Michel

"invivus" a écrit dans le
message de
news:
Bonjour,

sous excel 2007 je récupère un fichier de point qui contient une
courbe
représentant une courbe passe bande à plusieurs endroits. En
gros une
courbe
avec des pics à certains endroits.

J'aimerais calculé automatiquement la différence d'abscisse
entre deux
ordonnées identiques sachant qu'il y a plusieurs pics.

En gros si j'ai :
A = B > 1 ; 1
2 ; 21
3 ; 22
4 ; 23
5 ; 8
6 ; 2
7 ; 21
8 ; 22
9 ; 4

J'aimerais une formule qui me renvoie 4-2=2 pour le pic 1 et 8-7 pour le
pic
2.si je cherche l'intervalle d'abscisses entre les ordonnées
supérieurs à
20

J'ai essayé avec les fonctions recherche mais je ne suis pas sur que
ça
soit la
bonne chose à faire Help plz ^^

Merci d'avance !




ça marche du tonnerre ! Merci beaucoup !

Dommage juste qu'il faille rajouter des colonnes mais vu l'économie de temps que ça va me faire c'est déjà bien !
Publicité
Poster une réponse
Anonyme