calcul

Le
gillot denis
J'ai mis une suite de chiffre dans une colonne
exemple

756
757
758
777
778
779

Je voudrais dans la colonne B mettre en face du premier chiffre de la série
le dernier chiffre de la série

exemple
756 758 3
757
758
777 779 3
778
779

Comment écrire la formule pour avoir ce résultat

Merci

Denis
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #19596081
Bonsoir
Si les nombres sont en col A, je propose en C1 --->
=SOMMEPROD((GAUCHE(a1:a100;2)="75")*1)
et en B1 --> ¡+c1-1 ----> UNIQUEMENT S'IL N'Y A PAS DE TROU DANS LA
SERIE.
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"gillot denis" message de news:
J'ai mis une suite de chiffre dans une colonne
exemple

756
757
758
777
778
779

Je voudrais dans la colonne B mettre en face du premier chiffre de la
série
le dernier chiffre de la série

exemple
756 758 3
757
758
777 779 3
778
779

Comment écrire la formule pour avoir ce résultat

Merci

Denis


Jacky
Le #19596711
Bonjour,
Une proposition une solution en vba
'--------------
Sub jj()
Application.ScreenUpdating = False
Dim LigneColB As Double, Premier As String, x As Integer, y As Double
Range("a1:a" & Cells(Rows.Count, "a").End(3).Row).Copy
[b1].PasteSpecial Paste:=xlPasteValues
Application.CutCopyMode = False
LigneColB = 1
Premier = Cells(1, 1)
x = Application.Ceiling(Cells(1, 1), 10)
For i = 1 To Cells(Rows.Count, "a").End(3).Row
If Cells(i + 1, 1) > x Or Cells(i + 1, 1) = "" Then
y = y + 1
Cells(LigneColB, 2) = Premier & " " & Cells(i, 1) & " " & y
x = Application.Ceiling(Cells(i + 1, 1), 10)
LigneColB = i + 1
Premier = Cells(i + 1, 1)
y = 0
Else
y = y + 1
End If
Next
[a1].Activate
End Sub
'--------------
Voir ici
http://www.cijoint.fr/cjlink.php?file=cj200906/cij28cYLXd.xls
--
Salutations
JJ


"gillot denis" message de news:
J'ai mis une suite de chiffre dans une colonne
exemple

756
757
758
777
778
779

Je voudrais dans la colonne B mettre en face du premier chiffre de la
série
le dernier chiffre de la série

exemple
756 758 3
757
758
777 779 3
778
779

Comment écrire la formule pour avoir ce résultat

Merci

Denis


Charabeuh
Le #19596791
bonjour,

une autre piste

si la série est en colonne A à partir de A2:
en B2 mettre =SI(A1¢-1;B3+1)
en C2 mettre =SI(NON(B2);A2+B3;"")
en D2 mettre =SI(NON(B2); B3+1;"")

recopier B2,C2,D2 jusqu'à la fin de la série
laisser la ligne juste après la dernière ligne de la série vide.
Masquer la colonne B
(on suppose que la série en A est triée en ordre croissant)

voir http://www.cijoint.fr/cjlink.php?file=cj200906/cijkNTYPbI.xls






"gillot denis" message de news:
J'ai mis une suite de chiffre dans une colonne
exemple

756
757
758
777
778
779

Je voudrais dans la colonne B mettre en face du premier chiffre de la
série
le dernier chiffre de la série

exemple
756 758 3
757
758
777 779 3
778
779

Comment écrire la formule pour avoir ce résultat

Merci

Denis


Caetera
Le #19596971
"gillot denis" de news:
J'ai mis une suite de chiffre dans une colonne
exemple
756
757
758
777
778
779
Je voudrais dans la colonne B mettre en face du premier chiffre de la série
le dernier chiffre de la série
exemple
756 758 3
757
758
777 779 3
778
779
Comment écrire la formule pour avoir ce résultat



*******************************
Les données en A1:A10 et en ordre croissant
En B1 et recopie > B10, une matricielle (ctrl+maj+entrée) [Formule sur une seule
ligne]

=SI(LIGNE()<>MIN(SI(GAUCHE(A1;2)=GAUCHE($A$1:$A$10;2);LIGNE($A$1:$A$10);""));A1;INDEX($A$1:$A$10;MIN(SI(GAUCHE(A1;2)=GAUCHE($A$1:$A$10;2);LIGNE($A$1:$A$10);"")))&"
"&INDEX($A$1:$A$10;MAX(SI(GAUCHE(A1;2)=GAUCHE($A$1:$A$10;2);LIGNE($A$1:$A$10);"")))&"
"&SOMMEPROD(1*(GAUCHE($A$1:$A$10;2)=GAUCHE(A1;2))))

http://www.cijoint.fr/cjlink.php?file=cj200906/cijBUbXo0a.xls

Etc
Daniel.C
Le #19598451
Bonjour.
Avec tes données en A1 :
1. en B1 :
=INDEX($A$1:$A$6;EQUIV(1;($A$1:$A$6-A1-LIGNE($1:$6)+1)))
2. en B2 à recopier vers le bas :
=SI(A2-A1=1;"";INDEX($A$1:$A$6;EQUIV(1;($A$1:$A$6-A2-LIGNE($1:$6)+1))))
formules matricielles, à valider avec Ctrl+Maj+Entrée.
En C1, à recopier vers le bas :
=SI(B1="";"";EQUIV(B1;$A1:$A$6;0))
Cordialement.
Daniel

J'ai mis une suite de chiffre dans une colonne
exemple

756
757
758
777
778
779

Je voudrais dans la colonne B mettre en face du premier chiffre de la série
le dernier chiffre de la série

exemple
756 758 3
757
758
777 779 3
778
779

Comment écrire la formule pour avoir ce résultat

Merci

Denis


Publicité
Poster une réponse
Anonyme