calcul heure de nuit entre 21h et 6h00

Le
Jean-Pierre
bonjour a tous je suis a la recherche la formule exact pour calculer des
heures de nuit
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
poc
Le #5392751
Bonjour,
peut-être =MOD(A2-A1;1)
Cordialement
Poc
"Jean-Pierre" message de news:
bonjour a tous je suis a la recherche la formule exact pour calculer des
heures de nuit


Jean-Pierre
Le #5392721
t Bonjour Poc
dsl Celle je la connais pour calculer des après 24H
mais ce que recherche
ex: si A1 heure de début(20:35) en B1 heure de fin (1:05) en C1 ta formule
ok 4:30) pour calculer les aprés 24 heure, ce que je veut savoir quelle
formule a mettre en D1 pour avoir le nombre d'heure de nuit (4:05) en
sachant que les horaires de nuit ce situes en 21H00 et 6H00


Bonjour,
peut-être =MOD(A2-A1;1)
Cordialement
Poc
"Jean-Pierre" message de news:
bonjour a tous je suis a la recherche la formule exact pour calculer des
heures de nuit







isabelle
Le #5392671
bonjour Jean-Pierre,

A1 heure de début et en B1 heure de fin

=SI(ET(B1<1;B1>21/24);SI(ET(A1<1;A1>21/24);1-A1;3/24)-(1-B1);B1+SI(ET(A1<1;A1>21/24);1-A1;3/24))

isabelle

t Bonjour Poc
dsl Celle je la connais pour calculer des après 24H
mais ce que recherche
ex: si A1 heure de début(20:35) en B1 heure de fin (1:05) en C1 ta formule
ok 4:30) pour calculer les aprés 24 heure, ce que je veut savoir quelle
formule a mettre en D1 pour avoir le nombre d'heure de nuit (4:05) en
sachant que les horaires de nuit ce situes en 21H00 et 6H00


Bonjour,
peut-être =MOD(A2-A1;1)
Cordialement
Poc
"Jean-Pierre" message de news:
bonjour a tous je suis a la recherche la formule exact pour calculer des
heures de nuit








Filochard
Le #5392571
mais ce que recherche
ex: si A1 heure de début(20:35) en B1 heure de fin (1:05) en C1 ta formule
ok 4:30) pour calculer les aprés 24 heure, ce que je veut savoir quelle
formule a mettre en D1 pour avoir le nombre d'heure de nuit (4:05) en
sachant que les horaires de nuit ce situes en 21H00 et 6H00


Pour que (par ex.) le début à 20:00 [A1] et la fin à 08:00 [B1] donne le
résultat attendu c'est à dire 9:00 :

=MOD(B1-A1;1)-SI(B1>¡;MAX(0;MIN(B1;"21:")-MAX(A1;"6:"));MAX(0;"21:"-MAX(A1;"6:"))+MAX(0;MIN(B1;"21:")-"6:"))

Publicité
Poster une réponse
Anonyme