Calcul d'heures en négatif

Le
jo
Bonjour à vous,

J'essaie de calculer des heures de transport et j'ai des problèmes avec les
chiffres négatifs:

ex.: départ 22:43:00 Arrivée 3:35:00

J'ai essayé avec le calendrier 1904 mais le résultat est erroné aussi
(résultat à 2:18:00)..

J'ai aussi un autre cas où le départ est par exemple le 3 novembre à
18:32:00 avec l'arrivée le 5 novembre à 15:32:00. Comment je peux arriver à
faire ce calcul ?


Merci beaucoup
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Papy Jean
Le #17775091
Bonjour Jo

Une façon de faire est la suivante
Il faut déjà se rappeler que UNE cellule contient la date (sous forme
d'entier) et l'heure (en H, Mn, Sec., sous forme décimale).
La distinction des jours, heures, minutes, etc.. n'est qu'affaire
d'affichage.

Donc on peut mettre par exemple la Date ET l'heure de fin dans la cellule A1
celleS de début dans la cellule A2
dire que A3 = A1 -A2
Il reste à afficher

Les fonctions DAYS, MONTH, TIME etc sont commodes
En Visual Basic, on peut aussi utiliser TimeValue("x:xx:xx") pour charger
l'heure en numérique à partir d'une zone alpha.

Cordialement
Papy Jean

"jo"
Bonjour à vous,

J'essaie de calculer des heures de transport et j'ai des problèmes avec
les
chiffres négatifs:

ex.: départ 22:43:00 Arrivée 3:35:00

J'ai essayé avec le calendrier 1904 mais le résultat est erroné aussi
(résultat à 2:18:00)..

J'ai aussi un autre cas où le départ est par exemple le 3 novembre à
18:32:00 avec l'arrivée le 5 novembre à 15:32:00. Comment je peux arriver
à
faire ce calcul ?


Merci beaucoup


Sam
Le #17775261
Bonjour,
comme le dit Papy, si possible préciser la date

Pour les autres cas, tenir compte du lendemain en rajoutant +1 à la
soustraction.
Si tous les horaires se tiennent sur 2 jours, tu peux mettre une formule
plus générale =SI(B5<B4;B5+1-B4;B5-B4)
Cordialement
Michel dit "Sam"

"jo"
Bonjour à vous,

J'essaie de calculer des heures de transport et j'ai des problèmes avec
les
chiffres négatifs:

ex.: départ 22:43:00 Arrivée 3:35:00

J'ai essayé avec le calendrier 1904 mais le résultat est erroné aussi
(résultat à 2:18:00)..

J'ai aussi un autre cas où le départ est par exemple le 3 novembre à
18:32:00 avec l'arrivée le 5 novembre à 15:32:00. Comment je peux arriver
à
faire ce calcul ?


Merci beaucoup


Publicité
Poster une réponse
Anonyme