calcul de moyenne

Le
belloy
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?






--
.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18769381
bonjour Belloy,

=SOMME(A1:A10)/NBVAL(A1:A10)

isabelle

belloy a écrit :
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?









michdenis
Le #18787631
tu peux inscrire la formule suivante :

=MOYENNE(Plage)
la fonction moyenne ne tient pas compte des cellules vides
Plage = L'étendue de ta plage de cellules



"belloy" 49a6a2f4$0$21743$
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?






--
.
garnote
Le #18769341
Bonjour,

Supposons que tes sommes apparaissent
dans la colonne J à partir de J1.
Tu pourrais alors entrer cette formule en K1 :
=J1/NB(A1:I1)
et la « tirer » vers le bas.

Serge


"belloy"
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue divisé par le nombre de cellules comportant un
chiffre ?

Suis je assez clair?






--
.



Daniel.C
Le #18769651
Bonjour.
Utilise la fonction MOYENNE, ou j'ai raté quelque chose...
Daniel

Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?


Daniel.C
Le #18769981
Bonjour.
Utilise la fonction MOYENNE, ou j'ai raté quelque chose...
Daniel

Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?


Sully
Le #18774601
Bonjour, voici une propositon

Indépendament de la cellule total, mettre dans une cellule à part une
formule" moyenne(si" qui englobe toute la plage concenée.

=SI(SOMME(C39:N39)=0;0; MOYENNE(SI(C39:N39<>0;C39:N39)))

attention c'est une formule matricelle, valider par touche Maj + ctrl +
Valider
la premiere partie si la division est par zéro = 0 si non si non on aura
réponse "div/0 et valeur d'erreur
La partie suivante est la principale c'est celle qui nous faut, contiuner
et là il fera la moyenne des cellules et il pendra en compte que si les
cellules comportent un nombre supérieure à 0.

belloy" 49a6a2f4$0$21743$
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme
obtenue divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?






--
.



Daniel.C
Le #18776271
Bonjour.
Quelqu'un peut m'expliquer. J'ai beau relire la question, je ne vois
pas le problème ?
Daniel

Bonjour.
Utilise la fonction MOYENNE, ou j'ai raté quelque chose...
Daniel

Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?




Daniel.C
Le #18787961
je me sens moins seul... ;-)))
Daniel

tu peux inscrire la formule suivante :

=MOYENNE(Plage)
la fonction moyenne ne tient pas compte des cellules vides
Plage = L'étendue de ta plage de cellules



"belloy" discussion : 49a6a2f4$0$21743$
Bonjour

Dans un tableau , sur une ligne apparaissent des chiffres dans certaines
cellules, d'autres cellules sont vierges...
Au bout de cette ligne apparait la somme des chiffres entrés.

Comment mettre une formule pour obtenir la moyenne égale à la somme obtenue
divisé par le nombre de cellules comportant un chiffre ?

Suis je assez clair?


MichDenis
Le #18788481
| je me sens moins seul... ;-)))

même si cela a pris 2 jours avant de recevoir le message ?
J'ai supprimé totalement les comptes de "News" puis installé
à nouveau. Est-ce que cela sera suffisant ? ;-)
Daniel.C
Le #18788461
Je ne suis pas persuadé que ça soit ton install... On voit pas mal de
messages avec des dates bizarress, ces derniers jours.
Daniel

je me sens moins seul... ;-)))



même si cela a pris 2 jours avant de recevoir le message ?
J'ai supprimé totalement les comptes de "News" puis installé
à nouveau. Est-ce que cela sera suffisant ? ;-)


Publicité
Poster une réponse
Anonyme