calcul pourcentage

Le
zzzz
bonjour,
1re colonne = codes
2me = privé ou public
3me = nombre
Je souhaiterais calculer dans une 4me colonne le pourcentage public/
total pour chaque code de telle façon que s'il n'y a que privé dans un
code, le résultat sera 0% et s'il n'y a que du public, le résultat
sera 100%. (s'il n'y a que du privé ou que du public, je n'ai qu'une
seule ligne par code)

Merci d'avance
Eric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #21168941
bonjour Eric,

se n'est pas très clair, peut donner un petit exemple avec résultat attendu,

isabelle

Le 2010-02-10 11:37, zzzz a écrit :
bonjour,
1re colonne = codes
2me = privé ou public
3me = nombre
Je souhaiterais calculer dans une 4me colonne le pourcentage public/
total pour chaque code de telle façon que s'il n'y a que privé dans un
code, le résultat sera 0% et s'il n'y a que du public, le résultat
sera 100%. (s'il n'y a que du privé ou que du public, je n'ai qu'une
seule ligne par code)

Merci d'avance
Eric



FdeCourt
Le #21169091
Salut,

Je ne suis pas sur d'avoir compris.
Plusieurs question :
- Est-ce que la colonne Nombre à de l'importance ?
- Est-ce qu'il peut y avoir plusieurs fois le même code
- Est-ce qu'un code peut être public sur une ligne, privé sur une
autre ?
- Total correspond t'il au nombre de ligne total, à la somme de la
colonne Nombre, à la somme de la colonne Nombre pour chaque code ?

Par exemple
Code Prive Nombre Colonne 4 (cas 1) Colonne 4 (cas 2)
Colonne 4 (cas 3)
A Prive 3 50%
25% 0%
A Public 3 50%
25% 43%
B Prive 2 33%
16% 0
B Public 4 66%
33% 57%


Cas 1: 50% de code A sont prive ou public parmi les codes A
Cas 2 : 25% de code B est privé parmi tous les codes
Cas 3 : Code A public correspond à 43% de tous les codes publiques
ET je suis sur qu'il y a plein d'autre manière d'interpréter ton
énoncé.

Cordialement,

F.
FdeCourt
Le #21169081
Et merde !!!! saloperie de troncature !
Daniel.C
Le #21169181
Bonjour.
Regarde le classeur joint :
http://cjoint.com/?cksOmexmQb
Pour le pourcentage, j'ai appliqué :
public / (privé + public)
Les formules sont dans les celules jaunes. Ce sont des formules
matricielles (valider avec Ctrl+Maj+Enttrée).
Daniel

bonjour,
1re colonne = codes
2me = privé ou public
3me = nombre
Je souhaiterais calculer dans une 4me colonne le pourcentage public/
total pour chaque code de telle façon que s'il n'y a que privé dans un
code, le résultat sera 0% et s'il n'y a que du public, le résultat
sera 100%. (s'il n'y a que du privé ou que du public, je n'ai qu'une
seule ligne par code)

Merci d'avance
Eric


FdeCourt
Le #21169321
Salut,

En me basant sur le classeur de Daniel C., mais avec une formule un
peu plus simple (sans matricielle) :

=SI(SOMMEPROD(N(E8=$A$1:$A$13))=0;0;SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C
$13*N($B$1:$B$13="public"))/SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C$13))

Ce que correspond au cas 1 (et qui inclu le cas ou le code n'existe
pas)

Cordialement,

F.
zzzz
Le #21170101
On 10 fév, 19:13, FdeCourt
Salut,

En me basant sur le classeur de Daniel C., mais avec une formule un
peu plus simple (sans matricielle) :

=SI(SOMMEPROD(N(E8=$A$1:$A$13))=0;0;SOMMEPROD(N(E8=$A$1:$A$13)*$C $1:$C
$13*N($B$1:$B$13="public"))/SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C$13))

Ce que correspond au cas 1 (et qui inclu le cas ou le code n'existe
pas)

Cordialement,

F.



Bonjour,
L'exemple de Daniel C est bon, sauf que j'avais précisé que s'il n'y a
que du privé ou que du public, je n'ai qu'une
seule ligne par code.
Je testerais cela demain au bureau et vous tiendrais au courant.
Merci
Daniel.C
Le #21170581
Oui, mais on anticipe ;-)))
D'ailleurs, les formules fonctionnent s'il n'y a qu'un code (eg.C8).
Prends plutôt la formule de FdeCourt plus complète.
Daniel

On 10 fév, 19:13, FdeCourt
Salut,

En me basant sur le classeur de Daniel C., mais avec une formule un
peu plus simple (sans matricielle) :

=SI(SOMMEPROD(N(E8=$A$1:$A$13))=0;0;SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C
$13*N($B$1:$B$13="public"))/SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C$13))

Ce que correspond au cas 1 (et qui inclu le cas ou le code n'existe
pas)

Cordialement,

F.



Bonjour,
L'exemple de Daniel C est bon, sauf que j'avais précisé que s'il n'y a
que du privé ou que du public, je n'ai qu'une
seule ligne par code.
Je testerais cela demain au bureau et vous tiendrais au courant.
Merci


zzzz
Le #21173371
On 10 fév, 21:32, Daniel.C
Oui, mais on anticipe   ;-)))
D'ailleurs, les formules fonctionnent s'il n'y a qu'un code (eg.C8).
Prends plutôt la formule de FdeCourt plus complète.
Daniel



> On 10 fév, 19:13, FdeCourt >> Salut,

>> En me basant sur le classeur de Daniel C., mais avec une formule un
>> peu plus simple (sans matricielle) :

>> =SI(SOMMEPROD(N(E8=$A$1:$A$13))=0;0;SOMMEPROD(N(E8=$A$1:$A$13) *$C$1:$C
>> $13*N($B$1:$B$13="public"))/SOMMEPROD(N(E8=$A$1:$A$13)*$C$1:$C$13) )

>> Ce que correspond au cas 1 (et qui inclu le cas ou le code n'existe
>> pas)

>> Cordialement,

>> F.

> Bonjour,
> L'exemple de Daniel C est bon, sauf que j'avais précisé que s'il n' y a
> que du privé ou que du public, je n'ai qu'une
> seule ligne par code.
> Je testerais cela demain au bureau et vous tiendrais au courant.
> Merci- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Désolé, j'ai un gros problème, je dois laisser tomber, je reviendrais
la semaine prochaine...
Publicité
Poster une réponse
Anonyme