Calculer une somme en précisant nombre de colonne à additionner

Le
Pilou
Bonjour,
Peut être pouvez-vous m’aider.
J’aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu’il doit additionner.
Je m’explique

J’ai 12 colonnes avec des chiffres divers et la 13e c’est le total.
J’aimerais sur base d’une cellule indépendante choisir le nombre de colonne
qu’il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu’à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu’en avril)
B2 = Janvier
C2 = Février
D2= Mars etc…………
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
LSteph
Le #4355521
Bonjour,

plutôt ainsi en B1:M1 Janvier...Décembre
écris ainsi 01/01/2006.....01/12/2006
et mis au format date personnalisé "mmmm"

En A2 comme tu as dit un nombre de 1 à 12
de B2...m2 les valeurs correspondant à chaque mois.
En N2:

=SOMMEPROD((MOIS($B$1:$M$1)<=$A2)*($B$2:$M$2))

Cordialement.

lSteph


Bonjour,
Peut être pouvez-vous m’aider.
J’aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu’il doit additionner.
Je m’explique

J’ai 12 colonnes avec des chiffres divers et la 13e c’est le total.
J’aimerais sur base d’une cellule indépendante choisir le nombre de colonne
qu’il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu’à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu’en avril)
B2 = Janvier
C2 = Février
D2= Mars etc…………
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe





Daniel
Le #4355511
Bonjour.
=SOMME(INDIRECT("B2:"&ADRESSE(2;A2+1)))
Cordialement.
Daniel
"Pilou"
Bonjour,
Peut être pouvez-vous m'aider.
J'aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu'il doit additionner.
Je m'explique

J'ai 12 colonnes avec des chiffres divers et la 13e c'est le total.
J'aimerais sur base d'une cellule indépendante choisir le nombre de
colonne
qu'il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu'à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu'en avril)
B2 = Janvier
C2 = Février
D2= Mars etc....
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe





dre
Le #4355501
Bonjour,

A essayer :
En N2 : =SOMME(INDIRECT("B2:"&CAR(A2+65)&"2"))

Â+




Bonjour,
Peut être pouvez-vous m’aider.
J’aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu’il doit additionner.
Je m’explique

J’ai 12 colonnes avec des chiffres divers et la 13e c’est le total.
J’aimerais sur base d’une cellule indépendante choisir le nombre de colonne
qu’il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu’à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu’en avril)
B2 = Janvier
C2 = Février
D2= Mars etc…………
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe





JB
Le #4355421
Bonjour,

=SOMME(DECALER(B:B;;;;A2))

JB

On 7 mar, 16:54, Pilou
Bonjour,
Peut être pouvez-vous m'aider.
J'aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu'il doit additionner.
Je m'explique

J'ai 12 colonnes avec des chiffres divers et la 13e c'est le total.
J'aimerais sur base d'une cellule indépendante choisir le nombre de col onne
qu'il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu' à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu'en avril)
B2 = Janvier
C2 = Février
D2= Mars etc............
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe


LSteph
Le #4355401
Bonsoir,

...ou presque ... ;-)
en n2 à recopier vers bas

=SOMME(DECALER(B2;;;;A2))

Cordialement.

lSteph

Bonjour,
Peut être pouvez-vous m’aider.
J’aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu’il doit additionner.
Je m’explique

J’ai 12 colonnes avec des chiffres divers et la 13e c’est le total.
J’aimerais sur base d’une cellule indépendante choisir le nombre de colonne
qu’il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu’à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu’en avril)
B2 = Janvier
C2 = Février
D2= Mars etc…………
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe





Pilou
Le #4354301
ok super fonctionne nickel et j'utilise aussi du la formule de Lsteph
Merci à tous
Pilou



Bonjour,

A essayer :
En N2 : =SOMME(INDIRECT("B2:"&CAR(A2+65)&"2"))

Â+




Bonjour,
Peut être pouvez-vous m’aider.
J’aimerais faire une somme dans un tableau en précisant dans une autre
cellule le nombre de colonne qu’il doit additionner.
Je m’explique

J’ai 12 colonnes avec des chiffres divers et la 13e c’est le total.
J’aimerais sur base d’une cellule indépendante choisir le nombre de colonne
qu’il doit additionner.

A2 = Cellule du nombre de mois à additionner (pour un budget)
Si je remplis 4 dans cette cellule, le programme doit additionner jusqu’à
avril et pas tenir compte des mois qui suivent.

A2 = 4 (si 4 alors addition jusqu’en avril)
B2 = Janvier
C2 = Février
D2= Mars etc…………
N2 = TOTAL sur base de la sélection dans A2

Merci beaucoup pour votre aide
Salutations
Philippe







Publicité
Poster une réponse
Anonyme