Calendrier par mois / semaine A et B

Le
kerr2
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30


http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F (pour
fermé) quand la semaine complète est en période de vacances scolaire, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #4917151
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/


On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant uniq uement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F (pour
fermé) quand la semaine complète est en période de vacances scolair e, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.


alexandre-dit le jeune
Le #4916971
Bonjour,
comme je l'ai déjà dit j'utilise OOo 2.2, quand j'ai essayé d'ouvrir le
fichier de JB, et celui de kerr2, OOo m'a demandé si je voulais activer les
macros, j'ai répondu "Activer". Or sur le fichier de kerr2 je ne constate
presque pas d'erreur (juste en décalage de 1 jour sur le mois de septembre
mais pas sur les autres) et sur le fichier explicatif et très complet de JB,
certains classeurs ne fonctionnent pas du tout alors que d'autres oui, la
dernière version de OOo prendrait-elle en charge une partie du code Excel ?
Merci d'avance, cordialement,
Alexandre


"JB" news:
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/


On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F
(pour
fermé) quand la semaine complète est en période de vacances scolaire, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.


alexandre-dit le jeune
Le #4916881
re Bonjour,
exusez moi j'ai dit une bêtise, seulemnt une partie du fichier de kerr2
marche chez moi, autrement dit seule la feuille "semaine AB" s'affiche
correctement. Non vraiment aucune correspondance entre les macro OOo et
Excel ?
Merci d'avance,
Alexandre

"alexandre-dit le jeune" news:
Bonjour,
comme je l'ai déjà dit j'utilise OOo 2.2, quand j'ai essayé d'ouvrir le
fichier de JB, et celui de kerr2, OOo m'a demandé si je voulais activer
les macros, j'ai répondu "Activer". Or sur le fichier de kerr2 je ne
constate presque pas d'erreur (juste en décalage de 1 jour sur le mois de
septembre mais pas sur les autres) et sur le fichier explicatif et très
complet de JB, certains classeurs ne fonctionnent pas du tout alors que
d'autres oui, la dernière version de OOo prendrait-elle en charge une
partie du code Excel ?
Merci d'avance, cordialement,
Alexandre


"JB" news:
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/


On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F
(pour
fermé) quand la semaine complète est en période de vacances scolaire, et
A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.






kerr2
Le #4915911
Bonsoir JB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques petits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour cacher
son contenu que je ne connaissais pas et d'autres formules plus simple que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.
http://cjoint.com/?gnwRuuefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux colonnes
de chaque mois pour déterminer les semaines A et B ainsi que les semaines
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. Il faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.


"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/


On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F
(pour
fermé) quand la semaine complète est en période de vacances scolaire, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.


JB
Le #4915801
Bonjour,

http://cjoint.com/?gohlPRgfAk

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin);1))=NB(C4:C10);"F";"")
Valider avec Maj+Ctrl+Entrée

JB



On 13 juin, 22:59, "kerr2"
Bonsoir JB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques petits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour cach er
son contenu que je ne connaissais pas et d'autres formules plus simple que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRuuefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux c olonnes
de chaque mois pour déterminer les semaines A et B ainsi que les semain es
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. I l faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"


Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettre s F
(pour
fermé) quand la semaine complète est en période de vacances scola ire, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages pr écédents -


- Afficher le texte des messages précédents -



JB
Le #4915481
http://cjoint.com/?gonnGmSDjo

JB
On 13 juin, 22:59, "kerr2"
BonsoirJB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques petits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour cach er
son contenu que je ne connaissais pas et d'autres formules plus simple que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRuuefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux c olonnes
de chaque mois pour déterminer les semaines A et B ainsi que les semain es
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. I l faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"


Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettre s F
(pour
fermé) quand la semaine complète est en période de vacances scola ire, et A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages pr écédents -


- Afficher le texte des messages précédents -



kerr2
Le #4915021
Merci JB,

Pour trouver l'intitulé de la colonne F cela fonctionne pour un interval de
vacances, dans le cas ci-dessous les vacances de toussaint avec
Dtoussaint pour Debut des vacances de toussaint et
FToussaint pour la fin

=SI(SOMME(SI((C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint);1))=NB(C4:C10);"F";"")


Maintenant comment adapter à plusieurs intervals ? j'ai les 6 ci-dessous à
prendre en compte

C4:C10C<Drentrée
(C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint)
(C4:C10>=Dnoel)*(C4:C10<Fnoel)
(C4:C10>=Dhivers)*(C4:C10<Fhivers)
(C4:C10>=Dprintemps)*(C4:C10<Fprintemps)
C4:C10>=Dété

Drentrée 4/09/07
Dtoussaint 27/10/07
Ftoussaint 8/11/07
Dnoel 22/12/08
Fnoel 7/01/08
Dhivers 23/02/08
Fhivers 10/03/08
D printemps 19/04/08
Fprintemps 5/5/08
Dété 3/07/08





"JB"
http://cjoint.com/?gonnGmSDjo

JB
On 13 juin, 22:59, "kerr2"
BonsoirJB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques petits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour
cacher
son contenu que je ne connaissais pas et d'autres formules plus simple que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRuuefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux
colonnes
de chaque mois pour déterminer les semaines A et B ainsi que les semaines
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. Il
faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JB http://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"


Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F
(pour
fermé) quand la semaine complète est en période de vacances scolaire, et
A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages
précédents -


- Afficher le texte des messages précédents -



JB
Le #4914831
Bonsoir,

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin)+
(C4:C10>=début2)*(C4:C10<=fin2)+(C4:C10>=début3)*(C4:C10<=fin3);
1))=NB(C4:C10);"F";"")
Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?gotLxIifY8

JB

On 14 juin, 17:18, "kerr2"
MerciJB,

Pour trouver l'intitulé de la colonne F cela fonctionne pour un interva l de
vacances, dans le cas ci-dessous les vacances de toussaint avec
Dtoussaint pour Debut des vacances de toussaint et
FToussaint pour la fin

=SI(SOMME(SI((C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint);1))=NB(C4:C10 );"F";""­)

Maintenant comment adapter à plusieurs intervals ? j'ai les 6 ci-dessou s à
prendre en compte

C4:C10C<Drentrée
(C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint)
(C4:C10>=Dnoel)*(C4:C10<Fnoel)
(C4:C10>=Dhivers)*(C4:C10<Fhivers)
(C4:C10>=Dprintemps)*(C4:C10<Fprintemps)
C4:C10>=Dété

Drentrée 4/09/07
Dtoussaint 27/10/07
Ftoussaint 8/11/07
Dnoel 22/12/08
Fnoel 7/01/08
Dhivers 23/02/08
Fhivers 10/03/08
D printemps 19/04/08
Fprintemps 5/5/08
Dété 3/07/08

"JB" ://cjoint.com/ ?gonnGmSDjo

JB
On 13 juin, 22:59, "kerr2"


BonsoirJB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques peti ts
trucs comme par exemple la mise en forme d'une cellule avec ;; pour
cacher
son contenu que je ne connaissais pas et d'autres formules plus simple que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRuue fBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux
colonnes
de chaque mois pour déterminer les semaines A et B ainsi que les sema ines
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. Il
faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JBhttp://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lett res F
(pour
fermé) quand la semaine complète est en période de vacances sco laire, et
A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages
précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -




kerr2
Le #4914751
Merci JB

J'ai essayé de rajouter 2 conditions n'étant cette fois ci par bornées des
2 cotés comme l'étaient les autres
C4:C10<début4
C4:C10>=début5
comme cela mais sans succès:

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin)+
(C4:C10>=début2)*(C4:C10<=fin2)+(C4:C10>=début3)*(C4:C10<=fin3)+(C4:C10<début4)+(C4:C10>=début5);
1))=NB(C4:C10);"F";"")


Cela y est presque pour la colonne F mais obtenir semaine A ou B me parait
encore plus difficile.

Merci pour ton aide



"JB"
Bonsoir,

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin)+
(C4:C10>=début2)*(C4:C10<=fin2)+(C4:C10>=début3)*(C4:C10<=fin3);
1))=NB(C4:C10);"F";"")
Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?gotLxIifY8

JB

On 14 juin, 17:18, "kerr2"
MerciJB,

Pour trouver l'intitulé de la colonne F cela fonctionne pour un interval
de
vacances, dans le cas ci-dessous les vacances de toussaint avec
Dtoussaint pour Debut des vacances de toussaint et
FToussaint pour la fin

=SI(SOMME(SI((C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint);1))=NB(C4:C10);"F";""­)

Maintenant comment adapter à plusieurs intervals ? j'ai les 6 ci-dessous à
prendre en compte

C4:C10C<Drentrée
(C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint)
(C4:C10>=Dnoel)*(C4:C10<Fnoel)
(C4:C10>=Dhivers)*(C4:C10<Fhivers)
(C4:C10>=Dprintemps)*(C4:C10<Fprintemps)
C4:C10>=Dété

Drentrée 4/09/07
Dtoussaint 27/10/07
Ftoussaint 8/11/07
Dnoel 22/12/08
Fnoel 7/01/08
Dhivers 23/02/08
Fhivers 10/03/08
D printemps 19/04/08
Fprintemps 5/5/08
Dété 3/07/08

"JB" ://cjoint.com/?gonnGmSDjo

JB
On 13 juin, 22:59, "kerr2"


BonsoirJB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques petits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour
cacher
son contenu que je ne connaissais pas et d'autres formules plus simple
que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRuuefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F aux
colonnes
de chaque mois pour déterminer les semaines A et B ainsi que les
semaines
Fermés. Sur le fichier en lien, cet entête est rempli manuellement. Il
faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JBhttp://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonnes

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les lettres F
(pour
fermé) quand la semaine complète est en période de vacances scolaire,
et
A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages
précédents -


- Afficher le texte des messages précédents -- Masquer le texte des
messages précédents -


- Afficher le texte des messages précédents -




JB
Le #4914701
Toutes les dates des intervalles inférieurs vérifient la condition et
faussent le résultat.

+(C4:C10<déb­ut4)

JB

On 14 juin, 21:40, "kerr2"
Merci JB

J'ai essayé de rajouter 2 conditions n'étant cette fois ci par born ées des
2 cotés comme l'étaient les autres
C4:C10<début4
C4:C10>=début5
comme cela mais sans succès:

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin)+
(C4:C10>=début2)*(C4:C10<=fin2)+(C4:C10>=début3)*(C4:C10<=fin 3)+(C4:C10<déb­ut4)+(C4:C10>=début5);
1))=NB(C4:C10);"F";"")

Cela y est presque pour la colonne F mais obtenir semaine A ou B me parait
encore plus difficile.

Merci pour ton aide

"JB"
Bonsoir,

=SI(SOMME(SI((C4:C10>=début)*(C4:C10<=fin)+
(C4:C10>=début2)*(C4:C10<=fin2)+(C4:C10>=début3)*(C4:C10<=fin 3);
1))=NB(C4:C10);"F";"")
Valider avec Maj+Ctrl+Entrée

http://cjoint.com/?gotLxIifY8

JB

On 14 juin, 17:18, "kerr2"


MerciJB,

Pour trouver l'intitulé de la colonne F cela fonctionne pour un inter val
de
vacances, dans le cas ci-dessous les vacances de toussaint avec
Dtoussaint pour Debut des vacances de toussaint et
FToussaint pour la fin

=SI(SOMME(SI((C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint);1))=NB(C4:C 10);"F";""­­)

Maintenant comment adapter à plusieurs intervals ? j'ai les 6 ci-dess ous à
prendre en compte

C4:C10C<Drentrée
(C4:C10>=Dtoussaint)*(C4:C10<Ftoussaint)
(C4:C10>=Dnoel)*(C4:C10<Fnoel)
(C4:C10>=Dhivers)*(C4:C10<Fhivers)
(C4:C10>=Dprintemps)*(C4:C10<Fprintemps)
C4:C10>=Dété

Drentrée 4/09/07
Dtoussaint 27/10/07
Ftoussaint 8/11/07
Dnoel 22/12/08
Fnoel 7/01/08
Dhivers 23/02/08
Fhivers 10/03/08
D printemps 19/04/08
Fprintemps 5/5/08
Dété 3/07/08

"JB" ://cjoint.co m/?gonnGmSDjo

JB
On 13 juin, 22:59, "kerr2"
BonsoirJB,

Merci pour ton aide.
Cela y est cela fonctionne. J'en ai profité pour glaner quelques pe tits
trucs comme par exemple la mise en forme d'une cellule avec ;; pour
cacher
son contenu que je ne connaissais pas et d'autres formules plus simple
que
ce que je ne faisais.

J'ai joint le résultat de l'aide apporté.http://cjoint.com/?gnwRu uefBg

Il reste maintenant à octroyer un entête automatique A, B, ou F a ux
colonnes
de chaque mois pour déterminer les semaines A et B ainsi que les
semaines
Fermés. Sur le fichier en lien, cet entête est rempli manuellemen t. Il
faut
donc déterminer déjà comment cela fonctionne.

Je n'ai rien trouvé comme aide pour réaliser cela.

S'il y a des idées je suis preneur.

Merci par avance.

"JB"
Bonjour,

http://boisgontierjacques.free.fr/fichiers/jb-Calendriers.xls

P1 contient l'année (2007),B3 le mois (1):

-Sélectionner B5:G11

=SI(MOIS(DATE($P$1;B3;1)-JOURSEM(DATE($P$1;B3;1);
2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7)³;DATE($P$1;B3;1)-JOURSEM(DATE ($P
$1;B3;1);2)+{1;2;3;4;5;6;7}+{0.1.2.3.4.5}*7;"")

-Valider avec Maj+Ctrl+Entrée

JBhttp://boisgontierjacques.free.fr/

On 12 juin, 22:30, "kerr2"
Bonjour,

J'aimerais générer un calendrier scolaire par mois en modifiant
uniquement
l'année
AN = 2008 pour l'année scolaire 2007-2008
(A2:G9) pour le mois de septembre (AN-1)

J'ai en A1 le mois: Septembre
J'ai en ordonnée les jours de la semaine du Lun (A3) au Dim (A9)
L'abcisse du tableau de B2 à G2 contient l'entête des 5 colonn es

A B C D E F G
1 septembre
2 Qz F A B A B A
3 Lun. 3 10 17 24
4 Mar. 4 11 18 25
5 Merc. 5 12 19 26
6 Jeu. 6 13 20 27
7 Vend. 7 14 21 28
8 Sam. 1 8 15 22 29
9 Dim. 2 9 16 23 30

http://cjoint.com/?gmwzFxxl67

Il faudra par la suite attribuer à l'entête des colonnes les le ttres F
(pour
fermé) quand la semaine complète est en période de vacances s colaire,
et
A
ou B (pour semaine A ou B)

En vous remerciant pour votre aide.- Masquer le texte des messages
précédents -


- Afficher le texte des messages précédents -- Masquer le texte d es
messages précédents -


- Afficher le texte des messages précédents -- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -





Publicité
Poster une réponse
Anonyme