Carte son muette

Le
Philippe Delavalade
Bonjour la liste.

Je viens d'installer jessie sur une nouvelle machine, carte mère
MSI H87-G43.

Je n'arrive pas à avoir de son avec alsa.

Lorsque je lance alsamixer, je ne suis plus dans la même situation qu'avant
ou j'avais des colonnes nombreuses : master, front, pcm, etc. Maintenant je
n'ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.

Alsamixer me donne comme carte son HDA Intel HDMI.

À tout hasard des extraits de lspci et de lsmod :

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

snd_hda_codec_hdmi 40859 1
snd_hda_codec_realtek 50253 1
snd_hda_intel 43768 1
snd_hda_codec 146743 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13148 1 snd_hda_codec
snd_pcm_oss 44847 0
snd_mixer_oss 22042 1 snd_pcm_oss
snd_pcm 84153 4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 17114 2 snd_pcm,snd_hda_intel
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 26805 1 snd_seq_midi
snd_seq 48834 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 13132 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 26614 2 snd_pcm,snd_seq
snd 60917 14 snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_mixer_oss
soundcore 13026 1 snd

Je précise que je suis uniquement en console, rien de graphique sur la
machine.

Merci de toute aide ou suggestion.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/20140511141037.GA5927@messier31.home
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Adrien Dewulf
Le #26128502
--047d7b472800ace6a504f921519d
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonsoir,

Est que quand tu lances alsa dans un terminal.
Il y a une colonne (ou plusieurs colonnes) qui apparait, est ce que dans le
bas il s'y trouve deux "MM" ou "00" ?
Si tu y vois MM, appuies sur la touche M pour je pense que c'est pour le
mute.
Sinon je ne sais pas plus.

Debianement :D

Adrien Dewulf.
On 11 May 2014 16:11, "Philippe Delavalade" wrote:

Bonjour la liste.

Je viens d'installer jessie sur une nouvelle machine, carte mère
MSI H87-G43.

Je n'arrive pas à avoir de son avec alsa.

Lorsque je lance alsamixer, je ne suis plus dans la même situation q u'avant
ou j'avais des colonnes nombreuses : master, front, pcm, etc. Maintenant je
n'ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.

Alsamixer me donne comme carte son HDA Intel HDMI.

À tout hasard des extraits de lspci et de lsmod :

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core
Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High
Definition Audio Controller (rev 05)

snd_hda_codec_hdmi 40859 1
snd_hda_codec_realtek 50253 1
snd_hda_intel 43768 1
snd_hda_codec 146743 3
snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13148 1 snd_hda_codec
snd_pcm_oss 44847 0
snd_mixer_oss 22042 1 snd_pcm_oss
snd_pcm 84153 4
snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 17114 2 snd_pcm,snd_hda_intel
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 26805 1 snd_seq_midi
snd_seq 48834 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 13132 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 26614 2 snd_pcm,snd_seq
snd 60917 14
snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi, snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_ mixer_oss
soundcore 13026 1 snd

Je précise que je suis uniquement en console, rien de graphique sur la
machine.

Merci de toute aide ou suggestion.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/





--047d7b472800ace6a504f921519d
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<p dir="ltr">Bonsoir,</p>
Il y a une colonne (ou plusieurs colonnes) qui apparait, est ce que dans le bas il s&#39;y trouve deux &quot;MM&quot; ou &quot;00&quot; ? <br>
Si tu y vois MM, appuies sur la touche M pour je pense que c&#39;est pour l e mute.<br>
Sinon je ne sais pas plus.</p>
<p dir="ltr">Debianement :D</p>
Bonjour la liste.<br>
<br>
Je viens d&#39;installer jessie sur une nouvelle machine, carte mère<b r>
MSI H87-G43.<br>
<br>
Je n&#39;arrive pas à avoir de son avec alsa.<br>
<br>
Lorsque je lance alsamixer, je ne suis plus dans la même situation qu& #39;avant<br>
ou j&#39;avais des colonnes nombreuses : master, front, pcm, etc. Main tenant je<br>
n&#39;ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.<br>
<br>
Alsamixer me donne comme carte son HDA Intel HDMI.<br>
<br>
À tout hasard des extraits de lspci et de lsmod :<br>
<br>
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Proces sor HD Audio Controller (rev 06)<br>
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High D efinition Audio Controller (rev 05)<br>
<br>
snd_hda_codec_hdmi     40859  1<br>
snd_hda_codec_realtek    50253  1<br>
snd_hda_intel          43768  1<br>
snd_hda_codec         146743  3 snd_hda_codec_real tek,snd_hda_codec_hdmi,snd_hda_intel<br>
snd_hwdep              13148  1 snd _hda_codec<br>
snd_pcm_oss            44847  0<br>
snd_mixer_oss          22042  1 snd_pcm_oss<b r>
snd_pcm                84153   4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel<br>
snd_page_alloc         17114  2 snd_pcm,snd_hda_in tel<br>
snd_seq_midi           12848  0<br>
snd_seq_midi_event     13316  1 snd_seq_midi<br>
snd_rawmidi            26805  1 snd_seq_ midi<br>
snd_seq                48834   2 snd_seq_midi_event,snd_seq_midi<br>
snd_seq_device         13132  3 snd_seq,snd_rawmid i,snd_seq_midi<br>
snd_timer              26614  2 snd _pcm,snd_seq<br>
snd                    60 917  14 snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_ codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_ device,snd_mixer_oss<br>
soundcore              13026  1 snd <br>
<br>
Je précise que je suis uniquement en console, rien de graphique sur la <br>
machine.<br>
<br>
Merci de toute aide ou suggestion.<br>
<br>
--<br>
Ph. Delavalade<br>
<br>
--<br>
Lisez la FAQ de la liste avant de poser une question :<br>
<br>
Pour vous DESABONNER, envoyez un message avec comme objet &quot;unsubscribe &quot;<br>
vers En cas de soucis, contactez EN ANGLAIS Archive: <br>
</blockquote></div>

--047d7b472800ace6a504f921519d--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/CAK_iF3c2T=
nb
Le #26128492
Le Dimanche 11 Mai 2014 16:10 CEST, Philippe Delavalade
Bonjour la liste.

Je viens d'installer jessie sur une nouvelle machine, carte mère
MSI H87-G43.

Je n'arrive pas à avoir de son avec alsa.

Lorsque je lance alsamixer, je ne suis plus dans la même situati on qu'avant
ou j'avais des colonnes nombreuses : master, front, pcm, etc. Ma intenant je
n'ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.

Alsamixer me donne comme carte son HDA Intel HDMI.

À tout hasard des extraits de lspci et de lsmod :

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

snd_hda_codec_hdmi 40859 1
snd_hda_codec_realtek 50253 1
snd_hda_intel 43768 1
snd_hda_codec 146743 3 snd_hda_codec_realtek,snd_ hda_codec_hdmi,snd_hda_intel
snd_hwdep 13148 1 snd_hda_codec
snd_pcm_oss 44847 0
snd_mixer_oss 22042 1 snd_pcm_oss
snd_pcm 84153 4 snd_pcm_oss,snd_hda_codec_ hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 17114 2 snd_pcm,snd_hda_intel
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 26805 1 snd_seq_midi
snd_seq 48834 2 snd_seq_midi_event,snd_seq_ midi
snd_seq_device 13132 3 snd_seq,snd_rawmidi,snd_seq _midi
snd_timer 26614 2 snd_pcm,snd_seq
snd 60917 14 snd_hda_codec_realtek,snd_pc m_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_ seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_devic e,snd_mixer_oss
soundcore 13026 1 snd




Je commencerais par lire Documentation/sound/alsa/HD-Audio.txt

Pour certaines puces audio, il faut faut passer des options au module s nd_hda_intel
Par ailleurs, c'est comme s'il n'y avait que la partie "digitale" qui à ©tait prise en compte.

Bon courage.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Philippe Delavalade
Le #26128472
Le dimanche 11 mai à 16:10, Philippe Delavalade a écrit :
Bonjour la liste.

Je viens d'installer jessie sur une nouvelle machine, carte mère
MSI H87-G43.

Je n'arrive pas à avoir de son avec alsa.

Lorsque je lance alsamixer, je ne suis plus dans la même situation qu'avant
ou j'avais des colonnes nombreuses : master, front, pcm, etc. Maintenant je
n'ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.

Alsamixer me donne comme carte son HDA Intel HDMI.



Au fait, j'ai oublié de dire que la puce donnée par alsa est
Intel Haswell HDMI.

À tout hasard des extraits de lspci et de lsmod :

00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

snd_hda_codec_hdmi 40859 1
snd_hda_codec_realtek 50253 1
snd_hda_intel 43768 1
snd_hda_codec 146743 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep 13148 1 snd_hda_codec
snd_pcm_oss 44847 0
snd_mixer_oss 22042 1 snd_pcm_oss
snd_pcm 84153 4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc 17114 2 snd_pcm,snd_hda_intel
snd_seq_midi 12848 0
snd_seq_midi_event 13316 1 snd_seq_midi
snd_rawmidi 26805 1 snd_seq_midi
snd_seq 48834 2 snd_seq_midi_event,snd_seq_midi
snd_seq_device 13132 3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer 26614 2 snd_pcm,snd_seq
snd 60917 14 snd_hda_codec_realtek,snd_pcm_oss,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_mixer_oss
soundcore 13026 1 snd

Je précise que je suis uniquement en console, rien de graphique sur la
machine.

Merci de toute aide ou suggestion.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/




--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Philippe Delavalade
Le #26128482
Le dimanche 11 mai à 17:16, Adrien Dewulf a écrit :
Bonsoir,

Est que quand tu lances alsa dans un terminal.
Il y a une colonne (ou plusieurs colonnes) qui apparait, est ce que dans le
bas il s'y trouve deux "MM" ou "00" ?
Si tu y vois MM, appuies sur la touche M pour je pense que c'est pour le
mute.



J'ai bien des 'O', et ça je connais.

Merci.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Sylvain L. Sauvage
Le #26128462
Le dimanche 11 mai 2014, 17:23:24 Philippe Delavalade a écrit :
Le dimanche 11 mai à 16:10, Philippe Delavalade a écrit :
> Bonjour la liste.



’lut,

[…]
> Je n'arrive pas à avoir de son avec alsa.
>
> Lorsque je lance alsamixer, je ne suis plus dans la même
> situation qu'avant ou j'avais des colonnes nombreuses :
> master, front, pcm, etc. Maintenant je n'ai plus que trois
> : S/PDIF, S/PDIF 1, S/PDIF 2.



La puce présente deux « cartes » au sens ALSA du terme , une
« classique » et une pour la sortie HDMI. La sortie HDMI est la
première listée (n°0), donc celle présentée pa r alsamixer par
défaut.

Essaie alsamixer -c 1 (ou regarde d’abord /proc/asound/cards
ou la sortie de aplay -l).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
didier gaumet
Le #26128572
à priori tu as la partie entrées/sorties numériques HDMI qui est
reconnue comme carte 0 par Alsa et la partie entrées/sorties analogiques
(HP, casque, micro) qui est reconnue comme carte 1.

Alsa considère que la carte 0 est le défaut et ne gère donc pas les flux
présents sur les entrées/sorties de la carte 1. Le plus simple est donc
de faire considérer à Alsa que le défaut est la carte 1.

De mémoire, j'avais résolu ça (maintenant je gère avec PulseAudio) avec
un fichier système /etc/asound.conf (plutôt qu'un fichier utilisateur
~/.asound.rc).

La doc en anglais est ici:
http://www.alsa-project.org/main/index.php/Asoundrc

une doc en français assez proche de ce que tu veux faire:
http://www.bouthors.fr/wiki/doku.php?id=linux:config:alsa#exemple_1modifier_default

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/lko5ua$c7g$
Stéphane Goujet
Le #26129492
This message is in MIME format. The first part should be readable text,
while the remaining parts are likely unreadable without MIME-aware tools.

--8323328-1037902780-1399856938=:4936
Content-Type: TEXT/PLAIN; CHARSET=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 8BIT
Content-ID:
On Sun, 11 May 2014, Philippe Delavalade wrote:

Lorsque je lance alsamixer, je ne suis plus dans la même situation qu'avant
ou j'avais des colonnes nombreuses : master, front, pcm, etc. Maintenant je
n'ai plus que trois : S/PDIF, S/PDIF 1, S/PDIF 2.
Alsamixer me donne comme carte son HDA Intel HDMI.



Ça fait bizarre la première fois, oui :-)

Dans alsamixer, tu peux appuyer sur F6, ça devrait t'afficher d'autres
"cartes", dont la bonne.


A+,
Stéphane.
--8323328-1037902780-1399856938=:4936--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Philippe Delavalade
Le #26130712
Bonjour tout le monde et merci à ceux qui m'ont répondu.

J'avais essayé avec F6 pour le choix de la carte mais, ça n'avait rien
donné, allez savoir pourquoi...

Comme conseillé par Sylvain j'ai lancé alsamixer -c 1 et là je me suis
retrouvé en pays de connaissances mais une fois sorti, si je reviens sans
option, je me retrouve avec la carte 0 par défaut. De plus et surtout, si
je l'ance aplay sur un wav ou un mp3 j'obtiens :

ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: erreur à l'ouverture audio: Aucun fichier ou dossier de ce type

J'ai jeté un œil aux différentes docs conseillées ; je suis loin de tout
comprendre mais je vais continuer.

Merci encore.

--
Ph. Delavalade

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
maderios
Le #26130762
On 05/11/2014 05:33 PM, Sylvain L. Sauvage wrote:
Le dimanche 11 mai 2014, 17:23:24 Philippe Delavalade a écrit :
Le dimanche 11 mai à 16:10, Philippe Delavalade a écrit :
Bonjour la liste.





’lut,

[…]
Je n'arrive pas à avoir de son avec alsa.

Lorsque je lance alsamixer, je ne suis plus dans la même
situation qu'avant ou j'avais des colonnes nombreuses :
master, front, pcm, etc. Maintenant je n'ai plus que trois
: S/PDIF, S/PDIF 1, S/PDIF 2.





La puce présente deux « cartes » au sens ALSA du terme, une
« classique » et une pour la sortie HDMI. La sortie HDMI est la
première listée (n°0), donc celle présentée par alsamixer par
défaut.

Essaie alsamixer -c 1 (ou regarde d’abord /proc/asound/cards
ou la sortie de aplay -l).



Bonjour
J'ai eu le même problème et c'est résolu de la manière suivante.
La commande arecord -l permet de lister les cartes son dans leur
ordre effectif d'utilisation
Si la carte hdmi est en tête donc prioritaire, il faut la mettre à la fin.
Il faut alors configurer le fichier /etc/modprobe.d/alsa-base.conf pour
rétablir le bon ordre
Donc:
#j'ai du faire cela chez moi La carte index=0 devient prioritaire
Modifier selon les cartes
options snd_emu10k1 index=0
options snd_hda_intel index=1

--
Maderios


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Stephane Ascoet
Le #26130852
Le 12/05/2014 17:05, Philippe Delavalade a écrit :
Comme conseillé par Sylvain j'ai lancé alsamixer -c 1 et là je me suis
retrouvé en pays de connaissances mais une fois sorti, si je reviens sans
option, je me retrouve avec la carte 0 par défaut.




Bonjour, pour resoudre cela sur mon ordinateur mini-tour Nec, j'avais modifie un des fichiers de configuration a la main et avait
change l'ordre des peripheriques, je ne suis plus ou ni comment ni si tu pourras le faire car dans mon cas il s'agissait reellement
de deux peripheriques distincts.

--
Bien cordialement, Stephane Ascoet

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Publicité
Poster une réponse
Anonyme