carte tv reconnue 1 fois sur 2

Le
Daniel Caillibaud
Bonjour,

Très souvent (pas fait de stats), ma carte TV (PCI - bt878) n'est pas =
reconnue par xdtv ou
tvtime. les modules bttv et v4l2 sont bien chargés.
Visiblement c'est à cause de la webcam USB (UVC) qui doit passer "avan=
t" au boot (et récupère
en 1er /dev/video0), en tout cas quand je la débranche le pb disparait.

J'ai pas bcp creusé car je sais pas trop où chercher
Faut donner un ordre de chargement à udev ? Comment ? (ça je peux=
creuser si c'est par là qu'il
faut aller)
C'est ailleurs que ça se passe ?

Merci pour les pistes

--
Daniel

Revenus du clergé
Les prêtres obligés de tirer le diable par la queue.
Celui-ci ne s'en plaint pas.
Les nuls

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20110408104216.7d9ec99a@quad.lairdutemps.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Julien
Le #23268521
Le vendredi 08 avril 2011 à 10:42 +0200, Daniel Caillibaud a écrit :
Bonjour,

Très souvent (pas fait de stats), ma carte TV (PCI - bt878) n'est pas reconnue par xdtv ou
tvtime. les modules bttv et v4l2 sont bien chargés.
Visiblement c'est à cause de la webcam USB (UVC) qui doit passer "avant" au boot (et récupère
en 1er /dev/video0), en tout cas quand je la débranche le pb disparait.

J'ai pas bcp creusé car je sais pas trop où chercher...
Faut donner un ordre de chargement à udev ?



oui apparemment c'est possible avec udev. Le wiki de mythtv (en
anglais) :

http://www.mythtv.org/wiki/Device_Filenames_and_udev

contient une page sur le nommage des périphériques video.


Comment ? (ça je peux creuser si c'est par là qu'il
faut aller)
C'est ailleurs que ça se passe ?

Merci pour les pistes

--
Daniel

Revenus du clergé
Les prêtres obligés de tirer le diable par la queue.
Celui-ci ne s'en plaint pas.
Les nuls





--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Caillibaud
Le #23269011
Le 08/04/11 à 15:43, Julien J> > J'ai pas bcp creusé car je sais pas trop où chercher...
J> > Faut donner un ordre de chargement à udev ?
J>
J> oui apparemment c'est possible avec udev. Le wiki de mythtv (en
J> anglais) :
J>
J> http://www.mythtv.org/wiki/Device_Filenames_and_udev
J>
J> contient une page sur le nommage des périphériques video.

Merci bcp, y'a plus qu'à me pencher enfin sur udev...

PS: j'aime bien le "Sometimes, though, problems arise [...] because of [... ] because of [...]
or (so it seems sometimes) because of the phase of the Moon."

--
Daniel

J'aurais aimé être publicitaire pour faire dire des conneries aux vedettes.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
David Pinson
Le #23269211
Bonjour,

Le 08/04/2011 15:43, Julien a écrit :
Le vendredi 08 avril 2011 à 10:42 +0200, Daniel Caillibaud a écrit :
Bonjour,

Très souvent (pas fait de stats), ma carte TV (PCI - bt878) n'est




pas reconnue par xdtv ou
tvtime. les modules bttv et v4l2 sont bien chargés.
Visiblement c'est à cause de la webcam USB (UVC) qui doit passer




"avant" au boot (et récupère
en 1er /dev/video0), en tout cas quand je la débranche le pb disparait.

J'ai pas bcp creusé car je sais pas trop où chercher...
Faut donner un ordre de chargement à udev ?





Tu trouveras ton bonheur dans ce lien:
http://lists.debian.org/debian-user/2007/08/msg00079.html

Linuxement vôtre,
David Pinson

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23269551
On Fri, 8 Apr 2011 10:42:16 +0200
Daniel Caillibaud
...
Visiblement c'est à cause de la webcam USB (UVC) qui doit passer "av ant"
au boot (et récupère en 1er /dev/video0), en tout cas quand je la
débranche le pb disparait.

J'ai pas bcp creusé car je sais pas trop où chercher...
Faut donner un ordre de chargement à udev ? Comment ? (ça je pe ux creuser
si c'est par là qu'il faut aller)



pourquoi faire compliqué lorsqu'on peut faire simple?

C'est ailleurs que ça se passe ?



dans /etc/modprobe.d, les parms voulus se récupérant par:
modinfo nom_du_module
la même chose étant, en Gal, possible pour la WC.

--
San Diego:
Four million people, where you can't get a
good cheeseburger, no matter how hard you try.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Sylvain L. Sauvage
Le #23269611
’soir,

Le vendredi 8 avril 2011 à 21:24:59, Jean-Yves F. Barbier a
écrit :
[…]
dans /etc/modprobe.d, les parms voulus se récupérant par:
modinfo nom_du_module
la même chose étant, en Gal, possible pour la WC.



Sauf que, avec la solution udev :
1. on peut utiliser plusieurs périphériques qui sont gérà ©s par
le même pilote ;
2. c’est indépendant du pilote (absence dudit paramètre, nom
variable de celui-ci…) ou du type de matériel (ça fonct ionne
pour les cartes réseaux, les webcams, les clefs USB, les
claviers, etc.).

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Caillibaud
Le #23269681
Le 08/04/11 à 19:48, David Pinson DP> >> Très souvent (pas fait de stats), ma carte TV (PCI - bt878) n' est
DP> >> pas reconnue par xdtv ou
DP> >> tvtime. les modules bttv et v4l2 sont bien chargés.
DP> >> Visiblement c'est à cause de la webcam USB (UVC) qui doit pass er
DP> >> "avant" au boot (et récupère
DP> >> en 1er /dev/video0), en tout cas quand je la débranche le pb d isparait.
DP> >>
DP> >> J'ai pas bcp creusé car je sais pas trop où chercher...
DP> >> Faut donner un ordre de chargement à udev ?
DP>
DP> Tu trouveras ton bonheur dans ce lien:
DP> http://lists.debian.org/debian-user/2007/08/msg00079.html

Merci !

Effectivement, ça semble coller pile-poil.

Je me suis créé un /etc/udev/rules.d/80-video-capture.rules avec

# Pour que la carte TV reste en /dev/video0 et la webcam usb en /dev/video1
SUBSYSTEM=="video4linux", ATTR{name}=="BT878 video (Hauppauge (bt87 8))", NAME="video0"
SUBSYSTEM=="video4linux", ATTR{name}=="UVC Camera (046d:0819)", NAM E="video1"

j'ai récupéré les noms avec
udevadm info -a -p $(udevadm info -q path -n /dev/video0)

On va voir si le pb a définitivement disparu...

--
Daniel

Mieux vaut penser le changement que changer de pansement.
Francis Blanche

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Caillibaud
Le #23269731
Le 08/04/11 à 21:24, "Jean-Yves F. Barbier" JYFB> On Fri, 8 Apr 2011 10:42:16 +0200
JYFB> Daniel Caillibaud JYFB>
JYFB> ...
JYFB> > Visiblement c'est à cause de la webcam USB (UVC) qui doit pass er "avant"
JYFB> > au boot (et récupère en 1er /dev/video0), en tout cas qua nd je la
JYFB> > débranche le pb disparait.
JYFB> >
JYFB> > J'ai pas bcp creusé car je sais pas trop où chercher...
JYFB> > Faut donner un ordre de chargement à udev ? Comment ? (ça je peux creuser
JYFB> > si c'est par là qu'il faut aller)
JYFB>
JYFB> pourquoi faire compliqué lorsqu'on peut faire simple?

En général c'est qu'on sait pas qu'on pourrait faire plus simple ;-)

JYFB> > C'est ailleurs que ça se passe ?
JYFB>
JYFB> dans /etc/modprobe.d, les parms voulus se récupérant par:
JYFB> modinfo nom_du_module
JYFB> la même chose étant, en Gal, possible pour la WC.

Sauf que j'ai aucune idée de quel parm passer à quel module pour que la carte tv reste
en /dev/video0 et la webcam USB en /dev/video1

Les deux utilisent v4l2, la carte utilise bttv et la webcam uvcvideo
mais un modinfo sur ces 3 modules me donne pas grande idée, pas de par m listés.

Y'a aussi videodev au dessus (bttv et uvcvideo en dépendent), mais je sais pas trop comment lui
causer ;-)
(pas de parm non plus)

Reste bttv, qui a plein de parm, dont
parm: video_nr:video device numbers (array of int)

echo 'options bttv video_nr=0' > /etc/modprobe.d/bttv.conf
ferait la même chose que les règles udev ?

--
Daniel

Montrez moi un homme parfaitement satisfait de lui même, et je vous
montrerai un parfait raté.
Thomas Edison

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Jean-Yves F. Barbier
Le #23269911
On Fri, 8 Apr 2011 22:50:28 +0200
Daniel Caillibaud
...
Les deux utilisent v4l2, la carte utilise bttv et la webcam uvcvideo
mais un modinfo sur ces 3 modules me donne pas grande idée, pas de p arm
listés.

Y'a aussi videodev au dessus (bttv et uvcvideo en dépendent), mais j e sais
pas trop comment lui causer ;-)



çui-là y cause point.

(pas de parm non plus)

Reste bttv, qui a plein de parm, dont
parm: video_nr:video device numbers (array of int)

echo 'options bttv video_nr=0' > /etc/modprobe.d/bttv.conf
ferait la même chose que les règles udev ?



vi; malheureusement pour toi, le drv de la WC ne possède pas de parm
permettant la même chose, et comme c'est lui qui est chargé en pr emier...
mais tu peux intervertir les n°:)

comme l'a fait remarquer Sylvain, udev permet un réglage fin, mais sup porte
mal les erreurs éventuelles de conf.

--
BOFH excuse #308:
CD-ROM server needs recalibration

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Daniel Caillibaud
Le #23270811
Le 09/04/11 à 00:15, "Jean-Yves F. Barbier" JYFB> > Reste bttv, qui a plein de parm, dont
JYFB> > parm: video_nr:video device numbers (array of int)
JYFB> >
JYFB> > echo 'options bttv video_nr=0' > /etc/modprobe.d/bttv.conf
JYFB> > ferait la même chose que les règles udev ?
JYFB>
JYFB> vi; malheureusement pour toi, le drv de la WC ne possède pas de parm
JYFB> permettant la même chose, et comme c'est lui qui est chargé en premier...
JYFB> mais tu peux intervertir les n°:)

Le pb est que le driver de la webcam est visiblement pas toujours chargà © en premier (en tout
cas il a pas toujours /dev/video0), mais je note que je pourrais fixer bttv sur /dev/video1
comme ça.

JYFB> comme l'a fait remarquer Sylvain, udev permet un réglage fin, ma is supporte
JYFB> mal les erreurs éventuelles de conf.

Oui, j'ai fixé les règles udev, ça a l'air de marcher...
J'essaierai de mettre ça sur le wiki debian.

--
Daniel

La justice, c'est comme la Sainte Vierge. Si elle n'apparaît pas
de temps en temps, le doute s'installe.
Michel Audiard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme