Cellules avec caractères accentuées

Le
Albert
Bonjour

Comment compter les noms, prénoms ayant des caractères accentés dans une
liste de plus de 500 noms.

Colonne B = Nom, Colonne C = Prénom

J'ai essayé =NB.SI(B2:B500;"é") mais sans succès.

Merci de vos suggestions


--
albertri-at-videotron.ca.invalid
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23559911
Bonjour,
=NB.SI(B2:B500;"*é*")
mais, bien sûr, ce n'est valable que pour les "é".
Si tu veux une solution recherchant toutes les cellules contenant un
caractère accentué, dis-le.
Cordialement.
Daniel


Bonjour

Comment compter les noms, prénoms ayant des caractères accentés dans une
liste de plus de 500 noms.

Colonne B = Nom, Colonne C = Prénom

J'ai essayé =NB.SI(B2:B500;"é") mais sans succès.

Merci de vos suggestions
Albert
Le #23559961
Bonjour DanielCo

Il s'agit simplement de compter le nombre de noms contenant un caractère
accentué, é, è, ô etc..

Avec les filtres on a un bon aperçu, mais cela ne donne pas le compte.

merci
Albert

"DanielCo" news:ivk6g3$11p$
Bonjour,
=NB.SI(B2:B500;"*é*")
mais, bien sûr, ce n'est valable que pour les "é".
Si tu veux une solution recherchant toutes les cellules contenant un
caractère accentué, dis-le.
Cordialement.
Daniel


Bonjour

Comment compter les noms, prénoms ayant des caractères accentés dans une
liste de plus de 500 noms.

Colonne B = Nom, Colonne C = Prénom

J'ai essayé =NB.SI(B2:B500;"é") mais sans succès.

Merci de vos suggestions




DanielCo
Le #23560601
Essaie :

Sub test3()
Dim c As Range, Ctr As Long, i As Integer
For Each c In Range([A1], Cells(Rows.Count, 1).End(xlUp))
For i = 1 To Len(c.Value)
If LCase(Mid(c.Value, i, 1)) <= "a" Or LCase(Mid(c.Value, i,
1)) > "z" Then
If LCase(Mid(c.Value, i, 1)) <> "-" And LCase(Mid(c.Value,
i, 1)) <> "'" _
And LCase(Mid(c.Value, i, 1)) <> " " Then
Ctr = Ctr + 1
Exit For
End If
End If
Next i
Next c
MsgBox Ctr
End Sub

Daniel


Bonjour DanielCo

Il s'agit simplement de compter le nombre de noms contenant un caractère
accentué, é, è, ô etc..

Avec les filtres on a un bon aperçu, mais cela ne donne pas le compte.

merci
Albert

"DanielCo" news:ivk6g3$11p$
Bonjour,
=NB.SI(B2:B500;"*é*")
mais, bien sûr, ce n'est valable que pour les "é".
Si tu veux une solution recherchant toutes les cellules contenant un
caractère accentué, dis-le.
Cordialement.
Daniel


Bonjour

Comment compter les noms, prénoms ayant des caractères accentés dans une
liste de plus de 500 noms.

Colonne B = Nom, Colonne C = Prénom

J'ai essayé =NB.SI(B2:B500;"é") mais sans succès.

Merci de vos suggestions




Albert
Le #23561271
Rebonjour
Je répond au début

Il y a 543 lignes dans le fichier et Sub Test(3) donne comme résultat 543
incluant les entêtes
J'ai placé ce module dans ThisWorkBook et ensuite dans Module1 avec le même
résultat.
J'ai supprimé les colonnes où il y des mots avec accent(s) et j'ai encore
le même compte.

Il y a environ ±150 lignes avec des mots accentués, ce serait bien si on
pourrait compter les lignes contenants des cellules avec mots accentués,
cela inclurait alors la colonne B Nom de famille, la colonne C Prénoms, la
colonne D Concaténation de nom+prénom, la colonne E adresse civique, la
colonne F la ville.

merci
albert

"DanielCo" news:ivkhrl$vcf$
Essaie :

Sub test3()
Dim c As Range, Ctr As Long, i As Integer
For Each c In Range([A1], Cells(Rows.Count, 1).End(xlUp))
For i = 1 To Len(c.Value)
If LCase(Mid(c.Value, i, 1)) "z" Then
If LCase(Mid(c.Value, i, 1)) <> "-" And LCase(Mid(c.Value, i,
1)) <> "'" _
And LCase(Mid(c.Value, i, 1)) <> " " Then
Ctr = Ctr + 1
Exit For
End If
End If
Next i
Next c
MsgBox Ctr
End Sub

Daniel


Bonjour DanielCo

Il s'agit simplement de compter le nombre de noms contenant un caractère
accentué, é, è, ô etc..

Avec les filtres on a un bon aperçu, mais cela ne donne pas le compte.

merci
Albert

"DanielCo" news:ivk6g3$11p$
Bonjour,
=NB.SI(B2:B500;"*é*")
mais, bien sûr, ce n'est valable que pour les "é".
Si tu veux une solution recherchant toutes les cellules contenant un
caractère accentué, dis-le.
Cordialement.
Daniel


Bonjour

Comment compter les noms, prénoms ayant des caractères accentés dans
une liste de plus de 500 noms.

Colonne B = Nom, Colonne C = Prénom

J'ai essayé =NB.SI(B2:B500;"é") mais sans succès.

Merci de vos suggestions










DanielCo
Le #23561261
Je dirais qu'il y a des caractères non affichables dans les cellules.
Regarde le classeur :
http://www.cijoint.fr/cjlink.php?file=cj201107/cijurrKQD7.xls
Daniel


Rebonjour
Je répond au début

Il y a 543 lignes dans le fichier et Sub Test(3) donne comme résultat 543
incluant les entêtes
J'ai placé ce module dans ThisWorkBook et ensuite dans Module1 avec le même
résultat.
J'ai supprimé les colonnes où il y des mots avec accent(s) et j'ai encore
le même compte.

Il y a environ ±150 lignes avec des mots accentués, ce serait bien si on
pourrait compter les lignes contenants des cellules avec mots accentués,
cela inclurait alors la colonne B Nom de famille, la colonne C Prénoms, la
colonne D Concaténation de nom+prénom, la colonne E adresse civique, la
colonne F la ville.

merci
albert
Albert
Le #23561511
Vous avez raison la colonne A contient les adresses courriel donc le @, j'ai
supprimé la colonne pour le test et le résultat affiché est 360.

Dans votre fichier exemple je compte 4 lignes avec accents et Sub Test3() en
compte 5 ?

Votre compteur pourrait aller à la ligne suivante aussitôt qu'il rencontre
un caractère accentué.

albert



"DanielCo" news:4e1df355$0$18104$
Je dirais qu'il y a des caractères non affichables dans les cellules.
Regarde le classeur :
http://www.cijoint.fr/cjlink.php?file=cj201107/cijurrKQD7.xls
Daniel


Rebonjour
Je répond au début

Il y a 543 lignes dans le fichier et Sub Test(3) donne comme résultat 543
incluant les entêtes
J'ai placé ce module dans ThisWorkBook et ensuite dans Module1 avec le
même résultat.
J'ai supprimé les colonnes où il y des mots avec accent(s) et j'ai
encore le même compte.

Il y a environ ±150 lignes avec des mots accentués, ce serait bien si on
pourrait compter les lignes contenants des cellules avec mots accentués,
cela inclurait alors la colonne B Nom de famille, la colonne C Prénoms,
la colonne D Concaténation de nom+prénom, la colonne E adresse civique,
la colonne F la ville.

merci
albert




DanielCo
Le #23561661
Oui, il y a quelque chose de pas net avec les apostrophes. J'ai pas
trop le temps de regarder ce soir. Qu'est-ce que tu entends par "Votre
compteur pourrait aller à la ligne suivante aussitôt qu'il rencontre un
caractère accentué." ?
Daniel


Vous avez raison la colonne A contient les adresses courriel donc le @, j'ai
supprimé la colonne pour le test et le résultat affiché est 360.

Dans votre fichier exemple je compte 4 lignes avec accents et Sub Test3() en
compte 5 ?

Votre compteur pourrait aller à la ligne suivante aussitôt qu'il rencontre un
caractère accentué.

albert



"DanielCo" news:4e1df355$0$18104$
Je dirais qu'il y a des caractères non affichables dans les cellules.
Regarde le classeur :
http://www.cijoint.fr/cjlink.php?file=cj201107/cijurrKQD7.xls
Daniel


Rebonjour
Je répond au début

Il y a 543 lignes dans le fichier et Sub Test(3) donne comme résultat 543
incluant les entêtes
J'ai placé ce module dans ThisWorkBook et ensuite dans Module1 avec le
même résultat.
J'ai supprimé les colonnes où il y des mots avec accent(s) et j'ai encore
le même compte.

Il y a environ ±150 lignes avec des mots accentués, ce serait bien si on
pourrait compter les lignes contenants des cellules avec mots accentués,
cela inclurait alors la colonne B Nom de famille, la colonne C Prénoms, la
colonne D Concaténation de nom+prénom, la colonne E adresse civique, la
colonne F la ville.

merci
albert




Albert
Le #23561641
Ma description du but recherché a changer depuis ma première demande,
Au début je voulais compter les noms avec accents par colonne, en regardant
votre Macro je vois que vous y allez par ligne (ROW), en effet il faut
traiter différement les adresses avec mot accentué, un seul mot accentué ou
plusieurs dans la ligne compte pour un, donc à la recontre d'un accent on
passe à la ligne suivante,.

Je ne suis pas pressé
merci
Albert


"DanielCo" news:ivkuob$138$
Oui, il y a quelque chose de pas net avec les apostrophes. J'ai pas trop
le temps de regarder ce soir. Qu'est-ce que tu entends par "Votre compteur
pourrait aller à la ligne suivante aussitôt qu'il rencontre un
caractère accentué." ?
Daniel
DanielCo
Le #23562521
Non, je traite une colonne (A dans l'exemple), cellule par cellule.
Mais qu'est-ce que tu entends par "traiter" ?
Daniel

Albert a écrit
Ma description du but recherché a changer depuis ma première demande,
Au début je voulais compter les noms avec accents par colonne, en regardant
votre Macro je vois que vous y allez par ligne (ROW), en effet il faut
traiter différement les adresses avec mot accentué, un seul mot accentué ou
plusieurs dans la ligne compte pour un, donc à la recontre d'un accent on
passe à la ligne suivante,.

Je ne suis pas pressé
merci
Albert


"DanielCo" news:ivkuob$138$
Oui, il y a quelque chose de pas net avec les apostrophes. J'ai pas trop le
temps de regarder ce soir. Qu'est-ce que tu entends par "Votre compteur
pourrait aller à la ligne suivante aussitôt qu'il rencontre un
caractère accentué." ?
Daniel
Albert
Le #23563451
Bonjour DanielCo

Notre organisation sans but lucratif, veut transmettre aux membres leur
fiche personnelle par publipostage pour mise à jour.
Les FAI ne permettent pas de faire du publipostage par courriel, nous
essayons via un serveur PHP. Malheureusement les fiches personnelles
contenant des accents sont reçues par les membres avec des erreurs. Nous
voulons faire le compte des fiches de membre contenant un accent ou plus,
une fiche par ligne. Les colonnes B,C,D,E et F peuvent contenir des
accents, la colonne A doit obligatoirement contenir le Email. Tout cela en
attendant de trouver la solution avec le serveur PHP.

Merci de votre attention
Albert




"DanielCo" news:ivm52f$bq2$
Non, je traite une colonne (A dans l'exemple), cellule par cellule. Mais
qu'est-ce que tu entends par "traiter" ?
Daniel

Albert a écrit
Ma description du but recherché a changer depuis ma première demande,
Au début je voulais compter les noms avec accents par colonne, en
regardant votre Macro je vois que vous y allez par ligne (ROW), en effet
il faut traiter différement les adresses avec mot accentué, un seul mot
accentué ou plusieurs dans la ligne compte pour un, donc à la recontre
d'un accent on passe à la ligne suivante,.

Je ne suis pas pressé
merci
Albert



Publicité
Poster une réponse
Anonyme