celulle et plage comparatif

Le
STEPH B
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen de
savoir si ce chiffre est contenu dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne c
en rouge.

merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
STEPH B
Le #21258181
je l ai trouvé sur le net

voici le code ca peut aider mais a mettre au gout du jour si kelkun connais
une astuce pour l accelerer c est encore mieux

Sub monchiffre()
Dim it As Variant
Dim c
dcolc = Cells(Rows.Count, "c").End(3).Row
For zz = dcolc To 2 Step -1
it = Range("c" & zz).Value
For Each c In Range("j1:p10000")
If c = it Then
Range("c" & zz).Select
With Selection.Interior
.ColorIndex = 3
.Pattern = xlSolid
End With
End If
Next
Next
zz = 1
it = Range("c" & zz).Value
For Each c In Range("j1:p10000")
If c = it Then
Range("c" & zz).Select
With Selection.Interior
.ColorIndex = 3
.Pattern = xlSolid
End With
End If
Next
End Sub



"STEPH B" 4b852128$0$17886$
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen de
savoir si ce chiffre est contenu dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne c
en rouge.

merci d'avance.




Jacky
Le #21258291
Bonjour,

Sélection des données en colonne C
Menu Format / Mise en forme conditionnelle
Condition 1 ==> La formule est: =NB.SI($J$1:$J$5000;$C1)
Format ==>motif ==>la choix de la couleur
Ok
--
Salutations
JJ


"STEPH B" 4b852128$0$17886$
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen de savoir si ce chiffre est contenu
dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne c en rouge.

merci d'avance.




Jacky
Le #21258561
Oupsss!!
Pas vu le P de P5000
Donc
Condition 1 ==> La formule est =NB.SI($J$1:$P$5000;$C1)

Ou en VBA
'---------------
Sub jj()
Dim c As Range
[c:c].Interior.ColorIndex = 0
For Each c In Range("c1:c" & Cells(Rows.Count, "c").End(3).Row)
If Application.CountIf([j1:P5000], c) Then c.Interior.ColorIndex = 3
Next
End Sub

'-------------------
--
Salutations
JJ


"Jacky"
Bonjour,

Sélection des données en colonne C
Menu Format / Mise en forme conditionnelle
Condition 1 ==> La formule est: =NB.SI($J$1:$J$5000;$C1)
Format ==>motif ==>la choix de la couleur
Ok
--
Salutations
JJ


"STEPH B" 4b852128$0$17886$
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen de savoir si ce chiffre est contenu
dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne c en rouge.

merci d'avance.








STEPH B
Le #21259781
MERCI BCP
ton code est bcp plus rapide que le mien


"Jacky"
Oupsss!!
Pas vu le P de P5000
Donc
Condition 1 ==> La formule est =NB.SI($J$1:$P$5000;$C1)

Ou en VBA
'---------------
Sub jj()
Dim c As Range
[c:c].Interior.ColorIndex = 0
For Each c In Range("c1:c" & Cells(Rows.Count, "c").End(3).Row)
If Application.CountIf([j1:P5000], c) Then c.Interior.ColorIndex = 3
Next
End Sub

'-------------------
--
Salutations
JJ


"Jacky"
Bonjour,

Sélection des données en colonne C
Menu Format / Mise en forme conditionnelle
Condition 1 ==> La formule est: =NB.SI($J$1:$J$5000;$C1)
Format ==>motif ==>la choix de la couleur
Ok
--
Salutations
JJ


"STEPH B" 4b852128$0$17886$
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen
de savoir si ce chiffre est contenu dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne
c en rouge.

merci d'avance.












Jacky
Le #21260081
RE...
Pourquoi n'utilises-tu pas La MFC ??

En vba, ceci peut augmenter la vitesse d'exécution d'une manière assez considérable
"Application.Calculation = xlCalculationManual"
'----------------
Sub jj()
Application.ScreenUpdating = False
Application.Calculation = xlCalculationManual
Dim c As Range
[c:c].Interior.ColorIndex = 0
For Each c In Range("c1:c" & Cells(Rows.Count, "c").End(3).Row)
If Application.CountIf([j1:P5000], c) Then c.Interior.ColorIndex = 3
Next
Application.Calculation = xlCalculationAutomatic
End Sub
'-------------------

--
Salutations
JJ


"STEPH B" 4b8557c3$0$15841$
MERCI BCP
ton code est bcp plus rapide que le mien


"Jacky"
Oupsss!!
Pas vu le P de P5000
Donc
Condition 1 ==> La formule est =NB.SI($J$1:$P$5000;$C1)

Ou en VBA
'---------------
Sub jj()
Dim c As Range
[c:c].Interior.ColorIndex = 0
For Each c In Range("c1:c" & Cells(Rows.Count, "c").End(3).Row)
If Application.CountIf([j1:P5000], c) Then c.Interior.ColorIndex = 3
Next
End Sub

'-------------------
--
Salutations
JJ


"Jacky"
Bonjour,

Sélection des données en colonne C
Menu Format / Mise en forme conditionnelle
Condition 1 ==> La formule est: =NB.SI($J$1:$J$5000;$C1)
Format ==>motif ==>la choix de la couleur
Ok
--
Salutations
JJ


"STEPH B" 4b852128$0$17886$
Bonjour
je dispose de chiffre en colonne c et je voudrais si il existe un moyen de savoir si ce chiffre est
contenu dans une plage je J1 à P5000.

si tel est le cas alors qu'il mette le chiffre en question de la colonne c en rouge.

merci d'avance.
















Publicité
Poster une réponse
Anonyme