chiffres paire et arrondir

Le
Pellet15
bonjour a tous

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23437561
Bonjour,
Avec le nombre en A1 :
=SI(ENT(A1)<>A1;ENT(A1)+2;A1)
Cordialement.
Daniel


bonjour a tous

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6

Merci
MichD
Le #23437731
Bonjour,

Essaie ceci :

=SI(MOD(ENT(A1);2)=1;ENT(A1)+1;ENT(A1)+2)



MichD
--------------------------------------------
"Pellet15" a écrit dans le message de groupe de discussion :


bonjour a tous

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6

Merci
Tatanka
Le #23437721
Bonjour,

Je suppose que ton nombre est en A1.

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6
=SI(EST.PAIR(ENT(A1));ENT(A1)+2;ENT(A1)+1)

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6
=ENT(A1)+1

Serge
Maude Este
Le #23437711
Bonsour®

"Pellet15" a écrit
J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6



B1=2*(1+ENT(A1/2))
recopier la formule vers le bas
MichD
Le #23437691
Bonjour Maude Este,

Si en A1, il y a 2.5, la formule retourne 5 au lieu de 4
Est-ce normal ?



MichD
--------------------------------------------
"Maude Este" a écrit dans le message de groupe de discussion : isnprh$2bs$

Bonsour®

"Pellet15" a écrit
J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6



B1=2*(1+ENT(A1/2))
recopier la formule vers le bas
Vince35
Le #23437841
Le 08/06/2011 14:00, Pellet15 a écrit :
bonjour a tous

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6




=SI(ENT(A1)<>A1;2*(1+ENT(A1/2));A1)


--
Vincent
Vince35
Le #23437831
et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6

Merci



=ARRONDI.SUP(A1)


--
Vincent
michel ou sam
Le #23438011
Bonjour,
pour la 1ere question
=2*ENT(ARRONDI.SUP(A1/2;0))

pour la 2eme question
=ARRONDI.SUP(A1;0)
Michel

"Pellet15"
bonjour a tous

J'ai besoin que si un nombre avec un décimal soit changer pour un
chifre paire supérieur.
exemple: 2.1 devient 4
3.4 devient 4
4.9 devient 6

et un autre probleme est arrondir au chifre suivant
exemple: 3.1 devient 4
5.4 devient 6

Merci
Maude Este
Le #23438001
Bonsour®

"MichD"
Si en A1, il y a 2.5, la formule retourne 5 au lieu de 4
Est-ce normal ?



??????

B1=2*(1+ENT(A1/2))
recopier la formule vers le bas

1,076945305 2
2,531725264 4
0,468787607 2
7,530633477 8
4,948341161 6
5,578063244 6
9,026216273 10
2,902158246 4
Vince35
Le #23437991
Le 08/06/2011 14:50, Maude Este a écrit :
Bonsour®

"MichD"
Si en A1, il y a 2.5, la formule retourne 5 au lieu de 4
Est-ce normal ?



??????

B1=2*(1+ENT(A1/2))
recopier la formule vers le bas

1,076945305 2
2,531725264 4
0,468787607 2
7,530633477 8
4,948341161 6
5,578063244 6
9,026216273 10
2,902158246 4




OK pour les valeurs décimales mais NON OK pour les entiers pairs

2 ==> 4
4 ==> 6



--
Vincent
Publicité
Poster une réponse
Anonyme