Client debian avec PDC windows 2008R2

Le
Bonjour,

Je dois mettre en des clients debian avec un AD 2008 (imposé !)

Après l'installation de kerberos, winbind, samba, tout est ok
j'obtiens correctement un ticket de service avec kinit
De même, les commandes wbinfo -t / -u / -g fonctionnement
parfaitement.

J'utilise pam_mount pour le montage des homes.
En console tty, tout est ok.

Par contre avec gdm, l'authentification est ok mais avec gnome, xfce
ou fluxbox, j'obtiens des erreurs.
ce qui implique qaue je n'ai pas le gnome-panel ou aucun menu
contextuel sous fluxbox .
Extrait du fichiers .xessions-errors:

***************************************************************************************************************
gdm[2944]: DEBUG: Attempting to parse key string:
daemon/Greeter=/usr/lib/gdm/gdmlogin
gdm[2944]: DEBUG: Attempting to parse key string:
daemon/PreSessionScriptDir=/etc/gdm/PreSession/
gdm[2944]: DEBUG: Forking extra process: /etc/gdm/PreSession/Default
gdm[2945]: DEBUG: Attempting to parse key string: xdmcp/Enableúlse
gdm[2945]: DEBUG: Attempting to parse key string:
daemon/ServAuthDir=/var/lib/gdm
gdm[2945]: DEBUG: Attempting to parse key string:
daemon/RootPath=/sbin:/usr/sbin:/bin:/usr/bin
gdm[2944]: DEBUG: Attempting to parse key string:
daemon/DefaultPath=/bin:/usr/bin
gdm[2944]: DEBUG: Attempting to parse key string:
daemon/BaseXsession=/etc/gdm/Xsession
gdm[2944]: DEBUG: Running /etc/gdm/Xsession gnome-session for slebegue
on :0
/etc/gdm/Xsession: Beginning session setup
/home/slebegue/Bureau was removed, reassigning DESKTOP to homedir
/home/slebegue/Téléchargements was removed, reassigning DOWNLOAD to
homedir
/home/slebegue/Modèles was removed, reassigning TEMPLATES to homedir
/home/slebegue/Public was removed, reassigning PUBLICSHARE to homedir
/home/slebegue/Documents was removed, reassigning DOCUMENTS to homedir
/home/slebegue/Musique was removed, reassigning MUSIC to homedir
/home/slebegue/Images was removed, reassigning PICTURES to homedir
/home/slebegue/Vidéos was removed, reassigning VIDEOS to homedir
gnome-session[2944]: WARNING: Could not parse desktop file
/home/slebegue/.config/autostart/xfconf-migration-4.6.desktop: Le
fichier de clés n'a pas de clé « Name »
gnome-session[2944]: WARNING: could not read
/home/slebegue/.config/autostart/xfconf-migration-4.6.desktop
GNOME_KEYRING_CONTROL=/tmp/keyring-FBvg3i
GNOME_KEYRING_PID017
GNOME_KEYRING_CONTROL=/tmp/keyring-FBvg3i
SSH_AUTH_SOCK=/tmp/keyring-FBvg3i/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-FBvg3i
SSH_AUTH_SOCK=/tmp/keyring-FBvg3i/ssh
Avertissement du gestionnaire de fenêtres : La lecture du fichier de
session enregistré
/home/slebegue/.config/metacity/sessions/109e817bdc60c42f83131435468110503000000029440029.ms
a échoué : L'ouverture du fichier «
/home/slebegue/.config/metacity/sessions/109e817bdc60c42f83131435468110503000000029440029.ms
» a échoué : Aucun fichier ou dossier de ce type

MCS->Xfconf settings migration complete

Failed to create secure directory: Permission non accordée
E: core-util.c: Failed to create secure directory: Permission non
accordée
W: lock-autospawn.c: Impossible d'accèder au verrou autonome.
E: main.c: Failed to acquire autospawn lock

(polkit-gnome-authentication-agent-1:3042): GLib-GObject-WARNING **:
cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:3042): GLib-CRITICAL **:
g_once_init_leave: assertion `initialization_value != 0' failed

** (gnome-volume-control-applet:3038): WARNING **: Connection failed,
reconnecting
***************************************************************************************************************

Linux tokyo 2.6.32-5-686 #1 SMP Mon Jun 13 04:13:06 UTC 2011 i686
GNU/Linux

Je peux transmettre le fichier pam_mount.xml et les fichiers
/etc.pam.d/common* si nécessaire

Merci de votre aide

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/714be36e6e7423258b5f429839c9c104@localhost
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Bernard Schoenacker
Le #23689261
Le Fri, 26 Aug 2011 15:11:08 +0200,

Bonjour,

Je dois mettre en des clients debian avec un AD 2008 (imposé !)

Après l'installation de kerberos, winbind, samba, tout est ok
j'obtiens correctement un ticket de service avec kinit
De même, les commandes wbinfo -t / -u / -g fonctionnement
parfaitement.

J'utilise pam_mount pour le montage des homes.
En console tty, tout est ok.

Par contre avec gdm, l'authentification est ok mais avec gnome, xfce
ou fluxbox, j'obtiens des erreurs.
ce qui implique qaue je n'ai pas le gnome-panel ou aucun menu
contextuel sous fluxbox ....
Extrait du fichiers .xessions-errors:



bonjour,


j'ai trouvé le tuto pour la partie "active-directory" :

http://www.debian-administration.org/articles/340

autrement, quels sont les paquets pam installés ?

slt
bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Le #23691001
Bonjour,

Merci pour ce tuto ma


On Fri, 26 Aug 2011 21:50:19 +0200, Bernard Schoenacker
Le Fri, 26 Aug 2011 15:11:08 +0200,

Bonjour,

Je dois mettre en des clients debian avec un AD 2008 (imposé !)

Après l'installation de kerberos, winbind, samba, tout est ok
j'obtiens correctement un ticket de service avec kinit
De même, les commandes wbinfo -t / -u / -g fonctionnement
parfaitement.

J'utilise pam_mount pour le montage des homes.
En console tty, tout est ok.

Par contre avec gdm, l'authentification est ok mais avec gnome, xfce
ou fluxbox, j'obtiens des erreurs.
ce qui implique qaue je n'ai pas le gnome-panel ou aucun menu
contextuel sous fluxbox ....
Extrait du fichiers .xessions-errors:



bonjour,


j'ai trouvé le tuto pour la partie "active-directory" :

http://www.debian-administration.org/articles/340

autrement, quels sont les paquets pam installés ?

slt
bernard



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Le #23691011
Bonjour,

Merci pour le lien, mais j'ai déjà effectué toutes ces opérations:

********************************************************************************
:/home/info# kinit administrateur
Password for :
:/home/info# klist
Ticket cache: FILE:/tmp/krb5cc_0
Default principal:

Valid starting Expires Service principal
08/27/11 11:20:53 08/27/11 21:24:28 krbtgt/
renew until 08/28/11 11:20:53

:/home/info# net ads join -S seychelles -U administrateur
Enter administrateur's password:
Using short domain name -- EILCO
Joined 'TOKYO' to realm 'eilco.fr'
DNS update failed!

:/home/info# wbinfo -t
checking the trust secret for domain EILCO via RPC calls succeeded

:/home/info# wbinfo -g
ordinateurs du domaine
contrôleurs de domaine
administrateurs du schéma
administrateurs de l’entreprise
éditeurs de certificats
admins du domaine
utilisateurs du domaine
invités du domaine
propriétaires créateurs de la stratégie de groupe
serveurs ras et ias
groupe de réplication dont le mot de passe rodc est autorisé
groupe de réplication dont le mot de passe rodc est refusé
contrôleurs de domaine en lecture seule
contrôleurs de domaine d’entreprise en lecture seule
dnsadmins
dnsupdateproxy

:/home/info# wbinfo -u
TOKYOwnobody
TOKYOwinfo
administrateur
invité
krbtgt
slebegue
:/home/info#

********************************************************************************

Voici les listes des paquets pam:

********************************************************************************
:/home/info# dpkg -l libpam*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
|
État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom Version Description
+++-==============-==============-=========================================== ii libpam-ck-conn 0.4.1-4 ConsoleKit PAM module
ii libpam-crackli 1.1.1-6.1 PAM module to enable cracklib support
ii libpam-dbus 0.2-1 A PAM module which asks the logged in
user f
un libpam-dev <néant> (aucune description n'est disponible)
un libpam-doc <néant> (aucune description n'est disponible)
ii libpam-gnome-k 2.30.3-5 PAM module to unlock the GNOME
keyring upon
un libpam-keyring <néant> (aucune description n'est disponible)
ii libpam-ldap 184-8.5 Pluggable Authentication Module for
LDAP
un libpam-mkhomed <néant> (aucune description n'est disponible)
ii libpam-modules 1.1.1-6.1 Pluggable Authentication Modules for
PAM
un libpam-motd <néant> (aucune description n'est disponible)
ii libpam-mount 2.5-3 PAM module that can mount volumes for
a user
ii libpam-pgsql 0.7.1-4+squeez PAM module to authenticate using a
PostgreSQ
ii libpam-pwdfile 0.99-4 PAM module allowing authentication
via an /e
ii libpam-runtime 1.1.1-6.1 Runtime support for the PAM library
ii libpam-smbpass 2:3.5.6~dfsg-3 pluggable authentication module for
Samba
un libpam-ssh <néant> (aucune description n'est disponible)
ii libpam-sss 1.2.1-4+squeez Pam module for the System Security
Services
ii libpam-tmpdir 0.08-1 automatic per-user temporary
directories
un libpam-umask <néant> (aucune description n'est disponible)
ii libpam0g 1.1.1-6.1 Pluggable Authentication Modules
library
un libpam0g-crack <néant> (aucune description n'est disponible)
ii libpam0g-dev 1.1.1-6.1 Development files for PAM
un libpam0g-util <néant> (aucune description n'est disponible)
:/home/info#

********************************************************************************

Merci encore,
slt

On Fri, 26 Aug 2011 21:50:19 +0200, Bernard Schoenacker
Le Fri, 26 Aug 2011 15:11:08 +0200,

Bonjour,

Je dois mettre en des clients debian avec un AD 2008 (imposé !)

Après l'installation de kerberos, winbind, samba, tout est ok
j'obtiens correctement un ticket de service avec kinit
De même, les commandes wbinfo -t / -u / -g fonctionnement
parfaitement.

J'utilise pam_mount pour le montage des homes.
En console tty, tout est ok.

Par contre avec gdm, l'authentification est ok mais avec gnome, xfce
ou fluxbox, j'obtiens des erreurs.
ce qui implique qaue je n'ai pas le gnome-panel ou aucun menu
contextuel sous fluxbox ....
Extrait du fichiers .xessions-errors:



bonjour,


j'ai trouvé le tuto pour la partie "active-directory" :

http://www.debian-administration.org/articles/340

autrement, quels sont les paquets pam installés ?

slt
bernard



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme