Code hexadécimal sous vista (langage C)

Le
Hans Sébastien
Bonjour,
je suis débutant dans la programmation C
actuelement, je travaille sur un projet de classe qui m'a conduit à la
découverte de l'utilisation du code hexadécimal pour l'affichage des
caractères spéciaux de la langue francaise
mon programme fonctionne sans problème sur mon système (windows XP)
le problème qu'il y a est qu'il ne fonctionne pas convenablement sous
Vista, enfin tous les caractères spéciaux que j'ai remplacé par leur
code hexadécimal ne s'affichez pas normalement sous vista coe c'est le
cas sous xp !!!

y aurait-il pas un moyen pour résoudre ce problème???
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
domi
Le #19813801
Hans Sébastien wrote:
Bonjour,
je suis débutant dans la programmation C...
actuelement, je travaille sur un projet de classe qui m'a conduit à la
découverte de l'utilisation du code hexadécimal pour l'affichage des
caractères spéciaux de la langue francaise...
mon programme fonctionne sans problème sur mon système (windows XP)
le problème qu'il y a est qu'il ne fonctionne pas convenablement sous
Vista, enfin tous les caractères spéciaux que j'ai remplacé par leur
code hexadécimal ne s'affichez pas normalement sous vista coe c'est le
cas sous xp !!!

y aurait-il pas un moyen pour résoudre ce problème???



Sans voir le code...
Tu as bien fait les conversions genre OemToChar() ?
Demsking
Le #19814101
On 23 juil, 14:01, domi
Hans Sébastien wrote:
> Bonjour,
> je suis débutant dans la programmation C...
> actuelement, je travaille sur un projet de classe qui m'a conduit à l a
> découverte de l'utilisation du code hexadécimal pour l'affichage de s
> caractères spéciaux de la langue francaise...
> mon programme fonctionne sans problème sur mon système (windows XP)
> le problème qu'il y a est qu'il ne fonctionne pas convenablement sous
> Vista, enfin tous les caractères spéciaux que j'ai remplacé par l eur
> code hexadécimal ne s'affichez pas normalement sous vista coe c'est l e
> cas sous xp !!!

> y aurait-il pas un moyen pour résoudre ce problème???

Sans voir le code...
Tu as bien fait les conversions genre OemToChar() ?



Non domi, je ne sais même pas ce qu'est cette fonction....
domi
Le #19814461
Demsking wrote:
On 23 juil, 14:01, domi
Sans voir le code...
Tu as bien fait les conversions genre OemToChar() ?



Non domi, je ne sais même pas ce qu'est cette fonction....



Il faudrait voir la partie du code qui ne "fonctionne pas" (c'est vague..)
Publicité
Poster une réponse
Anonyme