Commande ifconfig ath0 down/ ne fonctionne pas

Le
Matsu
Bonjour tout le monde;

Voila je suis sous linux(open suse) depuis peu.

J ai un soucis avec la commande ifconfig ath0 down :

-Je rentre la commande dans un shell (en root) et tout a l'air de
fonctionner puisque je n'ai aucun message d'erreur;

mais, lorsque je rentre "iwconfig" il y a toujours mon interface (ath0)
qui apparait.

Quelqu un aurait -il une piste?(meme la plus "basique").

merci d'avance .

Matsu
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Mihamina Rakotomandimby (R12y)
Le #1885503
Matsu wrote:

ifconfig ath0 down
[...]

mais, lorsque je rentre "iwconfig"


iwconfig n'est pas ifconfig.
Si tu veux que ath0 disparaisse de iwconfig aussi,
alors essaie aussi/plutot:

# iwconfig ath0 down.

N'oublie pas de revenir dire si ça marche.

Matsu
Le #1885464
Tout d'abord merci d 'avoir pris le temps de repondre Mihamina

Rakotomandimby.

J ai essayé la commande met ca me renvoie "down" commande inconnue.

:-(

Et en ce qui concerne la différence entre iw et ifconfig??

L une (iw...) pour le wifi et l'autre(if...) pour l'ethernet ?Ou pas du
tout?.

Merci d'avance

Matsu
Mihamina (R12y) Rakotomandimby
Le #1885456
Matsu -
J ai essayé la commande met ca me renvoie "down" commande inconnue.


Effectivement.

Et en ce qui concerne la différence entre iw et ifconfig??


le man me dit:

DESCRIPTION
Iwconfig is similar to ifconfig(8), but is dedicated to
the wireless interfaces. It is used to set the parameters of the network
interface which are specific to the wireless operation (for example :
the frequency). Iwconfig may also be used to display those parameters,
and the wireless statistics (extracted from /proc/net/wireless).

La dernière phrase _semble_ me conduire à la conclusion que tant que ath0
est listée dans /proc/net/wireless, iwconfig la listera aussi.

(iw...) pour le wifi


"wireless". Le wireless n'est as exclusivement le WiFi.

et l'autre(if...) pour l'ethernet ?Ou pas du
tout?.


Historiquement "if" pour "InterFace" (je crois).
Ca fait beaucoup d'incertitude hein ;-)

Matsu
Le #1885401

Ca fait beaucoup d'incertitude hein ;-)



Pas grave ca fait plaisir d'obtenir des reponses :-)

Eric Belhomme
Le #1887896
Matsu @news.tiscali.fr:

J ai essayé la commande met ca me renvoie "down" commande inconnue.


Et en ce qui concerne la différence entre iw et ifconfig??

L une (iw...) pour le wifi et l'autre(if...) pour l'ethernet ?Ou pas du
tout?.

ifconfig = InterFace config => configuration d'une interface réseau, quel

que soit son type
iwconfig est quant à lui dédié au spécificités wifi des interfaces réseau
wifi.

Il est donc tout à fait normal que ta carte wifi soit toujours listée par
iwconfig alors que l'interface est down. Le seul moyen de faire en sorte
qu'elle ne soit plus listée, c'est de décharger le module.

Dans ton cas, etant donné que tu utilises une carte wifi Atheros, il est
possible de désactiver (outil wlanconfig) la carte sans décharger le module
si tu utilises le driver madwifi-ng

--
Rico

Matsu
Le #1887886
ifconfig = InterFace config => configuration d'une interface réseau, quel
que soit son type
iwconfig est quant à lui dédié au spécificités wifi des interfaces réseau
wifi.

Il est donc tout à fait normal que ta carte wifi soit toujours listée par
iwconfig alors que l'interface est down. Le seul moyen de faire en sorte
qu'elle ne soit plus listée, c'est de décharger le module.

Dans ton cas, etant donné que tu utilises une carte wifi Atheros, il est
possible de désactiver (outil wlanconfig) la carte sans décharger le module
si tu utilises le driver madwifi-ng



:-)Merci pour votre recette, disons que j'avais quelque ingrédients un
peu en bazard ^^


J'ai compris les explications.
Je posterais si je réussi.

Matsu

Eric Belhomme
Le #1887879
Matsu news:f2d0sk$8t9$:

:-)Merci pour votre recette, disons que j'avais quelque ingrédients un
peu en bazard ^^

J'ai compris les explications.
Je posterais si je réussi.

Puisque tu utilises une carte atheros, je te conseille vivement la lecture

du wiki de madwifi http://madwifi.org/wiki/UserDocs

Accessoirement, je te conseille aussi de passer à madwifi-ng, qui permet de
faire beaucoup de choses rigolotes avec ;)

--
Rico

Matsumura
Le #1887865

Puisque tu utilises une carte atheros, je te conseille vivement la lecture

du wiki de madwifi http://madwifi.org/wiki/UserDocs

Accessoirement, je te conseille aussi de passer à madwifi-ng,


Merci de vos conseils;

Je suis sous la vers° madiwi-0.9.3 téléchargée sur Sourceforge.

Je vais essayer de "dégoter" le -ng.

En tout cas, sur Usenet ca répond vite et bien (précis)

Félicitations a ceux qui se donnent la peine .C est top :-)


Caspual
Le #1887864
Le Mon, 14 May 2007 12:40:37 +0200, Matsu a écrit :

Bonjour tout le monde;

Voila je suis sous linux(open suse) depuis peu.

J ai un soucis avec la commande ifconfig ath0 down :

-Je rentre la commande dans un shell (en root) et tout a l'air de
fonctionner puisque je n'ai aucun message d'erreur;

mais, lorsque je rentre "iwconfig" il y a toujours mon interface (ath0)
qui apparait.

Quelqu un aurait -il une piste?(meme la plus "basique").

merci d'avance .

Matsu


Salut

Je viens tout juste d'avoir le même souci. La commande pour enlever une
atheros est :
wlanconfig ath0 destroy

Bye

Matsumura
Le #1887862

Bonjour tout le monde;

Voila je suis sous linux(open suse) depuis peu.

J ai un soucis avec la commande ifconfig ath0 down :

-Je rentre la commande dans un shell (en root) et tout a l'air de
fonctionner puisque je n'ai aucun message d'erreur;

mais, lorsque je rentre "iwconfig" il y a toujours mon interface (ath0)
qui apparait.

Quelqu un aurait -il une piste?(meme la plus "basique").

merci d'avance .

Matsu


Salut

Je viens tout juste d'avoir le même souci. La commande pour enlever une
atheros est :
wlanconfig ath0 destroy

Bye



Alors d'abord merci pour toute vos reponses :Rico, Caspual,et Mihamina.

Il m'est arrivé un truc super moche :un empiergement dans l adaptateur
secteur de mon joli Fujitsu Amilo p1510 .

Il en a résulté une casse de la dalle.(l'ecran).
Je cherche la meilleure (la moins chere surtout) solution pour le réparer.

En éspérant reposter avec mon portable tres vite ^^.

Merci a vous.


Publicité
Poster une réponse
Anonyme