comment calculer une moyenne en omettant les cellules vides ?

Le
OE
Je souhaite calculer des moyennes de prix (sous excel 2003) or mon tableau se
rempli au fur et à mesure des données que j'engrange. De ce fait, certaines
colonnes n'ayant pas encore de données sont en erreur ce qui me fausse mon
tableau récapitulatif.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
papou
Le #4799511
Bonjour
As-tu essayé les fonctions SI et ESTERREUR ?
Cordialement
Pascal

"OE"
Je souhaite calculer des moyennes de prix (sous excel 2003) or mon tableau
se
rempli au fur et à mesure des données que j'engrange. De ce fait,
certaines
colonnes n'ayant pas encore de données sont en erreur ce qui me fausse mon
tableau récapitulatif.



Daniel
Le #4799501
Bonjour.
En supposant tes données en colonne A :
=MOYENNE(SI(ESTNUM(A1:A100);A1:A100;""))
(formule matricielle, valider avec CTRL+MAJ+Entrée)
Cordialement.
Daniel
"OE"
Je souhaite calculer des moyennes de prix (sous excel 2003) or mon tableau
se
rempli au fur et à mesure des données que j'engrange. De ce fait,
certaines
colonnes n'ayant pas encore de données sont en erreur ce qui me fausse mon
tableau récapitulatif.



JB
Le #4673371
Bonjour,

S'il n'y a que des cellules vides, Moyenne ne prend pas les cellules
vides en compte.

S'il y a des zéros: =MOYENNE(SI(A1:A10>0;A1:A10;""))

S'il y a des erreurs:=MOYENNE(SI(ESTERREUR(A1:A10);"";A1:A10))

S'il y a des erreurs et des 0:
=MOYENNE(SI(ESTERREUR(A1:A10);"";SI(A1:A10=0;"";A1:A10)))

JB
On 23 août, 13:52, "papou"
Bonjour
As-tu essayé les fonctions SI et ESTERREUR ?
Cordialement
Pascal

"OE"



Je souhaite calculer des moyennes de prix (sous excel 2003) or mon tabl eau
se
rempli au fur et à mesure des données que j'engrange. De ce fait,
certaines
colonnes n'ayant pas encore de données sont en erreur ce qui me fauss e mon
tableau récapitulatif.- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme