Comment faire la Comparaison de 2 colonnes ?

Le
FPinton
Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont un
chiffre autre que 0 et dont la cellule en paralelle dans la colonne A (sur
la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la colonne
A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un peu
j'ai cru entrevoir une solution en utilisant les formules matricielles, mais
là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #19574461
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser VBA)
c'est de comptabiliser le nombre de cellule de la colonne C qui ont un
chiffre autre que 0 et dont la cellule en paralelle dans la colonne A (sur la
même ligne donc) se trouve elle à 0 (donc sans chiffre dans la colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un peu
j'ai cru entrevoir une solution en utilisant les formules matricielles, mais
là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !


Philippe.R
Le #19574451
Bonsoir,
Tu peux utiliser sommeprod() pour faire ça :
=SOMMEPROD((A1:A25=0)*(C1:C25>0)*(C1:C25))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"FPinton" news:u0aW$
Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !



FPinton
Le #19574431
Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !






Philippe.R
Le #19574421
Oups,
J'ai cru lire totaliser au lieu de comptabiliser ; il va ^être temps de
border le neurone...
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Philippe.R" news:
Bonsoir,
Tu peux utiliser sommeprod() pour faire ça :
=SOMMEPROD((A1:A25=0)*(C1:C25>0)*(C1:C25))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"FPinton" news:u0aW$
Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !






MichDenis
Le #19575001
Bonjour FPinton,

| =SOMMEPROD((A1:A25=0)*(C1:C25<>0))

La formule de Daniel est une formule matricielle.
sauf qu'avec la fonction "sommeprod()", l'usager
n'est pas obligé de valider la saisie par la combinaison
des touches : Ctrl + Maj + Enter

Une autre formule avec la validation matricielle :
Ctrl + Maj + Enter

=SOMME(si((A1:A25=0)*(C1:C25<>0))=1;1;"")







"FPinton"
Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !






LSteph
Le #19574961
Bonjour,

..une autre :

=SOMMEPROD(NON(A1:A8)*(C1:C8))

--
lSteph

FPinton a écrit :
Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont un
chiffre autre que 0 et dont la cellule en paralelle dans la colonne A (sur
la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la colonne
A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un peu
j'ai cru entrevoir une solution en utilisant les formules matricielles, mais
là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !




FPinton
Le #19611881
Bonsoir,

Sur le même principe de formule matricielle, est il possible, au lieu de
comptabiliser un nombre de valeurs, d'additionner par exemple les nombres de
la colonne C qui ont une valeur >0 dans la colonne A ?
Par exemple sur la représentation des 2 colonnes A et C ci dessous, de
pouvoir obtenir comme résultat : 20.5 soit 8.5+5+7

ColonneA ColonneC
10.5 8.5
0 8.5
9 5
0 0
0 10
12 7

D'avance merci de votre aide.



un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
"MichDenis" %
Bonjour FPinton,

| =SOMMEPROD((A1:A25=0)*(C1:C25<>0))

La formule de Daniel est une formule matricielle.
sauf qu'avec la fonction "sommeprod()", l'usager
n'est pas obligé de valider la saisie par la combinaison
des touches : Ctrl + Maj + Enter

Une autre formule avec la validation matricielle :
Ctrl + Maj + Enter

=SOMME(si((A1:A25=0)*(C1:C25<>0))=1;1;"")







"FPinton" discussion :

Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je
ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits
de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !









Philippe.R
Le #19612291
Bonsoir,
=SOMMEPROD((A1:A25>0)*(C1:C25<>0)*(C1:C25))
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"FPinton" news:
Bonsoir,

Sur le même principe de formule matricielle, est il possible, au lieu de
comptabiliser un nombre de valeurs, d'additionner par exemple les nombres
de la colonne C qui ont une valeur >0 dans la colonne A ?
Par exemple sur la représentation des 2 colonnes A et C ci dessous, de
pouvoir obtenir comme résultat : 20.5 soit 8.5+5+7

ColonneA ColonneC
10.5 8.5
0 8.5
9 5
0 0
0 10
12 7

D'avance merci de votre aide.



un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
"MichDenis" %
Bonjour FPinton,

| =SOMMEPROD((A1:A25=0)*(C1:C25<>0))

La formule de Daniel est une formule matricielle.
sauf qu'avec la fonction "sommeprod()", l'usager
n'est pas obligé de valider la saisie par la combinaison
des touches : Ctrl + Maj + Enter

Une autre formule avec la validation matricielle :
Ctrl + Maj + Enter

=SOMME(si((A1:A25=0)*(C1:C25<>0))=1;1;"")







"FPinton" discussion :

Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me
parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je
ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits
de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans
utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui
ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne
A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de
les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant
un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !













Daniel.C
Le #19612281
Bonsoir.
=SOMMEPROD((A1:A6<>0)*C1:C6)
Daniel

Bonsoir,

Sur le même principe de formule matricielle, est il possible, au lieu de
comptabiliser un nombre de valeurs, d'additionner par exemple les nombres de
la colonne C qui ont une valeur >0 dans la colonne A ?
Par exemple sur la représentation des 2 colonnes A et C ci dessous, de
pouvoir obtenir comme résultat : 20.5 soit 8.5+5+7

ColonneA ColonneC
10.5 8.5
0 8.5
9 5
0 0
0 10
12 7

D'avance merci de votre aide.



un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
"MichDenis" %
Bonjour FPinton,

| =SOMMEPROD((A1:A25=0)*(C1:C25<>0))

La formule de Daniel est une formule matricielle.
sauf qu'avec la fonction "sommeprod()", l'usager
n'est pas obligé de valider la saisie par la combinaison
des touches : Ctrl + Maj + Enter

Une autre formule avec la validation matricielle :
Ctrl + Maj + Enter

=SOMME(si((A1:A25=0)*(C1:C25<>0))=1;1;"")







"FPinton" :

Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !











Daniel.C
Le #19612271
Ou plutôt > au lieu de <>.
Daniel

Bonsoir.
=SOMMEPROD((A1:A6<>0)*C1:C6)
Daniel

Bonsoir,

Sur le même principe de formule matricielle, est il possible, au lieu de
comptabiliser un nombre de valeurs, d'additionner par exemple les nombres
de la colonne C qui ont une valeur >0 dans la colonne A ?
Par exemple sur la représentation des 2 colonnes A et C ci dessous, de
pouvoir obtenir comme résultat : 20.5 soit 8.5+5+7

ColonneA ColonneC
10.5 8.5
0 8.5
9 5
0 0
0 10
12 7

D'avance merci de votre aide.



un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
"MichDenis" %
Bonjour FPinton,

| =SOMMEPROD((A1:A25=0)*(C1:C25<>0))

La formule de Daniel est une formule matricielle.
sauf qu'avec la fonction "sommeprod()", l'usager
n'est pas obligé de valider la saisie par la combinaison
des touches : Ctrl + Maj + Enter

Une autre formule avec la validation matricielle :
Ctrl + Maj + Enter

=SOMME(si((A1:A25=0)*(C1:C25<>0))=1;1;"")







"FPinton" discussion :

Merci mille fois Daniel !

C'est exactement ce que je souhaitais obtenir.
Et bien sur, maintenant que j'ai ta formule sous les yeux, elle me parrait
évidente, mais je ne l'aurrais jamais trouvé tout seul...je commençais à
chercher dans les matrices (sans plus de succès d'ailleur).

Encore merci de ton aide.


"Daniel.C"
Bonsoir.
=SOMMEPROD((A1:A25=0)*(C1:C25<>0))
(quoique 0 soit un chiffre)
Daniel

Bonjour à tous,

J'ai un gros soucis que je n'arrive pas à résoudre car je pense que je
ne
maitrise pas du tout les formules matricielles.

Bon voila mon problème :

Dans la colonne A (de la cellule A1 à A25), j'ai des chiffres inscrits
de
façon alléatoire (beaucoup de 0 et quelques chiffres positifs).
Dans la colonne C (de la cellule C1 à C25), j'ai aussi des chiffres.

Ce que je cherche à faire (si possible avec une formule et sans utiliser
VBA) c'est de comptabiliser le nombre de cellule de la colonne C qui ont
un chiffre autre que 0 et dont la cellule en paralelle dans la colonne A
(sur la même ligne donc) se trouve elle à 0 (donc sans chiffre dans la
colonne A).

J'ai beau essayer un peu tout ce que je connais comme fonction et de les
assembler entre elles, je n'arrive à rien de cohérent et en cherchant un
peu j'ai cru entrevoir une solution en utilisant les formules
matricielles, mais là c'est au dessus de mes compétences.:(

Si vous aviez une idée pour me guider un peu ce serait sympa.
D'avance merci pour votre aide !










Publicité
Poster une réponse
Anonyme