Complément

Le
David Vincent
Bonsoir

Suite à 1 question posée hier à 23:04 qui était :
Si je porte un nombre en K4:
Est-il possible de reproduire (n-1) fois B4 en B5 et suivant
Avec K4 >1
Exemple:
Si j'ai Dupond en B4 et 4 en K4:
J'aimerai avoir Dupond reproduit en B5,B6 et B7
soit 4-1 qui est noté en K4
Windoxs et excel XP

Raoul Volfoni m'a répondu gracieusement :
=SI(LIGNE()-LIGNE($B$4)<$K$4;$B$4;"")

ça fonctionne en partie:
en effet si c'était à utiliser une seule fois = nickel

mais ce n'est pas les cas Il s'agit en fait d'évènements successifs
A savoir locations pour une durée de 1, 2 voir jusqu'à 10 jours ou plus

Ce qui implique que la formule ne doit pas être figée

Exemple:
première location en B4 sur 3 jours (B4 à B6) nickel (merci Raoul)

en B7 nouvelle location avec nouveau nom par dessus la formule et en K7 10
pour 10 jours de location et là, ça ne le fait plus
J'ai enlevé les $ sans succès

Auriez-vous une idée

Merci d'avance

DV
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pounet95
Le #18342981
Bonjour,
Si je lis bien, il s'agit là d'un problème de références soit absolues, soit
relatives, soit relativement absolues, soit absolument relatives !!

Plus sérieusement il s'agit de l'écriture des adresses :
$B$4 référence absolue toujours la cellule B4 en référence
$B4 référence absolue relative cellule B de la ligne x
B$4 référence absolue relative cellule ligne 4 de la colonne y

etc ....
Pounet95

"David Vincent" news:49665866$0$18370$
Bonsoir

Suite à 1 question posée hier à 23:04 qui était :
Si je porte un nombre en K4:
Est-il possible de reproduire (n-1) fois B4 en B5 et suivant...
Avec K4 >1
Exemple:
Si j'ai Dupond en B4 et 4 en K4:
J'aimerai avoir Dupond reproduit en B5,B6 et B7
soit 4-1 qui est noté en K4...
Windoxs et excel XP

Raoul Volfoni m'a répondu gracieusement :
=SI(LIGNE()-LIGNE($B$4)<$K$4;$B$4;"")

ça fonctionne en partie:
en effet si c'était à utiliser une seule fois = nickel

mais ce n'est pas les cas... Il s'agit en fait d'évènements successifs...
A savoir locations pour une durée de 1, 2 voir jusqu'à 10 jours ou plus...

Ce qui implique que la formule ne doit pas être figée

Exemple:
première location en B4 sur 3 jours (B4 à B6) nickel (merci Raoul)

en B7 nouvelle location avec nouveau nom par dessus la formule et en K7 10
pour 10 jours de location et là, ça ne le fait plus...
J'ai enlevé les $ sans succès...

Auriez-vous une idée...

Merci d'avance

DV




David Vincent
Le #18346381
Bonjour Pounet 95

Oui oui

J'ai donc enlevé les $ mais ça le fait pas...

Je vais abandonné, j'y planche depuis 2 jours...

Je peux m'en passer

Merci d'avoir regarder

DV
michdenis
Le #18347871
Un petit fichier exemple : http://cjoint.com/?bjwe6CYCKm





"David Vincent" news: 49665866$0$18370$
Bonsoir

Suite à 1 question posée hier à 23:04 qui était :
Si je porte un nombre en K4:
Est-il possible de reproduire (n-1) fois B4 en B5 et suivant...
Avec K4 >1
Exemple:
Si j'ai Dupond en B4 et 4 en K4:
J'aimerai avoir Dupond reproduit en B5,B6 et B7
soit 4-1 qui est noté en K4...
Windoxs et excel XP

Raoul Volfoni m'a répondu gracieusement :
=SI(LIGNE()-LIGNE($B$4)<$K$4;$B$4;"")

ça fonctionne en partie:
en effet si c'était à utiliser une seule fois = nickel

mais ce n'est pas les cas... Il s'agit en fait d'évènements successifs...
A savoir locations pour une durée de 1, 2 voir jusqu'à 10 jours ou plus...

Ce qui implique que la formule ne doit pas être figée

Exemple:
première location en B4 sur 3 jours (B4 à B6) nickel (merci Raoul)

en B7 nouvelle location avec nouveau nom par dessus la formule et en K7 10
pour 10 jours de location et là, ça ne le fait plus...
J'ai enlevé les $ sans succès...

Auriez-vous une idée...

Merci d'avance

DV
michdenis
Le #18349501
Juste pour le plaisir ...

Pour une version améliorée du fichier précédent

http://cjoint.com/?bkbW68VEuU
Publicité
Poster une réponse
Anonyme