Comptage conditionnelle

Le
Abso
Bonjour à tous,
voilà mon problème :
j'ai un tableau Excel qui représente le planning des salariés de mon
entreprise.
En colonne, j'ai les les jours de chaque semaine, à savoir Lundi,
Mardi, Mercredi, Jeudi, Vendredi, Samedi, Dimanche, et ainsi de suite
pour les semaines suivantes .
Sur chaque ligne, j'ai mes salariés avec un T s'il travaille le jour J
ou un RH s'il est en repos.

Je souhaiterais avoir en bout de chaque ligne un compteur qui
correspond au nombre de mercredi ou le salarié n'a pas travaillé,
c'est à dire le nbre de cellule avec RH dans la colonne Mercredi.

Il y a bien la fonction NB.SI, mais je n'arrive pas à l'utiliser avec
la clause de compter seulement que pour les colonnes correspondant à
un Mercredi.

Merci à vous pour votre aide.

Bien cordialement.

Abso.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrick BASTARD
Le #6685471
Bonjour, *Abso*

--
Bien amicordialement,
P. Bastard

Avant d'imprimer ce mail, ayez une pensée pour les arbres.
Soit de A1 àAA1 tes jours au format date.
Soit de A2 à AA2 tes T ou tes RH
La formule :
=SOMMEPROD((JOURSEM(B1:AA1)=3)*(B2:AA2="RH"))
te renverra le nombre de RH dans les mardis.
=SOMMEPROD((JOURSEM(B1:AA1)=2)*(B2:AA2="RH"))
te renverra le nombre de RH dans les lundis.




Bonjour à tous,
voilà mon problème :
j'ai un tableau Excel qui représente le planning des salariés de mon
entreprise.
En colonne, j'ai les les jours de chaque semaine, à savoir Lundi,
Mardi, Mercredi, Jeudi, Vendredi, Samedi, Dimanche, et ainsi de suite
pour les semaines suivantes ....
Sur chaque ligne, j'ai mes salariés avec un T s'il travaille le jour J
ou un RH s'il est en repos.

Je souhaiterais avoir en bout de chaque ligne un compteur qui
correspond au nombre de mercredi ou le salarié n'a pas travaillé,
c'est à dire le nbre de cellule avec RH dans la colonne Mercredi.

Il y a bien la fonction NB.SI, mais je n'arrive pas à l'utiliser avec
la clause de compter seulement que pour les colonnes correspondant à
un Mercredi.

Merci à vous pour votre aide.

Bien cordialement.

Abso.


Patrick BASTARD
Le #6685451
Bonjour, *Abso*

N'importe quoi :
La signature avant la réponse...
La fatigue, sans doute...
PB



Bonjour à tous,
voilà mon problème :
j'ai un tableau Excel qui représente le planning des salariés de mon
entreprise.
En colonne, j'ai les les jours de chaque semaine, à savoir Lundi,
Mardi, Mercredi, Jeudi, Vendredi, Samedi, Dimanche, et ainsi de suite
pour les semaines suivantes ....
Sur chaque ligne, j'ai mes salariés avec un T s'il travaille le jour J
ou un RH s'il est en repos.

Je souhaiterais avoir en bout de chaque ligne un compteur qui
correspond au nombre de mercredi ou le salarié n'a pas travaillé,
c'est à dire le nbre de cellule avec RH dans la colonne Mercredi.

Il y a bien la fonction NB.SI, mais je n'arrive pas à l'utiliser avec
la clause de compter seulement que pour les colonnes correspondant à
un Mercredi.

Merci à vous pour votre aide.

Bien cordialement.

Abso.


Jacky
Le #6685431
Bonjour,

Ou encore....
Si la ligne des jours est issue d'une colonne tirée et non pas d'une date,
ceci
=SOMMEPROD(($B$2:$V$2="Mercredi")*(B3:V3="RH"))
voir ici
http://cjoint.com/?fws14FCsvw

--
Salutations
JJ


"Abso"
Bonjour à tous,
voilà mon problème :
j'ai un tableau Excel qui représente le planning des salariés de mon
entreprise.
En colonne, j'ai les les jours de chaque semaine, à savoir Lundi,
Mardi, Mercredi, Jeudi, Vendredi, Samedi, Dimanche, et ainsi de suite
pour les semaines suivantes ....
Sur chaque ligne, j'ai mes salariés avec un T s'il travaille le jour J
ou un RH s'il est en repos.

Je souhaiterais avoir en bout de chaque ligne un compteur qui
correspond au nombre de mercredi ou le salarié n'a pas travaillé,
c'est à dire le nbre de cellule avec RH dans la colonne Mercredi.

Il y a bien la fonction NB.SI, mais je n'arrive pas à l'utiliser avec
la clause de compter seulement que pour les colonnes correspondant à
un Mercredi.

Merci à vous pour votre aide.

Bien cordialement.

Abso.
Abso
Le #6690611
On 22 mai, 19:11, "Jacky"
Bonjour,

Ou encore....
Si la ligne des jours est issue d'une colonne tirée et non pas d'une dat e,
ceci
=SOMMEPROD(($B$2:$V$2="Mercredi")*(B3:V3="RH"))
voir icihttp://cjoint.com/?fws14FCsvw

--
Salutations
JJ

"Abso"
Bonjour à tous,
voilà mon problème :
j'ai un tableau Excel qui représente le planning des salariés de mon
entreprise.
En colonne, j'ai les les jours de chaque semaine, à savoir Lundi,
Mardi, Mercredi, Jeudi, Vendredi, Samedi, Dimanche, et ainsi de suite
pour les semaines suivantes ....
Sur chaque ligne, j'ai mes salariés avec un T s'il travaille le jour J
ou un RH s'il est en repos.

Je souhaiterais avoir en bout de chaque ligne un compteur qui
correspond au nombre de mercredi ou le salarié n'a pas travaillé,
c'est à dire le nbre de cellule avec RH dans la colonne Mercredi.

Il y a bien la fonction NB.SI, mais je n'arrive pas à l'utiliser avec
la clause de compter seulement que pour les colonnes correspondant à
un Mercredi.

Merci à vous pour votre aide.

Bien cordialement.

Abso.



Merci beaucoup à vous deux pour votre aide qui m'est bien utile.
A très bientôt sur ce newsgroup.

Abso.

Publicité
Poster une réponse
Anonyme