Compter une durée total par site + mois + cause

Le
Apitos
Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site + =
Mois + Cause) dans le fichier joint en exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d’éventuelles explications.

Merci d'avance.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #24757402
Bonjour,
=SOMMEPROD(($A$2:$A$94=K2)*(MOIS($C$2:$C$94)<=MOIS(DATEVAL(1 & " " &
$G$2)))*($E$2:$E$94=Criteres)*$D$2:$D$94)
en L2, à recopier.
Limies de la formule : les arrêts chevauchant une limite de mois.
Daniel


Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site + Mois +
Cause) dans le fichier joint en exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d’éventuelles explications.

Merci d'avance.
Jacky
Le #24757802
Bonjour Daniel

Je pense que le "<" est de trop.

Aurais-tu une solution pour les mois chevauchant ??

--
Salutations
JJ


"DanielCo"
Bonjour,
=SOMMEPROD(($A$2:$A$94=K2)*(MOIS($C$2:$C$94)<=MOIS(DATEVAL(1 & " " &
$G$2)))*($E$2:$E$94=Criteres)*$D$2:$D$94)
en L2, à recopier.
Limies de la formule : les arrêts chevauchant une limite de mois.
Daniel


Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site + Mois + Cause) dans le fichier joint
en exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d'éventuelles explications.

Merci d'avance.




Jacky
Le #24757912
Bonjour,

Il y a des fautes de frappe dans la liste de validation sur février et décembre


--
Salutations
JJ


"Apitos"
Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site + Mois + Cause) dans le fichier joint en
exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d’éventuelles explications.

Merci d'avance.
Apitos
Le #24759292
Bonjour Daniel, Jacky

Il y a des fautes de frappe dans la liste de validation sur février et décembre



:)

Je suis en train de bidouiller pour adapter un code VBA.

Une fois avoir la tête seche, je poserais le code pour que quelqu'un me d onne un coup de main ;)
DanielCo
Le #24760712
Bonjour,
Ca complique un maximum. Si ça t'intéresse, je vais tâcher de chercher.
J'avais mis le "<" pour éviter les dates de fin postérieures à août,
mais, dans ce cas, il faut vérifier que le mois de la date de début est
<= août. Je m'absente, maintenant, ce sera pour ce soir.
Cordialement.
Daniel


Bonjour Daniel

Je pense que le "<" est de trop.

Aurais-tu une solution pour les mois chevauchant ??

--
Salutations
JJ


"DanielCo" k27g7j$dr3$
Bonjour,
=SOMMEPROD(($A$2:$A$94=K2)*(MOIS($C$2:$C$94)<=MOIS(DATEVAL(1 & " " &
$G$2)))*($E$2:$E$94=Criteres)*$D$2:$D$94)
en L2, à recopier.
Limies de la formule : les arrêts chevauchant une limite de mois.
Daniel


Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site +
Mois + Cause) dans le fichier joint en exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d'éventuelles explications.

Merci d'avance.




Jacky
Le #24760882
Re..

J'avais mis le "<" pour éviter les dates de fin postérieures à août,


Il va prendre en compte les arrêts des mois déjà écoulés
Exemple
site =tid
mois =octobre
cause =cs
Arrêt avec "<=" ==> 01jour 13h 05mn==>faux
Arrêt avec "=" ==> 00jour 00h 00mn==>juste

Si ça t'intéresse, je vais tâcher de chercher


Oui cela m'intéresse, mon neurone flanche lâchement.
Mais il n'y a aucune urgence, et seulement si tu en as envie.
Aucune obligation bien sûr.

--
Salutations
JJ


"DanielCo"
Bonjour,
Ca complique un maximum. Si ça t'intéresse, je vais tâcher de chercher. J'avais mis le "<" pour éviter les
dates de fin postérieures à août, mais, dans ce cas, il faut vérifier que le mois de la date de début est <=
août. Je m'absente, maintenant, ce sera pour ce soir.
Cordialement.
Daniel


Bonjour Daniel

Je pense que le "<" est de trop.

Aurais-tu une solution pour les mois chevauchant ??

--
Salutations
JJ


"DanielCo"
Bonjour,
=SOMMEPROD(($A$2:$A$94=K2)*(MOIS($C$2:$C$94)<=MOIS(DATEVAL(1 & " " &
$G$2)))*($E$2:$E$94=Criteres)*$D$2:$D$94)
en L2, à recopier.
Limies de la formule : les arrêts chevauchant une limite de mois.
Daniel


Bonjour à tous,

Comment puis-je compter une durée total par ces trois critères (Site + Mois + Cause) dans le fichier
joint en exemple ?

http://cjoint.com/?BIfnH76YVfA

Je suis prés pour d'éventuelles explications.

Merci d'avance.










DanielCo
Le #24761102
La formule (matricielle) cidessous semble fonctionner avec les données
du classeur d'Apitos (pour la cellule L2). J'ai juste remplacé le mois
en lettres par son numéro en G2 :
=SOMME((MOIS($B$2:$B$94)<=$G$2)*(MOIS($C$2:$C$94)>=$G$2)*($E$2:$E$94=Criteres)*($A$2:$A$94=K2)*((SI($C$2:$C$94<ÚTE(2012;$G$2+1;0);$C$2:$C$94;DATE(2012;$G$2+1;0)))-(SI($B$2:$B$94>DATE(2012;$G$2;1);$B$2:$B$94;DATE(2012;$G$2;1)))))
Il reste à la tester sérieusement.
Daniel

Oui cela m'intéresse, mon neurone flanche lâchement.
Apitos
Le #24763852
Bonjour Daniel, Jacky

J'ai changé le mois de G2 à H2.

J'ai nommé [Critère] en [Cause]þuil1!I2

Ainsi j'ai essayé la formule :

=SOMME((MOIS($B$2:$B$94)<=$H$2)*(MOIS($C$2:$C$94)>=$H$2)*($E$2:$E$94 Êuse)*($A$2:$A$94=K2)*((SI($C$2:$C$94<ÚTE(2012;$H$2+1;0);$C$2:$C$ 94;DATE(2012;$H$2+1;0)))-(SI($B$2:$B$94>DATE(2012;$H$2;1);$B$2:$B$94;DATE(2 012;$H$2;1)))))

Mais je n'ai que des #VALEUR!

http://cjoint.com/?BIhmIg08FTA

Merci.
Jacquouille
Le #24764122
Bonjour Apitos
J'ai nommé tes colonnes du nom de leur en-tête.
Ceci donne 05:46:00
=SOMMEPROD((MOIS(début)<=8)*(MOIS(fin)>=8)*(cause=$I$2)*(site=$K$13)*durée)
Est-ce cela que tu désires?


Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"Apitos" a écrit dans le message de groupe de discussion :


Bonjour Daniel, Jacky

J'ai changé le mois de G2 à H2.

J'ai nommé [Critère] en [Cause]þuil1!I2

Ainsi j'ai essayé la formule :

=SOMME((MOIS($B$2:$B$94)<=$H$2)*(MOIS($C$2:$C$94)>=$H$2)*($E$2:$E$94Êuse)*($A$2:$A$94=K2)*((SI($C$2:$C$94<ÚTE(2012;$H$2+1;0);$C$2:$C$94;DATE(2012;$H$2+1;0)))-(SI($B$2:$B$94>DATE(2012;$H$2;1);$B$2:$B$94;DATE(2012;$H$2;1)))))

Mais je n'ai que des #VALEUR!

http://cjoint.com/?BIhmIg08FTA

Merci.
Apitos
Le #24764662
Bonjour Jaquouille,

Ca donne bien des résultatn sauf pour les durée qui s'ettendent entre d es dates de mois defferents.

Par exemple pour le site ADB, le calcul me donnera :

ADB 02 jour(s) 13 heure(s) 12 minute(s)

Pour :

Site Début Fin Durée de l'arrêt Cause Durée (min)
ADB 30/07/2012 13:57 01/08/2012 15:41 02 jour 01h:44mn CS 2984
ADB 09/08/2012 00:31 09/08/2012 11:59 00 jour 11h:28mn CS 688

Or pour la premiere ligre, la durée de l'arrêt s'ettend du 30/07/2012 1 3:57 jusqu'au 01/08/2012 15:41

DAns ce cas le calcul ne devra prendre en compte que la durée allant du 0 1/08/2012 00:00 au 01/08/2012 15:41, soit une durée de 15 heures et 41 mi nutes.

Alors on se retrouvera en fin de compte, avec une durée de 00 jours(s) 27 heure(s) 09 minute(s)

Voila !
Publicité
Poster une réponse
Anonyme