compter le nombre de samedi

Le
francky54 Hors ligne
Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine sauf pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #23681801
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.
MichD
Le #23682691
Bonjour,

Lorsque la cellule est vide, cette formule
=JOURSEM(A1;1) retourne 7

Essaie plutôt comme ceci :
=SOMMEPROD((C45:C56<>"")*(JOURSEM(C45:C56;1)=7))


MichD
--------------------------------------------
Charles
Le #23681901
Salut Franky

Ta formule fonctionne parfaitement bien.

Remplace simplement le 7(dimanche) par un 6(samedi).

J'ai testé, aucune raison de modifer

Galto
"DanielCo" news:j33duc$obi$
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine
sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.




francky54 Hors ligne
Le #23681871
DanielCo a écrit le 24/08/2011 à 19h55 :
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.




j'obtiens un résultat erroné de même que si les cellules sont vide le résultat est egale a 12

merci de votre reponse
Jacquouille
Le #23681941
Bonjour
Vérifie bien que toutes les cel de la plage soient en format nombre/date.
Ensuite, tu valides Sommeprod avec une pression très légère du petit doigt
droit sur la touche ''enter''. pas valider en matricielle.

Le résultat de 12 est JUSTE.
Appliques ta formule sur une plage vierge et tu verras.
S'il n'y a rien dans la cel et qu'elle est formatée en date, Excel considère
(à tort ou à raison) que la cel contient une valeur = au 1/1/1900 qui est un
dimanche.
Ta formule demande le nombre de dimanches ....( voir réponse de Charles )

Si tu entres 12 dates valides dans la plage c45:c56 ET que tu modifies ta
formule (remplacer 7 par 6) ( RE voir réponse de Charles), tu auras un bon
résultat.
Vérifies aussi que tes dates soient bien en colonne C. On ne C jamais ...ça
expliquerait le 12 dimanches -)))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"francky54" a écrit dans le message de groupe de discussion :


DanielCo a écrit le 24/08/2011 à 19h55 :
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine




sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.




j'obtiens un résultat erroné de même que si les cellules sont vide le
résultat
est egale a 12

merci de votre reponse
francky54 Hors ligne
Le #23681921
DanielCo a écrit le 24/08/2011 à 19h55 :
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.




mon probleme est résolue j' ai trouve la formule sur le site

=SOMMEPROD((JOURSEM(C45:C56)=7)*(C45:C56<>"")*1)


merci
DanielCo
Le #23682021
Bonjour,
Pourquoi ? le 7 est bien le samedi dans JOURSEM, par défaut.
Daniel


Salut Franky

Ta formule fonctionne parfaitement bien.

Remplace simplement le 7(dimanche) par un 6(samedi).

J'ai testé, aucune raison de modifer

Galto
"DanielCo" news:j33duc$obi$
Bonjour,
Qu'est-ce que tu obtiens, un résultat erronné ou une erreur ?
Cordialement.
Daniel


Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine
sauf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.




Jacquouille
Le #23684351
Bonjour Denis
C'est effectivement cela qui m'a ''enduit'' d'erreur. j'ai aussi fait le
test et il me retourne le 7 avec comme point d'orgue, le 1/1/1900. Pige
pas.
Tu as une explication, steplé?
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
j33usa$1mb$

Bonjour,

Lorsque la cellule est vide, cette formule
=JOURSEM(A1;1) retourne 7

Essaie plutôt comme ceci :
=SOMMEPROD((C45:C56<>"")*(JOURSEM(C45:C56;1)=7))


MichD
--------------------------------------------
DanielCo
Le #23684341
Bonjour,
La cellule vide est considérée généralement (mais pas toujours !) comme
ayant une valeur 0. Ce zéro est , pour le système de dates Excel
Windows, le 01/01/1900, samedi 01/01/1900.
JOURSEM, sans autre option retourne le numéro de jour, le dimanche
étant le jour 1 et par conséquent le samedi est le jour 7.
Cordialement.
Daniel


Bonjour Denis
C'est effectivement cela qui m'a ''enduit'' d'erreur. j'ai aussi fait le
test et il me retourne le 7 avec comme point d'orgue, le 1/1/1900. Pige pas.
Tu as une explication, steplé?
Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
j33usa$1mb$

Bonjour,

Lorsque la cellule est vide, cette formule
=JOURSEM(A1;1) retourne 7

Essaie plutôt comme ceci :
=SOMMEPROD((C45:C56<>"")*(JOURSEM(C45:C56;1)=7))


MichD
--------------------------------------------
LSteph
Le #23684541
Bonjour,

Cette formule renvoie correctement nombre de Samedi, sous réserve que
la plage visée contienne bien des dates.
Si une de ces cellules n'est pas date, elle renvoie #VALEUR!
Si une de ces cellules renvoie elle même un ou plusieurs codes
Erreur , exemple #REF! , ou #DIV/0! c'est le premier code erreur qui
sera retourné.

Cordialement.

--
LSteph


On Aug 24, 7:37 pm, francky54
Bonjour,
je cherche une formule pour compter le nombre de samedi dans une plage de
cellule (cellule au format date).
j'essaye cette formule qui fonctionne pour tous les jours de la semaine s auf
pour le samedi je ne comprends pas pourquoi..
=SOMMEPROD((JOURSEM(C45:C56)=7)*1)

merci de votre aide.
Publicité
Poster une réponse
Anonyme