Compter les rangées avec plusieurs critères

Le
Nancy
Bonjour,

J'ai un tableau qui contient des entiers, des lettres et des cellules vides.
Juste pour illustrer simplement:
5 B
3
C
R 5
2 4
Je veux compter le nombre de rangées qui contiennent des chiffres.
Pourquoi Excel comptabilise les cellules qui contiennent des lettres dans la
syntaxe des formules suivantes ?
=SOMMEPROD(($C$8:$C$12>0)*($D$8:$D$12>0)) réponse 3
=SOMMEPROD(($C$8:$C$12="")*($D$8:$D$12>0)) réponse 1

Quel critère tiendrait seulement compte des nombres ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
garnote
Le #4566171
Bonsoir Nancy,

Est-ce que cette formule répond à ton besoin ?
=SOMMEPROD(ESTNUM(c8:c12)*ESTNUM(d8:d12))

Serge

"Nancy"
Bonjour,

J'ai un tableau qui contient des entiers, des lettres et des cellules vides.
Juste pour illustrer simplement:
5 B
3
C
R 5
2 4
Je veux compter le nombre de rangées qui contiennent des chiffres.
Pourquoi Excel comptabilise les cellules qui contiennent des lettres dans la
syntaxe des formules suivantes ?
=SOMMEPROD(($C$8:$C$12>0)*($D$8:$D$12>0)) réponse 3
=SOMMEPROD(($C$8:$C$12="")*($D$8:$D$12>0)) réponse 1

Quel critère tiendrait seulement compte des nombres ?


garnote
Le #4566151
Bonsoir Nancy,

Est-ce que cette formule répond à ton besoin ?
=SOMMEPROD(ESTNUM($C$8:$C$12)*ESTNUM($D$8:$D$12))

Serge

"Nancy"
Bonjour,

J'ai un tableau qui contient des entiers, des lettres et des cellules vides.
Juste pour illustrer simplement:
5 B
3
C
R 5
2 4
Je veux compter le nombre de rangées qui contiennent des chiffres.
Pourquoi Excel comptabilise les cellules qui contiennent des lettres dans la
syntaxe des formules suivantes ?
=SOMMEPROD(($C$8:$C$12>0)*($D$8:$D$12>0)) réponse 3
=SOMMEPROD(($C$8:$C$12="")*($D$8:$D$12>0)) réponse 1

Quel critère tiendrait seulement compte des nombres ?


JB
Le #4566091
=SOMMEPROD(($C$8:$C$12>0)*(ESTNUM(C8:C12))*($D$8:$D$12>0))

JB

On 31 mai, 21:50, Nancy
Bonjour,

J'ai un tableau qui contient des entiers, des lettres et des cellules vid es.
Juste pour illustrer simplement:
5 B
3
C
R 5
2 4
Je veux compter le nombre de rangées qui contiennent des chiffres.
Pourquoi Excel comptabilise les cellules qui contiennent des lettres dans la
syntaxe des formules suivantes ?
=SOMMEPROD(($C$8:$C$12>0)*($D$8:$D$12>0)) réponse 3
=SOMMEPROD(($C$8:$C$12="")*($D$8:$D$12>0)) réponse 1

Quel critère tiendrait seulement compte des nombres ?


Nancy
Le #4566071
Merci beaucoup, ça fonctionne parfaitement.


Bonsoir Nancy,

Est-ce que cette formule répond à ton besoin ?
=SOMMEPROD(ESTNUM(c8:c12)*ESTNUM(d8:d12))

Serge

"Nancy"
Bonjour,

J'ai un tableau qui contient des entiers, des lettres et des cellules vides.
Juste pour illustrer simplement:
5 B
3
C
R 5
2 4
Je veux compter le nombre de rangées qui contiennent des chiffres.
Pourquoi Excel comptabilise les cellules qui contiennent des lettres dans la
syntaxe des formules suivantes ?
=SOMMEPROD(($C$8:$C$12>0)*($D$8:$D$12>0)) réponse 3
=SOMMEPROD(($C$8:$C$12="")*($D$8:$D$12>0)) réponse 1

Quel critère tiendrait seulement compte des nombres ?







Publicité
Poster une réponse
Anonyme