compter les répetitions de plusieurs valeurs

Le
Shirley
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4813041
Bonjour Shirley,
Regarde du côté de sommeprod(), qui est en quelque sorte un
somme.si.et.si.aussi()
Pour plus de renseignements, quelques informations complémentaires seraient
les bienvenues
--
Philippe.R
"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où


Shirley
Le #4813001
Bonjour Philippe,

Pour être honnête, j'ai un peu de mal avec ces formules un peu complexes.

Je vais te donner plus d'informations.

Mon tableau de saisie de données (COMMANDES) contient les colonnes suivantes :
- Date de commande
- Modèles : Stylos, Cahier, Feutres
- Couleur : Noir, Bleu, Fuschia, ...
- Contact : Bruno, Noël, Anne, ...
- Livré : Oui ou Non
J'y fait donc figurer toutes les commandes de la période au jour le jour.

Mon jour de commande, je souhaiterais utiliser un second tableau STOCKS
contenant les colonnes suivantes :
- Modèles : Stylos, Cahier, Feutres
- Couleur : Noir, Bleu, Fuschia, ...
- Quantité => formule à trouver
- Commandé : Oui ou Non

Je remplis donc ce second tableau en reprenant les valeurs des colonnes
Modèles et Couleur du tableau de COMMANDES. Je procède au tri en enlevant les
doublons.

Ainsi, pour remplir la colonne Quantité de mon tableau STOCKS, je
souhaiterais, par exemple, calculer le nombre de stylos bleus demandés dans
le 1er tableau.

Voilà, je te laisse me conseiller pour la marche à suivre.

Merci d'avance,

Shirley.


Bonjour Shirley,
Regarde du côté de sommeprod(), qui est en quelque sorte un
somme.si.et.si.aussi()
Pour plus de renseignements, quelques informations complémentaires seraient
les bienvenues
--
Philippe.R
"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où






Jacky
Le #4812991
Bonjour,

=SOMMEPROD((A2:A20ñ)*(B2:B20=G1)*(C2:C20=H1))
Un peu comme ici:
http://cjoint.com/?iendKz6gIt

--
Salutations
JJ


"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où


Shirley
Le #4812951
Ca marche.
Merci beaucoup à tous les 2.

Bonne fin de journée,

Shirley.


Bonjour,

=SOMMEPROD((A2:A20ñ)*(B2:B20=G1)*(C2:C20=H1))
Un peu comme ici:
http://cjoint.com/?iendKz6gIt

--
Salutations
JJ


"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où







Shirley
Le #4812581
Rebonjour Jacky,

Grâce à tes indications, j'ai pas mal avancé dans mon modèle.

Je suis déjà contente de pouvoir utiliser la formule mais, tant qu'à faire,
je voudrais simplifier au max l'utilisation de mon tableau.
Penses-tu donc que je puisse simplifier un peu plus la formule que j'utilise
dans la colonne C de l'onglet "Commande de DVDs", notamment en utilisant les
références ZoneTitre et ZoneLangue de mon onglet "Saisie de Données" ? .

Voici mon doc : http://cjoint.com/?iet5341zg7

Je te remercie d'avance,

Shirley.


Bonjour,

=SOMMEPROD((A2:A20ñ)*(B2:B20=G1)*(C2:C20=H1))
Un peu comme ici:
http://cjoint.com/?iendKz6gIt

--
Salutations
JJ


"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où







Jacky
Le #4812551
Re....
Apparemment tu es sous xl2007
Je n'arrive pas à faire fonctionner ton classeur sous xl 2003 :o((
Mais de visu la formule en C4:
=SOMMEPROD((ZoneTitre=$A4)*(ZoneLangue=$B4))
et tirer vers le bas.
Mais..... car il y a un mais.....
Pour que cela fonctionne, il faut absolument que tes plages
nommées"ZoneTitre" et "ZoneLangue" soient de même longueur, ce qui n'est pas
le cas.
='Saisie des Données'!$E$5:$E$25 pour "ZoneLangue"
='Saisie des Données'!$D$5:$D$24 pour "ZoneTitre"
Donc à modifier......
--
Salutations
JJ


"Shirley" news:
Rebonjour Jacky,

Grâce à tes indications, j'ai pas mal avancé dans mon modèle.

Je suis déjà contente de pouvoir utiliser la formule mais, tant qu'à
faire,
je voudrais simplifier au max l'utilisation de mon tableau.
Penses-tu donc que je puisse simplifier un peu plus la formule que
j'utilise
dans la colonne C de l'onglet "Commande de DVDs", notamment en utilisant
les
références ZoneTitre et ZoneLangue de mon onglet "Saisie de Données" ? .

Voici mon doc : http://cjoint.com/?iet5341zg7

Je te remercie d'avance,

Shirley.


Bonjour,

=SOMMEPROD((A2:A20ñ)*(B2:B20=G1)*(C2:C20=H1))
Un peu comme ici:
http://cjoint.com/?iendKz6gIt

--
Salutations
JJ


"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la
couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où









Shirley
Le #4812511
Merci beaucoup, Jacky pour ces dernières précisions.
C'étaient en effet le fait que les 2 zones soient de longueurs qui bloquait
ma formule.
Merci pour tout.
Bonne soirée,
Shirley.


Re....
Apparemment tu es sous xl2007
Je n'arrive pas à faire fonctionner ton classeur sous xl 2003 :o((
Mais de visu la formule en C4:
=SOMMEPROD((ZoneTitre=$A4)*(ZoneLangue=$B4))
et tirer vers le bas.
Mais..... car il y a un mais.....
Pour que cela fonctionne, il faut absolument que tes plages
nommées"ZoneTitre" et "ZoneLangue" soient de même longueur, ce qui n'est pas
le cas.
='Saisie des Données'!$E$5:$E$25 pour "ZoneLangue"
='Saisie des Données'!$D$5:$D$24 pour "ZoneTitre"
Donc à modifier......
--
Salutations
JJ


"Shirley" news:
Rebonjour Jacky,

Grâce à tes indications, j'ai pas mal avancé dans mon modèle.

Je suis déjà contente de pouvoir utiliser la formule mais, tant qu'à
faire,
je voudrais simplifier au max l'utilisation de mon tableau.
Penses-tu donc que je puisse simplifier un peu plus la formule que
j'utilise
dans la colonne C de l'onglet "Commande de DVDs", notamment en utilisant
les
références ZoneTitre et ZoneLangue de mon onglet "Saisie de Données" ? .

Voici mon doc : http://cjoint.com/?iet5341zg7

Je te remercie d'avance,

Shirley.


Bonjour,

=SOMMEPROD((A2:A20ñ)*(B2:B20=G1)*(C2:C20=H1))
Un peu comme ici:
http://cjoint.com/?iendKz6gIt

--
Salutations
JJ


"Shirley" news:
Bonjour,

Je suis entrain de travailler sur un tableau d'aide à la commandes de
produits.

Les produits se distinguent grâce à 2 critères : le modèle et la
couleur.

Je souhaite donc faire un récapitulatif des quantités à commander par
modèle
et par couleur.

Quelle est la formule pour pouvoir calculer ces quantités ?

J'ai essayé avec des NB.SI et des SOMME(SI mais toutes mes formules ont
été
erronées jusqu'à présent.
Merci d'avance pour votre aide,
Shirley.


Comment puis-je faire pour avoir le nombre de fois où














Publicité
Poster une réponse
Anonyme