configuration baroque

Le
Philippe Vessaire
Bonjour,

j'ai une configuration peu habituelle:

un disque SATA principal
un DVDrom en IDE natif sur la carte mère
deux disques IDE sur carte PCI (avec fonction raid que je n'utilise pas)

Les disque sont normalement vus comme sda, hda, sdb et sdc dans
l'ordre.

Sauf que de temps en temps, au boot, le disque SATA devient sdc
D'autres fois, linux (ubuntu) ne monte pas la partition sda6 qui
est /home La partition sda5 (racine) est bien montée, elle

La carte mère: ASUS M2A-VM chipset AMD 690 processeur X2 5600.
la carte IDE n'intervient pas, ce sont des vieux disques pour conserver
de vielles données.


Comment forcer l'ordre des disques?

D'où peut venir l'erreur qui fait rejeter un montage au démarrage alors
que, une fois logué en console, je peux la monter et ensuite avoir
accès a /home ?

Merci
--
Volem rien foutre al païs!
Philippe Vessaire Ò¿Ó¬
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien LE LEZ
Le #1917796
On Wed, 20 Feb 2008 09:31:27 +0100, Philippe Vessaire :

Sauf que de temps en temps, au boot, le disque SATA devient sdc...


Dis-donc, mon petit, faudrait peut-être lire un peu le forum avant d'y
poser des questions ?
La même question a été posée dans le thread "peripherique USB et
nommage dans /dev".

Philippe Vessaire
Le #1917792
Fabien LE LEZ wrote:

On Wed, 20 Feb 2008 09:31:27 +0100, Philippe Vessaire :

Sauf que de temps en temps, au boot, le disque SATA devient sdc...


La même question a été posée dans le thread "peripherique USB et
nommage dans /dev".
dis donc papy, ce n'est pas la même question.

Tout est branché en permanence, c'est là depuis l'installation sur
disque vierge et le fstab est tout à fait conforme au dernier standard
avec les uuid...

donc mes questions sont toujours là:

Sauf que de temps en temps, au boot, le disque SATA devient sdc...
et bien sur, ça ne démarre même pas...






D'autres fois, linux (ubuntu) ne monte pas la partition sda6 qui
est /home ... La partition sda5 (racine) est bien montée, elle ...




As-tu une solution car je ne voie pas comment un montage a la main
fonctionne alors que le montage habituel au boot ne s'est pas fait...



--
Volem rien foutre al païs!
Philippe Vessaire Ò¿Ó¬



J-P
Le #1917791
Bonjour,

j'ai une configuration peu habituelle:

un disque SATA principal
un DVDrom en IDE natif sur la carte mère
deux disques IDE sur carte PCI (avec fonction raid que je n'utilise pas)

Les disque sont normalement vus comme sda, hda, sdb et sdc dans
l'ordre.

Sauf que de temps en temps, au boot, le disque SATA devient sdc...
D'autres fois, linux (ubuntu) ne monte pas la partition sda6 qui
est /home ... La partition sda5 (racine) est bien montée, elle ...

La carte mère: ASUS M2A-VM chipset AMD 690 processeur X2 5600.
la carte IDE n'intervient pas, ce sont des vieux disques pour conserver
de vielles données.


Comment forcer l'ordre des disques?

D'où peut venir l'erreur qui fait rejeter un montage au démarrage alors
que, une fois logué en console, je peux la monter et ensuite avoir
accès a /home ?

Merci



regarde du côté de udev en créant tes propres règles ou renseigne le
uuid dans ton fstab

Philippe Vessaire
Le #1917790
J-P wrote:

renseigne le uuid dans ton fstab


C'est fait depuis le premier jour...

--
Volem rien foutre al païs!
Philippe Vessaire Ò¿Ó¬

Nicolas S.
Le #1917784
Philippe Vessaire
Sauf que de temps en temps, au boot, le disque SATA devient sdc...


La même question a été posée dans le thread "peripherique USB et
nommage dans /dev".
ce n'est pas la même question.



Tel que tu l'avais présenté, si.

Tout est branché en permanence


Mais tu dis toi-même redémarrer la machine...

Tout est branché en permanence, c'est là depuis l'installation sur
disque vierge


Avec udev, le contenu de /dev est géré de manière dynamique et les
fichiers recréés à chaque démarrage.

disque vierge et le fstab est tout à fait conforme au dernier standard
avec les uuid...


Ok. Tu as donc vérifié qu'ils sont corrects?

Sauf que de temps en temps, au boot, le disque SATA devient sdc...
et bien sur, ça ne démarre même pas...





Information importante, mais ça serait mieux avec le message d'erreur
et si possible en nous disant à quel moment cela intervient au
démarrage.

D'autres fois, linux (ubuntu) ne monte pas la partition sda6 qui
est /home ... La partition sda5 (racine) est bien montée, elle ...




As-tu une solution car je ne voie pas comment un montage a la main
fonctionne alors que le montage habituel au boot ne s'est pas fait...


Une erreur de configuration du fstab? Un script bancal? Plusieurs
versions de noyaux utilisées? Un problème matériel? dmesg?

--
Nicolas S.




Philippe Vessaire
Le #1917782
Nicolas S. wrote:

Sauf que de temps en temps, au boot, le disque SATA devient
sdc...
et bien sur, ça ne démarre même pas...





Information importante, mais ça serait mieux avec le message d'erreur
et si possible en nous disant à quel moment cela intervient au
démarrage.
Ça me semble normal: le disque sda du moment n'a pas de secteur

d'amorçage.
Ou plutôt n'avait pas, jai fait un truc barbare avec grub-install sur
chacun des trois disques.

Là, en fait c'est un problème différent.
D'autres fois, linux (ubuntu) ne monte pas la partition sda6 qui
est /home ... La partition sda5 (racine) est bien montée, elle




As-tu une solution car je ne voie pas comment un montage a la main
fonctionne alors que le montage habituel au boot ne s'est pas fait...


Une erreur de configuration du fstab?
C'est de temps en temps, pas systématique... 1 fois sur 10... C'est bien

là qu'est l'os....

Un script bancal?
C'est en plein dans mon ignorance.

Rien que la config de Kubuntu à l'installation.

Plusieurs versions de noyaux utilisées?
non

SMP Tue Feb 12 07:42:25 UTC 2008 (Ubuntu 2.6.22-14.52-generic)


Un problème matériel?
certainement... voir la fin du message


dmesg?
je mets les dernière lignes d'un boot qui a marché:


début <<<
[ 13.672000] Adding 2803300k swap on /dev/sda8. Priority:-1 extents:1



across:2803300k
[ 14.504000] EXT3 FS on sda5, internal journal
[ 15.796000] kjournald starting. Commit interval 5 seconds
[ 15.796000] EXT3 FS on sda6, internal journal
[ 15.796000] EXT3-fs: mounted filesystem with ordered data mode.
[ 16.268000] kjournald starting. Commit interval 5 seconds
[ 16.276000] EXT3 FS on sdc1, internal journal
[ 16.276000] EXT3-fs: mounted filesystem with ordered data mode.
fin <<<




Voilà, mais c'est sans anomalie ce boot là.
sda5 racine
sda6 /home
sdc1 sans affectation particulière... du vrac venu des anciennes
config.

Les partitions ntfs ne sont pas là...
sda1 en lecture seule.
sdb1 en lecture/écriture (ntfs-3g), le même contenu que sdc1 sur un
disque identique.

J'ai reconfirmé dans le setup le comportement des disques sata comme les
disque pata. Je n'ai pas, de mémoire, les termes exacts, et cette
fonction n'est pas dans la doc papier de la carte mère.
Le problème ne s'est pas reproduit depuis...

merci et A+
--
Volem rien foutre al païs!
Philippe Vessaire Ò¿Ó¬





Publicité
Poster une réponse
Anonyme