Connexion MySQL

Le
steganux
Bonjour,

je souhaite me connecter à une base de données MySQL sur un serveur
distant à partir de l'accès natif windev 9, la connexion se fait bien
par contre je ne peux pas accéder à mes données.
Voici mon code :
SI hDécritConnexion
("dbmysql",user,"pass,hote,base,hAccèsNatifMySQL,hOLectureEcriture)
ALORS
SI PAS HOuvreConnexion("dbmysql") ALORS
Info(HErreurInfo(hErrComplet))
FIN
reqsel="SELECT * FROM dossierweb WHERE EtatEncours=0"
SI HExécuteRequêteSQL(srcsel,"dbmysql",hRequêteDéfaut,reqsel) ALOR=
S
HLitPremier(srcsel)
SINON
Info(HErreurInfo(hErrComplet))
FIN
FIN


Le message d'erreur retourné est : code erreur 70208, Problème
d'initialisation de la requête <srcsel>, Fichier dossierweb inconnu

Pour info j'ai essayé de me connecter à ma base à partir d'un autre
logiciel (phpeditor), et lui fonctionne trés bien, il récupère bien
les données de ma table dossierweb en utilisant le même utilisateur
que sous windev.
J'utilise la dernières MAJ de l'accés natif pour Windev 9, je me
connecte à un MySQL serveur 5.0.2 avec la librairie de ce MySQL 5.0.2.

Merci pour votre aide


Cordialement
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fredo G-MDI
Le #18892421
"steganux"
Bonjour,

je souhaite me connecter à une base de données MySQL sur un serveur
distant à partir de l'accès natif windev 9, la connexion se fait bien
par contre je ne peux pas accéder à mes données.
Voici mon code :
SI hDécritConnexion
("dbmysql",user,"pass,hote,base,hAccèsNatifMySQL,hOLectureEcriture)
ALORS
SI PAS HOuvreConnexion("dbmysql") ALORS
Info(HErreurInfo(hErrComplet))
FIN
reqsel="SELECT * FROM dossierweb WHERE EtatEncours=0"
SI HExécuteRequêteSQL(srcsel,"dbmysql",hRequêteDéfaut,reqsel) ALORS
HLitPremier(srcsel)
SINON
Info(HErreurInfo(hErrComplet))
FIN
FIN


Le message d'erreur retourné est : code erreur 70208, Problème
d'initialisation de la requête <srcsel>, Fichier dossierweb inconnu

Pour info j'ai essayé de me connecter à ma base à partir d'un autre
logiciel (phpeditor), et lui fonctionne trés bien, il récupère bien
les données de ma table dossierweb en utilisant le même utilisateur
que sous windev.
J'utilise la dernières MAJ de l'accés natif pour Windev 9, je me
connecte à un MySQL serveur 5.0.2 avec la librairie de ce MySQL 5.0.2.

Merci pour votre aide


Cordialement


Bonjour, est-ce que tu as bien la bibliothèque "libmysql.dll" dans le RepExe
de ton application ?
Dvlpt.Steganux
Le #18892711
On 13 mar, 15:00, "Fredo G-MDI"
"steganux"
Bonjour,

je souhaite me connecter à une base de données MySQL sur un serveur
distant à partir de l'accès natif windev 9, la connexion se fait bien
par contre je ne peux pas accéder à mes données.
Voici mon code :
SI hDécritConnexion
("dbmysql",user,"pass,hote,base,hAccèsNatifMySQL,hOLectureEcriture)
ALORS
SI PAS HOuvreConnexion("dbmysql") ALORS
Info(HErreurInfo(hErrComplet))
FIN
reqsel="SELECT * FROM dossierweb WHERE EtatEncours=0"
SI HExécuteRequêteSQL(srcsel,"dbmysql",hRequêteDéfaut,reqsel) ALO RS
HLitPremier(srcsel)
SINON
Info(HErreurInfo(hErrComplet))
FIN
FIN

Le message d'erreur retourné est : code erreur 70208, Problème
d'initialisation de la requête <srcsel>, Fichier dossierweb inconnu

Pour info j'ai essayé de me connecter à ma base à partir d'un autre
logiciel (phpeditor), et lui fonctionne trés bien, il récupère bien
les données de ma table dossierweb en utilisant le même utilisateur
que sous windev.
J'utilise la dernières MAJ de l'accés natif pour Windev 9, je me
connecte à un MySQL serveur 5.0.2 avec la librairie de ce MySQL 5.0.2.

Merci pour votre aide

Cordialement

Bonjour, est-ce que tu as bien la bibliothèque "libmysql.dll" dans le R epExe
de ton application ?




oui j'ai bien mis le fichier libmysql.dll dans les repertoires de
l'appli, windev et system32. J'ai essayé avec plusieurs versions
trouvées sur internet et j'ai le même résultat. La connexion à la b ase
se fait bien, c'est vraiment la lecture des tables qui posent problème.
Fredo G-MDI
Le #18893131
Essai d'exécuter la requête "USE nomBDD" avant de faire une requête SELECT.

"Dvlpt.Steganux"
On 13 mar, 15:00, "Fredo G-MDI"
"steganux"
Bonjour,

je souhaite me connecter à une base de données MySQL sur un serveur
distant à partir de l'accès natif windev 9, la connexion se fait bien
par contre je ne peux pas accéder à mes données.
Voici mon code :
SI hDécritConnexion
("dbmysql",user,"pass,hote,base,hAccèsNatifMySQL,hOLectureEcriture)
ALORS
SI PAS HOuvreConnexion("dbmysql") ALORS
Info(HErreurInfo(hErrComplet))
FIN
reqsel="SELECT * FROM dossierweb WHERE EtatEncours=0"
SI HExécuteRequêteSQL(srcsel,"dbmysql",hRequêteDéfaut,reqsel) ALORS
HLitPremier(srcsel)
SINON
Info(HErreurInfo(hErrComplet))
FIN
FIN

Le message d'erreur retourné est : code erreur 70208, Problème
d'initialisation de la requête <srcsel>, Fichier dossierweb inconnu

Pour info j'ai essayé de me connecter à ma base à partir d'un autre
logiciel (phpeditor), et lui fonctionne trés bien, il récupère bien
les données de ma table dossierweb en utilisant le même utilisateur
que sous windev.
J'utilise la dernières MAJ de l'accés natif pour Windev 9, je me
connecte à un MySQL serveur 5.0.2 avec la librairie de ce MySQL 5.0.2.

Merci pour votre aide

Cordialement

Bonjour, est-ce que tu as bien la bibliothèque "libmysql.dll" dans le
RepExe
de ton application ?




oui j'ai bien mis le fichier libmysql.dll dans les repertoires de
l'appli, windev et system32. J'ai essayé avec plusieurs versions
trouvées sur internet et j'ai le même résultat. La connexion à la base
se fait bien, c'est vraiment la lecture des tables qui posent problème.
Dvlpt.Steganux
Le #18911511
La requête "Use bdd" me renvoit une erreur " ... Mot bdd
inattendu ..."

On 13 mar, 16:59, "Fredo G-MDI"
Essai d'exécuter la requête "USE nomBDD" avant de faire une requête SELECT.


Fredo G-MDI
Le #18917831
"USE LeNomDeTaBaseDeDonnees".
Fais les même tests mais avec un
SQLConnecte("NomDSN","User","Pass","","ODBC") et regarde si tu peux exécuter
la requête. Pour la création du "NomDSN" il faut télécharger le driver ODBC
pour MySQL et configurer la connexion avec "User", "Pass", "N° port" et le
nom de la base de données.

"Dvlpt.Steganux"
La requête "Use bdd" me renvoit une erreur " ... Mot bdd
inattendu ..."

On 13 mar, 16:59, "Fredo G-MDI"
Essai d'exécuter la requête "USE nomBDD" avant de faire une requête
SELECT.


Publicité
Poster une réponse
Anonyme