Copier (finder)

Le
Wykaaa
Bonjour,
Je suis sous Mac OS 10.4.9.
J'ai voulu copier un dossier de plus de 1 Go sur une clé USB de 2 Go
(par glissement du dossier sur la racine de la clé).

J'ai eu un message au bout d'un certain temps, après copie de quelques
centaines de fichiers, qui me disait qu'il existait déjà un fichier du
même nom. J'ai cliqué sur OK et la copie s'est arrêtée.

Effectivement, j'avais un fichier qui portait le même nom mais dans un
autre dossier : l'un au niveau 5 et l'autre au niveau 8 de la même
arborescence.
Je considère ceci comme un bug de Mac OS X.

Quelqu'un a-t-il déjà eu ce problème ?
Comment résoudre ce genre de bug ? Par un shell adéquat qui écrase tout
systématiquement ?

Wykaaa
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nina Popravka
Le #2482711
On Tue, 14 Aug 2007 22:01:14 +0200, Wykaaa
Je considère ceci comme un bug de Mac OS X.
Quelqu'un a-t-il déjà eu ce problème ?
Comment résoudre ce genre de bug ? Par un shell adéquat qui écrase tout
systématiquement ?


On va pas s'énerver : si la clé ne doit être relue que par Mac,
initialise la en HFS+. C'est pas vraiment un bug, c'est plus complexe.
J'ai trois clés, une en HFS+ (rose), une en NTFS (bleue), et une en
FAT32 (noire) pour le tout venant.
--
Nina

Wykaaa
Le #2482701
Nina Popravka wrote:

On Tue, 14 Aug 2007 22:01:14 +0200, Wykaaa

Je considère ceci comme un bug de Mac OS X.
Quelqu'un a-t-il déjà eu ce problème ?
Comment résoudre ce genre de bug ? Par un shell adéquat qui écrase tout
systématiquement ?



On va pas s'énerver : si la clé ne doit être relue que par Mac,
initialise la en HFS+. C'est pas vraiment un bug, c'est plus complexe.
J'ai trois clés, une en HFS+ (rose), une en NTFS (bleue), et une en
FAT32 (noire) pour le tout venant.


Tu dis "C'est pas vraiment un bug, c'est plus complexe."
Ca m'intéresse, je veux savoir le fin fond de la chose. Je suis
informaticien depuis 35 ans, j'ai fait des choses comme un optimiseur
pour les calculs flottants dans un compilo FORTRAN ou d'autres
joyeusetés de ce genre. Donc vas-y, explique.
Merci

Wykaaa.


afriqs
Le #2482681
Wykaaa
Tu dis "C'est pas vraiment un bug, c'est plus complexe."
Ca m'intéresse, je veux savoir le fin fond de la chose. Je suis
informaticien depuis 35 ans, j'ai fait des choses comme un optimiseur
pour les calculs flottants dans un compilo FORTRAN ou d'autres
joyeusetés de ce genre. Donc vas-y, explique.


Ouah... j'suis tout retourné....;-))))

ok, je sors =>

--
@lex
MacPro
iBook Dual 600 MHz
Mac OS X v10.4

jperrocheau
Le #2511241
Wykaaa
J'ai eu un message au bout d'un certain temps, après copie de quelques
centaines de fichiers, qui me disait qu'il existait déjà un fichier du
même nom. J'ai cliqué sur OK et la copie s'est arrêtée.


Sur Mac OS X 10.4.x, ce n'est pas OK, mais "Stop" ou "Replace"... ;)

Effectivement, j'avais un fichier qui portait le même nom mais dans un
autre dossier : l'un au niveau 5 et l'autre au niveau 8 de la même
arborescence.


??

Je considère ceci comme un bug de Mac OS X.


~
Ça se discute...

--
Jacques PERROCHEAU
________________________________________________________________________
e-mail: mailto:

Wykaaa
Le #2511231
Jacques Perrocheau wrote:
Wykaaa

J'ai eu un message au bout d'un certain temps, après copie de quelques
centaines de fichiers, qui me disait qu'il existait déjà un fichier du
même nom. J'ai cliqué sur OK et la copie s'est arrêtée.



Sur Mac OS X 10.4.x, ce n'est pas OK, mais "Stop" ou "Replace"... ;)


Effectivement, j'avais un fichier qui portait le même nom mais dans un
autre dossier : l'un au niveau 5 et l'autre au niveau 8 de la même
arborescence.



??


Je considère ceci comme un bug de Mac OS X.



~
Ça se discute...

Je suis désolé mais :

1) le bouton de la fenêtre de warning était bien OK et il n'y avait pas
d'autre choix (pas de bouton stop ou replace, de toute façon j'ai un OS
en français...). La copie s'est arrêtée après le clic sur ce bouton.
2) Pourquoi dire que ça se discute si c'est un bug ou non. Il n'y a
aucune raison d'avoir ce message si les 2 fichiers ne sont pas dans le
même répertoire.
3) Je ne vois pas pourquoi il y a ?? derrière mon paragraphe sur
l'arborescence. Ce que j'explique est tout à fait clair :
rep1->rep2->rep3->rep4->rep5->fichier-toto
rep1->rep2->rep3->rep4->rep5->rep6->rep7->rep8->fichier-toto
rep1 était en fait mon répertoire "documents" dans l'arborescence
"Utilisateurs" et non pas celui de la racine et rep2 à rep5 sont les
mêmes répertoires dans les 2 cas.

Wykaaa


Patrick Stadelmann
Le #2511221
In article Wykaaa
3) Je ne vois pas pourquoi il y a ?? derrière mon paragraphe sur
l'arborescence. Ce que j'explique est tout à fait clair :
rep1->rep2->rep3->rep4->rep5->fichier-toto
rep1->rep2->rep3->rep4->rep5->rep6->rep7->rep8->fichier-toto
rep1 était en fait mon répertoire "documents" dans l'arborescence
"Utilisateurs" et non pas celui de la racine et rep2 à rep5 sont les
mêmes répertoires dans les 2 cas.


Qu'est-ce qui te fait dire que c'est ce sont ces deux fichiers qui ont
causé le problème ?

Patrick
--
Patrick Stadelmann
Wykaaa
Le #2511201
Patrick Stadelmann wrote:

In article Wykaaa

3) Je ne vois pas pourquoi il y a ?? derrière mon paragraphe sur
l'arborescence. Ce que j'explique est tout à fait clair :
rep1->rep2->rep3->rep4->rep5->fichier-toto
rep1->rep2->rep3->rep4->rep5->rep6->rep7->rep8->fichier-toto
rep1 était en fait mon répertoire "documents" dans l'arborescence
"Utilisateurs" et non pas celui de la racine et rep2 à rep5 sont les
mêmes répertoires dans les 2 cas.



Qu'est-ce qui te fait dire que c'est ce sont ces deux fichiers qui ont
causé le problème ?

Patrick


Parce que le message d'alerte m'a donné le nom du fichier et que j'ai
recherché où se trouvaient ces 2 fichiers de même nom dans
l'arborescence "Documents".

Wykaaa


kurtz le pirate
Le #2511181
In article Wykaaa
Patrick Stadelmann wrote:

In article Wykaaa

3) Je ne vois pas pourquoi il y a ?? derrière mon paragraphe sur
l'arborescence. Ce que j'explique est tout à fait clair :
rep1->rep2->rep3->rep4->rep5->fichier-toto
rep1->rep2->rep3->rep4->rep5->rep6->rep7->rep8->fichier-toto
rep1 était en fait mon répertoire "documents" dans l'arborescence
"Utilisateurs" et non pas celui de la racine et rep2 à rep5 sont les
mêmes répertoires dans les 2 cas.



Qu'est-ce qui te fait dire que c'est ce sont ces deux fichiers qui ont
causé le problème ?

Patrick


Parce que le message d'alerte m'a donné le nom du fichier et que j'ai
recherché où se trouvaient ces 2 fichiers de même nom dans
l'arborescence "Documents".

Wykaaa


donc ta clé est formaté dos (fat32) non ?


--
klp



Wykaaa
Le #2511171
kurtz le pirate wrote:

In article Wykaaa

Patrick Stadelmann wrote:


In article Wykaaa


3) Je ne vois pas pourquoi il y a ?? derrière mon paragraphe sur
l'arborescence. Ce que j'explique est tout à fait clair :
rep1->rep2->rep3->rep4->rep5->fichier-toto
rep1->rep2->rep3->rep4->rep5->rep6->rep7->rep8->fichier-toto
rep1 était en fait mon répertoire "documents" dans l'arborescence
"Utilisateurs" et non pas celui de la racine et rep2 à rep5 sont les
mêmes répertoires dans les 2 cas.



Qu'est-ce qui te fait dire que c'est ce sont ces deux fichiers qui ont
causé le problème ?

Patrick


Parce que le message d'alerte m'a donné le nom du fichier et que j'ai
recherché où se trouvaient ces 2 fichiers de même nom dans
l'arborescence "Documents".

Wykaaa



donc ta clé est formaté dos (fat32) non ?


Voici ce que me dit MAC OS X à propos de la clé :

Capacité : 1.92 Go
Disponible : 356.72 Mo
Inscriptible : Oui
Système de fichiers : MS-DOS FAT16

je ne souhaite pas la formater HFS+ car je veux pouvoir la lire aussi
sur PC (à cause du boulot...)

Wykaaa




mloiseauSANS-SPAM-LA-VIE-EST-PLUS-BELLE
Le #2511041
Wykaaa
Donc vas-y, explique.


Imaginons que ta clé soit formatée en FAT et que ce système de fichiers
ne permette de lire que quelques caractères de chaque nom de fichier ?
--
Ça c'est du blog destroy avec rien dans la tête, oui !

Publicité
Poster une réponse
Anonyme