Coup de main : lecture vidéo derrièrehtaccess

Le
voir_le_reply-to
Bonjour,

J'ai besoin d'un petit coup de main : je sais depuis longtemps comment
insérer une lecture vidéo html5 dans mes pages web, ça marche bien et
c'est rodé.

J'ai créé récemment un espace "privé" dans mon site, protégé par
htaccess, et quoi que je fasse, la lecture vidéo intégrée à la page
échoue : ça ne charge pas. Par défaut mon logiciel (RapidWeaver mais
c'est sans importance) place la vidéo en "ressource" dans un sous
dossier de la page protégée. J'ai tenté de déporter les vidéos dans un
dossier non protégé à la racine du site : idem. Le lecteur html apparaît
bien à sa place, mais au lieu de commencer à charger le fichier à
l'ouverture de la page il reste à l'arrêt. Un clic sur le bouton de
lecture ne l'active pas.

J'ai lu la nécessité de déclarer les types MIME dans un fichier
.htaccess. J'ai ajouté les "AddType à la suite dans LE fichier htaccess
qui protège la page sans que cela ne change rien. S'agit-il d'un "autre"
.htaccess ? placé où ?

C'est sûrement bête comme chou. Si quelqu'un sait, qu'il soit déjà
remercié par avance.

--
Gérald
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
pmn
Le #26324965
Le 24/11/2014 à 14:32,
(Gerald) a écrit :
Bonjour,

J'ai besoin d'un petit coup de main : je sais depuis longtemps comment
insérer une lecture vidéo html5 dans mes pages web, ça marche bien et
c'est rodé.

J'ai créé récemment un espace "privé" dans mon site, protégé par
htaccess, et quoi que je fasse, la lecture vidéo intégrée à la page
échoue : ça ne charge pas. Par défaut mon logiciel (RapidWeaver mais
c'est sans importance) place la vidéo en "ressource" dans un sous
dossier de la page protégée. J'ai tenté de déporter les vidéos dans un
dossier non protégé à la racine du site : idem. Le lecteur html apparaît
bien à sa place, mais au lieu de commencer à charger le fichier à
l'ouverture de la page il reste à l'arrêt. Un clic sur le bouton de
lecture ne l'active pas.

J'ai lu la nécessité de déclarer les types MIME dans un fichier
.htaccess. J'ai ajouté les "AddType à la suite dans LE fichier htaccess
qui protège la page sans que cela ne change rien. S'agit-il d'un "autre"
.htaccess ? placé où ?

C'est sûrement bête comme chou. Si quelqu'un sait, qu'il soit déjà
remercié par avance.




je ne vois que quelques possibilités, pas nombreuses :
la propriété de votre vidéo, si elle est sur votre site : 755 ou 777,
avez-vous vérifié cela ?
ou bien le code embed de votre page
si elle est ailleurs, sur un autre site, et auquel cas la vidéo pourrait
être protégée et inaccessible. Sinon, votre code js sur la page d'appel
serait mauvais sur l'appel de cette vidéo.
Ou bien, le poids de cette vidéo ne serait il pas trop important pour
votre site ? avez vous essayé avec une autre vidéo moins lourde?
apparemment, puisque vous connaissez, ce ne serait pas votre .htaccess...
mais avez vous essayé en mettant votre vidéo dans un dossier particulier
sans .htaccess, juste pour essai et juste pour essayer si vous aviez un
code propre sur votre page ?
voir_le_reply-to
Le #26324983
pmn
mais avez vous essayé en mettant votre vidéo dans un dossier particulier
sans .htaccess, juste pour essai et juste pour essayer si vous aviez un
code propre sur votre page ?



Oui et non : depuis j'ai créé une page "documents" qui, dans mon
logiciel de fabrication web, est de type "partage de fichiers" : qu'on
clique pour la visionner en ligne ou que ce soit pour la télécharger, il
est demandé d'abord une nouvelle identification, puis ça lit en ligne
(dans une page séparée) ou ça télécharge sans problème.

La question est donc bien de la protection du dossier source, qui ne
permet d'utilisation externe qu'après ré-identification (pénible).

Si j'ai bien compris la logique du .htaccess, je devrais pouvoir
contredire les instructions de niveau 1 en mettant un autre fichier
.htaccess dans le dossier de niveau 2 contenant les vidéos (il s'appelle
"resources", mais je patauge dans la syntaxe :

Mettre simplement :
AuthType None
dedans ? (ça paraît trop simple !)

Sinon :
AuthType Basic
Allow from all

Encore merci dans tous les cas.

--
Gérald
Publicité
Poster une réponse
Anonyme