crash libxml

Le
pes
Bonjour,

j' ai une application (Xilinx Platform Studio) qui crashe brutalement
sous Mandriva 2010 32bits.

$dmesg me donne cette erreur :

xpsgui[16290]: segfault at 5 ip b6168465 sp bf9a1500 error 4 in
libxml2.so.2.7.6[b60f6000+13a000]


je ne comprends pas d' où vient le problème et j' aimerais essayer une
version plus récente de libxml par exemple. Je ne sais pas où trouver
cette nouvelle librairie, dans cooker? a quel endroit?

Toute aide est la bienvenue pour m' aider à résoudre mon problème de crash.

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #21259921
pes wrote in message
xpsgui[16290]: segfault at 5 ip b6168465 sp bf9a1500 error 4 in
libxml2.so.2.7.6[b60f6000+13a000]

je ne comprends pas d' où vient le problème et j' aimerais essayer une
version plus récente de libxml par exemple. Je ne sais pas où trouver
cette nouvelle librairie, dans cooker? a quel endroit?



récente avec un bon « git clone git://git.gnome.org/libxml2 ».

Note qu'une segfault ne se manifeste pas forcément à l'endroit qui a causé
le problème, la libxml2 est peut-être totalement innocente.
pes
Le #21265341
Nicolas George wrote:
pes wrote in message
xpsgui[16290]: segfault at 5 ip b6168465 sp bf9a1500 error 4 in
libxml2.so.2.7.6[b60f6000+13a000]

je ne comprends pas d' où vient le problème et j' aimerais essayer une
version plus récente de libxml par exemple. Je ne sais pas où trouver
cette nouvelle librairie, dans cooker? a quel endroit?



récente avec un bon « git clone git://git.gnome.org/libxml2 ».




Je n' ai pas su compilé la version en cours, il n' y a pas de script de
configuration ni de Makefile dans le dossier.
J' ai par contre pu installer une version plus ancienne (2.7.2) sans
plus de succés.



Note qu'une segfault ne se manifeste pas forcément à l'endroit qui a causé
le problème, la libxml2 est peut-être totalement innocente.




Je vais creuser par là.
Nicolas George
Le #21265441
pes wrote in message
Je n' ai pas su compilé la version en cours, il n' y a pas de script de
configuration ni de Makefile dans le dossier.



Il y a autogen.sh.
pes
Le #21266541
Nicolas George wrote:
pes wrote in message
Je n' ai pas su compilé la version en cours, il n' y a pas de script de
configuration ni de Makefile dans le dossier.



Il y a autogen.sh.



ok. Probablement que ça ne vient pas de libxml
Publicité
Poster une réponse
Anonyme