Créer des cellules à partir d'une liste déroulante

Le
Greg
Bonjour,

J'ai créé une liste déroulante en A1 qui fait référence aux noms de champ
(ligne 1) d'une base de données (feuille "baseDD).

Ce que je souhaite, c'est pouvoir coller automatiquement dans la colonne A,
à partir de A2, l'ensemble des cellules de la base qui correpondent à ce
champ. Petite difficulté supplémentaire: la cellule A3 est "occupée". Il
faudra donc coller en A2, quitte à ce que le contenu de A3 se retrouve en
A20 s'il y a 18 cellules pour ce champ.

Est-ce possible?

Voici un fichier pour être plus explicite: http://cjoint.com/?kon6wrLZvO

Merci pour vos lumières.

Greg
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Corona
Le #20350971
Bonsoir Greg,
En reprenant ton classeur
par exemple en cellule 'H1' de la feuille 'Feuil2'
=NBVAL(INDIRECT(ADRESSE(1;EQUIV($A$1;champ;0);;;"baseDD")
&":"&ADRESSE(65536;EQUIV($A$1;champ;0))))-1
Dans la même feuille
dans les cellules A1:An :
=SI(LIGNE()-2<$H$1;DECALER(BASEDD!$A$1;LIGNE()-1; EQUIV($A$1;champ;0)-1
);SI(LIGNE()-2=$H$1;"NE PAS TOUCHER - Cette cellule doit descendre en
fonction des items collés";""))

Il y a peut-être plus simple
Le lien ici http://cjoint.com/?kosXVScoVq

Philippe Tulliez

Greg a écrit :
Bonjour,

J'ai créé une liste déroulante en A1 qui fait référence aux noms de
champ (ligne 1) d'une base de données (feuille "baseDD).

Ce que je souhaite, c'est pouvoir coller automatiquement dans la colonne
A, à partir de A2, l'ensemble des cellules de la base qui correpondent à
ce champ. Petite difficulté supplémentaire: la cellule A3 est "occupée".
Il faudra donc coller en A2, quitte à ce que le contenu de A3 se
retrouve en A20 s'il y a 18 cellules pour ce champ.

Est-ce possible?

Voici un fichier pour être plus explicite: http://cjoint.com/?kon6wrLZvO

Merci pour vos lumières.

Greg


Greg
Le #20422391
Merci Philippe et désolé pour ma réponse un peu tardive.

Le fichier en pièce jointe correspond exactement à mon attente. Seulement,
je n'arrive pas à l'adapter à mon classeur.

Voici la partie que je n'arrive pas à mettre en place:

Dans la même feuille dans les cellules A1:An :
=SI(LIGNE()-2<$H$1;DECALER(BASEDD!$A$1;LIGNE()-1;
EQUIV($A$1;champ;0)-1);SI(LIGNE()-2=$H$1;"NE PAS TOUCHER - Cette cellule
doit descendre en fonction des items collés";""))

Je ne vois pas ce que je dois faire. Quelqu'un pourrait-il m'aiguiller, pas
à pas, en sachant que je suis sous excel 2007?

Merci

Greg




"Corona" news:
Bonsoir Greg,
En reprenant ton classeur
par exemple en cellule 'H1' de la feuille 'Feuil2'
=NBVAL(INDIRECT(ADRESSE(1;EQUIV($A$1;champ;0);;;"baseDD")
&":"&ADRESSE(65536;EQUIV($A$1;champ;0))))-1
Dans la même feuille
dans les cellules A1:An :
=SI(LIGNE()-2<$H$1;DECALER(BASEDD!$A$1;LIGNE()-1;
EQUIV($A$1;champ;0)-1 );SI(LIGNE()-2=$H$1;"NE PAS TOUCHER - Cette cellule
doit descendre en fonction des items collés";""))

Il y a peut-être plus simple
Le lien ici http://cjoint.com/?kosXVScoVq
Philippe Tulliez

Greg a écrit :
Bonjour,

J'ai créé une liste déroulante en A1 qui fait référence aux noms de champ
(ligne 1) d'une base de données (feuille "baseDD).

Ce que je souhaite, c'est pouvoir coller automatiquement dans la colonne
A, à partir de A2, l'ensemble des cellules de la base qui correpondent à
ce champ. Petite difficulté supplémentaire: la cellule A3 est "occupée".
Il faudra donc coller en A2, quitte à ce que le contenu de A3 se retrouve
en A20 s'il y a 18 cellules pour ce champ.

Est-ce possible?

Voici un fichier pour être plus explicite: http://cjoint.com/?kon6wrLZvO

Merci pour vos lumières.

Greg




Greg
Le #20424331
Bonjour et Re-merci....

J'ai enfin réussi à adapter les formules...

à bientôt

Greg

"Greg" news:
Merci Philippe et désolé pour ma réponse un peu tardive.

Le fichier en pièce jointe correspond exactement à mon attente. Seulement,
je n'arrive pas à l'adapter à mon classeur.

Voici la partie que je n'arrive pas à mettre en place:

Dans la même feuille dans les cellules A1:An :
=SI(LIGNE()-2<$H$1;DECALER(BASEDD!$A$1;LIGNE()-1;
EQUIV($A$1;champ;0)-1);SI(LIGNE()-2=$H$1;"NE PAS TOUCHER - Cette cellule
doit descendre en fonction des items collés";""))

Je ne vois pas ce que je dois faire. Quelqu'un pourrait-il m'aiguiller,
pas à pas, en sachant que je suis sous excel 2007?

Merci

Greg




"Corona" news:
Bonsoir Greg,
En reprenant ton classeur
par exemple en cellule 'H1' de la feuille 'Feuil2'
=NBVAL(INDIRECT(ADRESSE(1;EQUIV($A$1;champ;0);;;"baseDD")
&":"&ADRESSE(65536;EQUIV($A$1;champ;0))))-1
Dans la même feuille
dans les cellules A1:An :
=SI(LIGNE()-2<$H$1;DECALER(BASEDD!$A$1;LIGNE()-1;
EQUIV($A$1;champ;0)-1 );SI(LIGNE()-2=$H$1;"NE PAS TOUCHER - Cette cellule
doit descendre en fonction des items collés";""))

Il y a peut-être plus simple
Le lien ici http://cjoint.com/?kosXVScoVq
Philippe Tulliez

Greg a écrit :
Bonjour,

J'ai créé une liste déroulante en A1 qui fait référence aux noms de
champ (ligne 1) d'une base de données (feuille "baseDD).

Ce que je souhaite, c'est pouvoir coller automatiquement dans la colonne
A, à partir de A2, l'ensemble des cellules de la base qui correpondent à
ce champ. Petite difficulté supplémentaire: la cellule A3 est "occupée".
Il faudra donc coller en A2, quitte à ce que le contenu de A3 se
retrouve en A20 s'il y a 18 cellules pour ce champ.

Est-ce possible?

Voici un fichier pour être plus explicite: http://cjoint.com/?kon6wrLZvO

Merci pour vos lumières.

Greg







Publicité
Poster une réponse
Anonyme