cumul dans un tableau de certaines occurences

Le
Nick
Bonjour

Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains libelles.
Je voudrais faire apparaitre dans une case le nom du libellé, et dans la
case juste à droite le cumul du tableau correspondant à ce libellé (sans
passer par un tableau croisé).

Par avance , merci

Nico
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Modeste
Le #5329581
Bonsour® Nick avec ferveur ;o))) vous nous disiez :
Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains
libelles. Je voudrais faire apparaitre dans une case le nom du
libellé, et dans la case juste à droite le cumul du tableau
correspondant à ce libellé (sans passer par un tableau croisé).


=SOMMEPROD(C1:Cx*(B1:Bx="Cellulelibellé"))

--
--
@+
;o)))

Jacky
Le #5329571
Bonjour,

Je voudrais faire apparaitre dans une case le nom du libellé,
Données/validation


Autoriser=liste
Source=Libelle
et:
=SOMME.SI(Libelle;E2;montant)
voir ici:
http://cjoint.com/?dzmUAu6ljv

--
Salutations
JJ


"Modeste" %
Bonsour® Nick avec ferveur ;o))) vous nous disiez :
Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains
libelles. Je voudrais faire apparaitre dans une case le nom du
libellé, et dans la case juste à droite le cumul du tableau
correspondant à ce libellé (sans passer par un tableau croisé).


=SOMMEPROD(C1:Cx*(B1:Bx="Cellulelibellé"))

--
--
@+
;o)))





Christian
Le #5329551
On 25 mar, 12:04, "Nick"
Bonjour

Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puis je faire pour faire le cumul pour certains libelles .
Je voudrais faire apparaitre dans une case le nom du libellé, et dans la
case juste à droite le cumul du tableau correspondant à ce libellé ( sans
passer par un tableau croisé).

Par avance , merci

Nico


Bonjour,

Pour corriger modeste:

=SOMMEPROD((B1:Bx="libellé")*(C1:Cx)) et valider simplement par
[Entrée]

Cette formule fait la somme des valeurs de C... de tous les
B...="libellé"
1er phase: top "vrai" ou "faux" les cellules de B
2ème phase: somme le valeurs de C si B lui correspondant (même ligne)
est vrai.
en fait, 1 TCD en formule, personnellement je n'utilise que ça, bien
plus léger qu'un TCD.
Particularité: il ne faut aucune erreur dans les colonnes de la base
autrement utiliser "SI(ESTERREUR(....))

Cdlt

Christian

Christian
Le #5329541
On 25 mar, 12:04, "Nick"
Bonjour

Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains libelles.
Je voudrais faire apparaitre dans une case le nom du libellé, et dans la
case juste à droite le cumul du tableau correspondant à ce libellé ( sans
passer par un tableau croisé).

Par avance , merci

Nico


Bonjour,

Pour corriger modeste:

=SOMMEPROD((B1:Bx="libellé")*(C1:Cx)) et valider simplement par
[Entrée]

Cette formule fait la somme des valeurs de C... de tous les
B...="libellé"
1er phase: top "vrai" ou "faux" les cellules de B
2ème phase: somme le valeurs de C si B lui correspondant (même ligne)
est vrai.
en fait, 1 TCD en formule, personnellement je n'utilise que ça, bien
plus léger qu'un TCD.
Le SOMMEPROD est très bien dès que le nombre de champ est supérieur à
2, sinon utiliser le SOMME.SI pour 2 champs comme dans ton exemple.
Particularité de SOMMEPROD: il ne faut aucune erreur dans les colonnes
de la base autrement utiliser "SI(ESTERREUR(....))

Cdlt

Christian

Jacky
Le #5329531
Oupss!
Erreur d'aiguillage
Désolé, Modeste.

--
Salutations
JJ


"Jacky"
Bonjour,

Je voudrais faire apparaitre dans une case le nom du libellé,
Données/validation


Autoriser=liste
Source=Libelle
et:
=SOMME.SI(Libelle;E2;montant)
voir ici:
http://cjoint.com/?dzmUAu6ljv

--
Salutations
JJ


"Modeste" %
Bonsour® Nick avec ferveur ;o))) vous nous disiez :
Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains
libelles. Je voudrais faire apparaitre dans une case le nom du
libellé, et dans la case juste à droite le cumul du tableau
correspondant à ce libellé (sans passer par un tableau croisé).


=SOMMEPROD(C1:Cx*(B1:Bx="Cellulelibellé"))

--
--
@+
;o)))









JB
Le #5329341
Bonjour,

http://cjoint.com/?dzq11hxW64

JB
http://boisgontierjacques.free.fr/


On 25 mar, 12:04, "Nick"
Bonjour

Soit un tableau contenant en colonne B un libellé, et en colonne C un
chiffre , comment puisje faire pour faire le cumul pour certains libelles.
Je voudrais faire apparaitre dans une case le nom du libellé, et dans la
case juste à droite le cumul du tableau correspondant à ce libellé ( sans
passer par un tableau croisé).

Par avance , merci

Nico


nick
Le #5328351
Grand merci pour vos aides respectives. Est-ce qu'on peut poser aussi une
condition à l'addition des libelles (a savoir : libelle contient les lettres
xxx ou yyy) ?
Merci
Nick
Publicité
Poster une réponse
Anonyme